Loading ...
Sorry, an error occurred while loading the content.

Cherokee : 405 Method Not Allowed

Expand Messages
  • Daniel Berenguer
    I ve installed cherokee + pfp + php-fcgi on my OpenSlug (from optware packages). PHP seems to work fine (I ve just completed some initial tests) but simple
    Message 1 of 2 , Jul 22, 2007
    • 0 Attachment
      I've installed cherokee + pfp + php-fcgi on my OpenSlug (from optware
      packages).

      PHP seems to work fine (I've just completed some initial tests) but
      simple html pages are not working at all. I get this error when I want
      to open index.html:

      405 Method Not Allowed

      My index.html:

      <html>
      <head>
      <title>Test page</title>
      </head>
      <body>
      <br>This is my first test<br>
      </body>
      </html>

      and this is my cherokee.conf file:

      Port 8082
      IPv6 Off
      Timeout 60
      KeepAlive On
      MaxKeepAliveRequests 500
      ServerTokens Full
      PidFile /var/tmp/cherokee.pid
      Icons /opt/etc/cherokee/icons.conf
      MimeFile /opt/etc/cherokee/mime.types
      MimeFile /opt/etc/cherokee/mime.compression.types
      Include /opt/etc/cherokee/advanced.conf
      Include /opt/etc/cherokee/mods-enabled
      Documentroot /home/root/www
      DirectoryIndex index.html
      Extension php, php3, php4, php5 {
      Handler fcgi {
      Server localhost:8002 {
      Env PHP_FCGI_MAX_REQUESTS "4000"
      Env PHP_FCGI_CHILDREN "4"
      Interpreter "/opt/bin/php-fcgi -b 8002"
      }
      }
      }

      Documentroot is correctly pointing to the server root and mime.types
      contains the html type so ... I don't know where the problem could be...

      Any idea out there?

      Thanks,

      Daniel.
    • fatmcgav
      I m gettin the same issue as below... Any ideas? Dan - did you find out what caused it? Cheers Fatmcgav ... -- View this message in context:
      Message 2 of 2 , Sep 11 6:48 AM
      • 0 Attachment
        I'm gettin the same issue as below...

        Any ideas? Dan - did you find out what caused it?

        Cheers
        Fatmcgav


        Daniel Berenguer-2 wrote:
        >
        > I've installed cherokee + pfp + php-fcgi on my OpenSlug (from optware
        > packages).
        >
        > PHP seems to work fine (I've just completed some initial tests) but
        > simple html pages are not working at all. I get this error when I want
        > to open index.html:
        >
        > 405 Method Not Allowed
        >
        > My index.html:
        >
        > <html>
        > <head>
        > <title>Test page</title>
        > </head>
        > <body>
        > <br>This is my first test<br>
        > </body>
        > </html>
        >
        > and this is my cherokee.conf file:
        >
        > Port 8082
        > IPv6 Off
        > Timeout 60
        > KeepAlive On
        > MaxKeepAliveRequests 500
        > ServerTokens Full
        > PidFile /var/tmp/cherokee.pid
        > Icons /opt/etc/cherokee/icons.conf
        > MimeFile /opt/etc/cherokee/mime.types
        > MimeFile /opt/etc/cherokee/mime.compression.types
        > Include /opt/etc/cherokee/advanced.conf
        > Include /opt/etc/cherokee/mods-enabled
        > Documentroot /home/root/www
        > DirectoryIndex index.html
        > Extension php, php3, php4, php5 {
        > Handler fcgi {
        > Server localhost:8002 {
        > Env PHP_FCGI_MAX_REQUESTS "4000"
        > Env PHP_FCGI_CHILDREN "4"
        > Interpreter "/opt/bin/php-fcgi -b 8002"
        > }
        > }
        > }
        >
        > Documentroot is correctly pointing to the server root and mime.types
        > contains the html type so ... I don't know where the problem could be...
        >
        > Any idea out there?
        >
        > Thanks,
        >
        > Daniel.
        >

        --
        View this message in context: http://www.nabble.com/Cherokee-%3A-405-Method-Not-Allowed-tf4126079.html#a12615187
        Sent from the Nslu2 - General mailing list archive at Nabble.com.
      Your message has been successfully submitted and would be delivered to recipients shortly.