Loading ...
Sorry, an error occurred while loading the content.

openssh error

Expand Messages
  • jonneymendoza
    Hi, i am having trouble installing openssh so that i can access my nslu2 remotely. i have installed openssh by doing this. ipkg update ipkg install openssh the
    Message 1 of 6 , Jul 19, 2007
    View Source
    • 0 Attachment
      Hi, i am having trouble installing openssh so that i can access my nslu2
      remotely.

      i have installed openssh by doing this.

      ipkg update
      ipkg install openssh

      the outcome is:

      Installing openssh (4.5p1-1) to root...
      Downloading
      http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/openssh_4.5p1-1_armeb.ipk
      ipkg: extract_archive: /opt/etc/init.d/: File exists
      ipkg: /opt/etc/init.d/S40sshd: Not a directory
      file_md5sum_alloc: Failed to open file /opt/etc/init.d/S40sshd: Not a
      directory
      Configuring cron
      Remember that the system crontab file is "/opt/etc/crontab".
      //usr/lib/ipkg/info/cron.postinst: /opt/etc/init.d/S10cron: Not a directory
      postinst script returned status 2
      ERROR: cron.postinst returned 2
      Configuring openssh

      Fixing permissions on the /tmp directory...
      //usr/lib/ipkg/info/openssh.postinst: /opt/etc/init.d/S40sshd: Not a
      directory
      postinst script returned status 2
      ERROR: openssh.postinst returned 2
      Configuring xinetd
      Note that telnetd is enabled by default. Edit /opt/etc/xinetd.d/telnetd
      and set 'disable=yes' to disable telnet AFTER making sure that Dropbear
      or other means of logging onto your system are enabled and working.

      Note that only 192.168.1.0/24 has access in the default configuration
      //usr/lib/ipkg/info/xinetd.postinst: /opt/etc/init.d/S10xinetd: Not a
      directory
      postinst script returned status 2
      ERROR: xinetd.postinst returned 2


      why do it get this error?

      Because of this error openssh seems to not be running properly

      i did ps -ef to see if i find a line of ( 1735 root 3208 R
      /opt/sbin/sshd)

      But i dont. instead i get a load of other information that i dont
      understand.



      PID TTY Uid Size State Command
      1 root 1212 S /bin/init
      2 root 0 S [keventd]
      3 root 0 S [ksoftirqd_CPU0]
      4 root 0 S [kswapd]
      5 root 0 S [bdflush]
      6 root 0 S [kupdated]
      7 root 0 S [mtdblockd]
      8 root 0 S [khubd]
      9 root 0 S [jffs2_gcd_mtd4]
      16 root 0 S [usb-storage-0]
      17 root 0 S [scsi_eh_0]
      18 root 0 S [sd-mc-thread]
      19 root 0 S [usb-storage-1]
      20 root 0 S [scsi_eh_1]
      29 root 0 S [kjournald]
      52 root 0 D [ixp425_csr]
      53 root 0 S [ixp425 ixp0]
      56 ttyS0 root 1916 S /bin/sh
      57 root 1936 S /sbin/syslogd -n
      58 root 1924 S /sbin/klogd -n
      149 root 0 S [kjournald]
      215 root 10948 S upnpd &>/dev/null
      223 root 10948 S upnpd &>/dev/null
      224 root 10948 S upnpd &>/dev/null
      228 root 10948 S upnpd &>/dev/null
      229 root 10948 S upnpd &>/dev/null
      325 root 2144 S /usr/sbin/thttpd -C /etc/thttpd.conf
      349 root 6172 S /usr/sbin/smbd -D
      351 root 4824 S /usr/sbin/nmbd -D
      366 root 6172 S /usr/sbin/smbd -D
      376 root 1952 S /usr/sbin/QuickSet
      381 root 1904 S /usr/sbin/USB_Detect
      385 root 1900 S /usr/sbin/USB_Detect
      389 root 1884 S /usr/sbin/onetouch_detect
      392 root 1884 S /usr/sbin/onetouch_detect
      406 root 1296 S /usr/sbin/crond
      412 root 1928 S /usr/sbin/CheckResetButton
      414 root 1196 S /usr/sbin/CheckPowerButton
      416 root 1196 S /usr/sbin/do_umount
      1383 root 10948 S upnpd &>/dev/null
      1427 root 2144 S /usr/sbin/thttpd -C /etc/thttpd.conf
      1441 root 1276 S /bin/inetd
      1447 root 1256 S /usr/sbin/telnetd
      1448 ttyp0 root 1928 S -sh
      1486 ttyp0 root 1984 R ps -ef



      I am fairly new to Linux but i am slowing learning. Hope someone can help me
      get openSSH working on my nslu2, thanks



      --
      View this message in context: http://www.nabble.com/openssh-error-tf4113016.html#a11695481
      Sent from the Nslu2 - General mailing list archive at Nabble.com.
    • Rod Whitby
      Looks like some application has installed a file as /opt/etc/init.d instead of making sure it created that as a directory first and then installed the file in
      Message 2 of 6 , Jul 19, 2007
      View Source
      • 0 Attachment
        Looks like some application has installed a file as /opt/etc/init.d
        instead of making sure it created that as a directory first and then
        installed the file in the directory.

        First thing to do is to look in the /opt/etc/init.d file and tell us
        what is in it. pastebin.ca is a good place to do that - just send us
        the link.

        Then delete that file, and create a directory of the same name. Then
        openssh should install.

        But don't forget the first step of telling us what's in the file,
        otherwise we won't be able to fix the root cause.

        -- Rod

        jonneymendoza wrote:
        > Hi, i am having trouble installing openssh so that i can access my nslu2
        > remotely.
        >
        > i have installed openssh by doing this.
        >
        > ipkg update
        > ipkg install openssh
        >
        > the outcome is:
        >
        > Installing openssh (4.5p1-1) to root...
        > Downloading
        > http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/openssh_4.5p1-1_armeb.ipk
        > ipkg: extract_archive: /opt/etc/init.d/: File exists
        > ipkg: /opt/etc/init.d/S40sshd: Not a directory
        > file_md5sum_alloc: Failed to open file /opt/etc/init.d/S40sshd: Not a
        > directory
        > Configuring cron
        > Remember that the system crontab file is "/opt/etc/crontab".
        > //usr/lib/ipkg/info/cron.postinst: /opt/etc/init.d/S10cron: Not a directory
        > postinst script returned status 2
        > ERROR: cron.postinst returned 2
        > Configuring openssh
        >
        > Fixing permissions on the /tmp directory...
        > //usr/lib/ipkg/info/openssh.postinst: /opt/etc/init.d/S40sshd: Not a
        > directory
        > postinst script returned status 2
        > ERROR: openssh.postinst returned 2
        > Configuring xinetd
        > Note that telnetd is enabled by default. Edit /opt/etc/xinetd.d/telnetd
        > and set 'disable=yes' to disable telnet AFTER making sure that Dropbear
        > or other means of logging onto your system are enabled and working.
        >
        > Note that only 192.168.1.0/24 has access in the default configuration
        > //usr/lib/ipkg/info/xinetd.postinst: /opt/etc/init.d/S10xinetd: Not a
        > directory
        > postinst script returned status 2
        > ERROR: xinetd.postinst returned 2
        >
        >
        > why do it get this error?
        >
        > Because of this error openssh seems to not be running properly
        >
        > i did ps -ef to see if i find a line of ( 1735 root 3208 R
        > /opt/sbin/sshd)
        >
        > But i dont. instead i get a load of other information that i dont
        > understand.
        >
        >
        >
        > PID TTY Uid Size State Command
        > 1 root 1212 S /bin/init
        > 2 root 0 S [keventd]
        > 3 root 0 S [ksoftirqd_CPU0]
        > 4 root 0 S [kswapd]
        > 5 root 0 S [bdflush]
        > 6 root 0 S [kupdated]
        > 7 root 0 S [mtdblockd]
        > 8 root 0 S [khubd]
        > 9 root 0 S [jffs2_gcd_mtd4]
        > 16 root 0 S [usb-storage-0]
        > 17 root 0 S [scsi_eh_0]
        > 18 root 0 S [sd-mc-thread]
        > 19 root 0 S [usb-storage-1]
        > 20 root 0 S [scsi_eh_1]
        > 29 root 0 S [kjournald]
        > 52 root 0 D [ixp425_csr]
        > 53 root 0 S [ixp425 ixp0]
        > 56 ttyS0 root 1916 S /bin/sh
        > 57 root 1936 S /sbin/syslogd -n
        > 58 root 1924 S /sbin/klogd -n
        > 149 root 0 S [kjournald]
        > 215 root 10948 S upnpd &>/dev/null
        > 223 root 10948 S upnpd &>/dev/null
        > 224 root 10948 S upnpd &>/dev/null
        > 228 root 10948 S upnpd &>/dev/null
        > 229 root 10948 S upnpd &>/dev/null
        > 325 root 2144 S /usr/sbin/thttpd -C /etc/thttpd.conf
        > 349 root 6172 S /usr/sbin/smbd -D
        > 351 root 4824 S /usr/sbin/nmbd -D
        > 366 root 6172 S /usr/sbin/smbd -D
        > 376 root 1952 S /usr/sbin/QuickSet
        > 381 root 1904 S /usr/sbin/USB_Detect
        > 385 root 1900 S /usr/sbin/USB_Detect
        > 389 root 1884 S /usr/sbin/onetouch_detect
        > 392 root 1884 S /usr/sbin/onetouch_detect
        > 406 root 1296 S /usr/sbin/crond
        > 412 root 1928 S /usr/sbin/CheckResetButton
        > 414 root 1196 S /usr/sbin/CheckPowerButton
        > 416 root 1196 S /usr/sbin/do_umount
        > 1383 root 10948 S upnpd &>/dev/null
        > 1427 root 2144 S /usr/sbin/thttpd -C /etc/thttpd.conf
        > 1441 root 1276 S /bin/inetd
        > 1447 root 1256 S /usr/sbin/telnetd
        > 1448 ttyp0 root 1928 S -sh
        > 1486 ttyp0 root 1984 R ps -ef
        >
        >
        > Edit: i noticed that when i try to install other packages it wont let me
        > now. here is what hapens when i install vsftpd
        >
        > ipkg install vsftpd
        > Installing vsftpd (2.0.5-1) to root...
        > Downloading
        > http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/vsftpd_2.0.5-1_armeb.ipk
        > Configuring cron
        > Remember that the system crontab file is "/opt/etc/crontab".
        > //usr/lib/ipkg/info/cron.postinst: /opt/etc/init.d/S10cron: Not a directory
        > postinst script returned status 2
        > ERROR: cron.postinst returned 2
        > Configuring openssh
        >
        > Fixing permissions on the /tmp directory...
        > //usr/lib/ipkg/info/openssh.postinst: /opt/etc/init.d/S40sshd: Not a
        > directory
        > postinst script returned status 2
        > ERROR: openssh.postinst returned 2
        > Configuring vsftpd
        > You'll need to add line like
        > echo "ftp stream tcp nowait root /opt/sbin/vsftpd /opt/etc/vsftpd.conf"
        >>> /etc/inetd.conf
        > to your /unslung/rc.xinetd file -- see the wiki at
        > http://www.nslu2-linux.org for more info
        > Configuring xinetd
        > Note that telnetd is enabled by default. Edit /opt/etc/xinetd.d/telnetd
        > and set 'disable=yes' to disable telnet AFTER making sure that Dropbear
        > or other means of logging onto your system are enabled and working.
        >
        > Note that only 192.168.1.0/24 has access in the default configuration
        > //usr/lib/ipkg/info/xinetd.postinst: /opt/etc/init.d/S10xinetd: Not a
        > directory
        > postinst script returned status 2
        > ERROR: xinetd.postinst returned 2
        >
        >
        >
        > I am fairly new to Linux but i am slowing learning. Hope someone can help me
        > get openSSH working on my nslu2, thanks
        >
        >
        >
      • jonneymendoza
        herr we go. here is the file located here http://pastebin.ca/627247 thanks -- View this message in context:
        Message 3 of 6 , Jul 19, 2007
        View Source
        • 0 Attachment
          herr we go. here is the file located here http://pastebin.ca/627247 thanks
          --
          View this message in context: http://www.nabble.com/openssh-error-tf4113016.html#a11702599
          Sent from the Nslu2 - General mailing list archive at Nabble.com.
        • Rod Whitby
          ... OK, I think I ve tracked down what has happened. You ve installed cups previously, right? And you read the cups-install.doc info to do so? And that
          Message 4 of 6 , Jul 20, 2007
          View Source
          • 0 Attachment
            jonneymendoza wrote:
            > herr we go. here is the file located here http://pastebin.ca/627247 thanks

            OK, I think I've tracked down what has happened.

            You've installed cups previously, right?

            And you read the cups-install.doc info to do so?

            And that document says:

            "
            - If wanting to run lpd as standalone server (not recommended), copy
            /opt/doc/cups/S89lpd to /opt/etc/init.d
            "

            And you said "cp /opt/doc/cups/S89lpd /opt/etc/init.d" without doing a
            "mkdir /opt/etc/init.d" first.

            I've updated the doco so others don't fall into the same trap. We
            continually forget that a lot of people installing Optware packages
            won't recognise that /opt/etc/init.d should be a directory, so they
            shouldn't copy files without making sure the directory exists first.

            -- Rod
          • jonneymendoza
            Ahh yes i installed cups previously. shall i delete cups and openshell and start again by installing openssh first and then cups? ... -- View this message in
            Message 5 of 6 , Jul 20, 2007
            View Source
            • 0 Attachment
              Ahh yes i installed cups previously. shall i delete cups and openshell and
              start again by installing openssh first and then cups?

              Rod Whitby-2 wrote:
              >
              > jonneymendoza wrote:
              >> herr we go. here is the file located here http://pastebin.ca/627247
              >> thanks
              >
              > OK, I think I've tracked down what has happened.
              >
              > You've installed cups previously, right?
              >
              > And you read the cups-install.doc info to do so?
              >
              > And that document says:
              >
              > "
              > - If wanting to run lpd as standalone server (not recommended), copy
              > /opt/doc/cups/S89lpd to /opt/etc/init.d
              > "
              >
              > And you said "cp /opt/doc/cups/S89lpd /opt/etc/init.d" without doing a
              > "mkdir /opt/etc/init.d" first.
              >
              > I've updated the doco so others don't fall into the same trap. We
              > continually forget that a lot of people installing Optware packages
              > won't recognise that /opt/etc/init.d should be a directory, so they
              > shouldn't copy files without making sure the directory exists first.
              >
              > -- Rod
              >
              >

              --
              View this message in context: http://www.nabble.com/openssh-error-tf4113016.html#a11707504
              Sent from the Nslu2 - General mailing list archive at Nabble.com.
            Your message has been successfully submitted and would be delivered to recipients shortly.