Loading ...
Sorry, an error occurred while loading the content.

Re: Virtual Hosting with THTTPD problems

Expand Messages
  • bty597733
    SIles, thanks for the info, but logging in via ssh everytime I want to see a different web site seems a complete pain to me. Thi is fustrations as I;d got
    Message 1 of 6 , Jul 1, 2007
    View Source
    • 0 Attachment
      SIles, thanks for the info, but logging in via ssh everytime I want
      to see a different web site seems a complete pain to me.

      Thi is fustrations as I;d got dyndns set up with 2 domain name that
      point to my router, which in turn forwarded port 80 to my slug, and
      the virtual hosting was pointing my my html files for my new site
      (on one domain), and a to the existing web admin page on another.

      I can't get the linksys page to see any of my data while virtual
      hosting is switched on, but I have found a way round the problem...

      I've switched off virtual hosting and gone back to the original
      setup. I've create a new index.html file in the /home/httpd/html
      directory for my home page. Your browser will go to index.html
      before trying index.cgi (which is what the linksys page uses).
      Thesefore I go to my web site, and just need to type /index.cgi to
      access the linksys page (or provide a link on my site to this). It
      means I can;t have multiple sites as possible under vistual hosting,
      but at leat I can have a web site plus full usability of the linksys
      pages.

      To ensure I don't screw anything up with the linksys pages I've only
      created index.html in the /html directory, and put everything else
      my site references in a new /content sub-directory. The only thing
      you need to do to ensure your new pages work is to chmod 775 them
      after copying them to the slug.

      By if anyone can access the data on your disk using virtual hosts
      I'd be very interested.

      With thanks, Jase.

      --- In nslu2-general@yahoogroups.com, Siles <siles.bazerman@...>
      wrote:
      >
      > bty597733 wrote:
      > > Following the instructions at http://www.nslu2-
      > > linux.org/wiki/HowTo/VirtualHostingWithTHTTPD I have added a
      managed
      > > to host a web site on my slug. However; I now can't access my
      web
      > > admin page.
      > >
      > > I followed the instructions and set up the vhosts directory and
      > > user, followed all of the instructions to create a directory for
      my
      > > domain name, and set-up a test web site. I modified my
      thttpd.conf
      > > file as directed, and now when I go to my url (externally), my
      > > router forwards port 80 to my slug and I get my new page.
      However,
      > > if I try to access the linksys admin page (using /login.cgi
      > > or /sharename) I get the following message:
      > >
      > > The requested URL `%.80s' resolves to a file outside the
      permitted
      > > web server directory tree.
      > >
      > > I can access the linksys web page from my network, but when ever
      I
      > > login to my data, I don't see any information!
      > >
      > > For some reasons my thttpd can no longer see my data etc. Has
      any
      > > one else had this problem? Any ideas what it can be? Use the web
      > > page daily to access my data remotely so any advice is really
      > > appreciated.
      > >
      > > With thanks, Jase.
      > >
      > >
      > >
      > >
      > Hi Jase,
      >
      > I have had the same problem, not only using the vhosts but with the
      > others suggested in the "how to's".
      > What I did was to have two lines in thttpd.conf. One points to
      > /www/httpd/html and the other to /home/httpd/html. I comment out
      the
      > approptiate line and when I need to get into the admin pages I SSH
      in
      > and edit then reboot the slug. Not elegant but works.
      >
      > Complicating this is my ISP blocking port 80 and needing to port
      forward
      > to 8080. Of course they will kindly unblock 80 for $116 a month as
      a
      > commercial account. I also have had a problem with creating a new
      user
      > as outlined in the "how to" articles. Every time my web site is
      reached
      > a login password is requested. Never did find a workarounf fot
      that, so
      > I put my /www directory in ADMIN 2.
      >
      > BTW my website is running on an 8GB Sony flash drive as Disk 2 and
      a 4GB
      > Memorex flash drive. Very lowpower and completely silent.
      >
      > Siles
      >
    • Peter Richard
      Are you trying this with two copies of thttpd running as described at http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver ? By using the second copy
      Message 2 of 6 , Jul 1, 2007
      View Source
      • 0 Attachment
        Are you trying this with two copies of thttpd running as described
        at http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver ? By
        using the second copy at port 80 for standard websever and the
        setting the original to use port 8080, I have access to both the
        configuration webpages by using http://myslughost:8080/ and to
        regular webpages at http://slughost/ which you would configure with
        virtual hosting in it's conf file.

        peter
        On Jul 1, 2007, at 8:15 AM, bty597733 wrote:

        > SIles, thanks for the info, but logging in via ssh everytime I want
        > to see a different web site seems a complete pain to me.
        >
        > Thi is fustrations as I;d got dyndns set up with 2 domain name that
        > point to my router, which in turn forwarded port 80 to my slug, and
        > the virtual hosting was pointing my my html files for my new site
        > (on one domain), and a to the existing web admin page on another.
        >
        > I can't get the linksys page to see any of my data while virtual
        > hosting is switched on, but I have found a way round the problem...
        >
        > I've switched off virtual hosting and gone back to the original
        > setup. I've create a new index.html file in the /home/httpd/html
        > directory for my home page. Your browser will go to index.html
        > before trying index.cgi (which is what the linksys page uses).
        > Thesefore I go to my web site, and just need to type /index.cgi to
        > access the linksys page (or provide a link on my site to this). It
        > means I can;t have multiple sites as possible under vistual hosting,
        > but at leat I can have a web site plus full usability of the linksys
        > pages.
        >
        > To ensure I don't screw anything up with the linksys pages I've only
        > created index.html in the /html directory, and put everything else
        > my site references in a new /content sub-directory. The only thing
        > you need to do to ensure your new pages work is to chmod 775 them
        > after copying them to the slug.
        >
        > By if anyone can access the data on your disk using virtual hosts
        > I'd be very interested.
        >
        > With thanks, Jase.
        >
        > --- In nslu2-general@yahoogroups.com, Siles <siles.bazerman@...>
        > wrote:
        >>
        >> bty597733 wrote:
        >>> Following the instructions at http://www.nslu2-
        >>> linux.org/wiki/HowTo/VirtualHostingWithTHTTPD I have added a
        > managed
        >>> to host a web site on my slug. However; I now can't access my
        > web
        >>> admin page.
        >>>
        >>> I followed the instructions and set up the vhosts directory and
        >>> user, followed all of the instructions to create a directory for
        > my
        >>> domain name, and set-up a test web site. I modified my
        > thttpd.conf
        >>> file as directed, and now when I go to my url (externally), my
        >>> router forwards port 80 to my slug and I get my new page.
        > However,
        >>> if I try to access the linksys admin page (using /login.cgi
        >>> or /sharename) I get the following message:
        >>>
        >>> The requested URL `%.80s' resolves to a file outside the
        > permitted
        >>> web server directory tree.
        >>>
        >>> I can access the linksys web page from my network, but when ever
        > I
        >>> login to my data, I don't see any information!
        >>>
        >>> For some reasons my thttpd can no longer see my data etc. Has
        > any
        >>> one else had this problem? Any ideas what it can be? Use the web
        >>> page daily to access my data remotely so any advice is really
        >>> appreciated.
        >>>
        >>> With thanks, Jase.
        >>>
        >>>
        >>>
        >>>
        >> Hi Jase,
        >>
        >> I have had the same problem, not only using the vhosts but with the
        >> others suggested in the "how to's".
        >> What I did was to have two lines in thttpd.conf. One points to
        >> /www/httpd/html and the other to /home/httpd/html. I comment out
        > the
        >> approptiate line and when I need to get into the admin pages I SSH
        > in
        >> and edit then reboot the slug. Not elegant but works.
        >>
        >> Complicating this is my ISP blocking port 80 and needing to port
        > forward
        >> to 8080. Of course they will kindly unblock 80 for $116 a month as
        > a
        >> commercial account. I also have had a problem with creating a new
        > user
        >> as outlined in the "how to" articles. Every time my web site is
        > reached
        >> a login password is requested. Never did find a workarounf fot
        > that, so
        >> I put my /www directory in ADMIN 2.
        >>
        >> BTW my website is running on an 8GB Sony flash drive as Disk 2 and
        > a 4GB
        >> Memorex flash drive. Very lowpower and completely silent.
        >>
        >> Siles
        >>
      • bty597733
        Peter, not using 2 instances of thttpd as my work are security nuts and have locked out all available ports. Need to keep everything on port 80 which is the
        Message 3 of 6 , Jul 1, 2007
        View Source
        • 0 Attachment
          Peter, not using 2 instances of thttpd as my work are security nuts
          and have locked out all available ports. Need to keep everything on
          port 80 which is the virtual hosting would be perfect (if I could
          see my data of course).

          Jase.

          --- In nslu2-general@yahoogroups.com, Peter Richard <pdfrichard@...>
          wrote:
          >
          > Are you trying this with two copies of thttpd running as
          described
          > at http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver ?
          By
          > using the second copy at port 80 for standard websever and the
          > setting the original to use port 8080, I have access to both the
          > configuration webpages by using http://myslughost:8080/ and to
          > regular webpages at http://slughost/ which you would configure
          with
          > virtual hosting in it's conf file.
          >
          > peter
          > On Jul 1, 2007, at 8:15 AM, bty597733 wrote:
          >
          > > SIles, thanks for the info, but logging in via ssh everytime I
          want
          > > to see a different web site seems a complete pain to me.
          > >
          > > Thi is fustrations as I;d got dyndns set up with 2 domain name
          that
          > > point to my router, which in turn forwarded port 80 to my slug,
          and
          > > the virtual hosting was pointing my my html files for my new site
          > > (on one domain), and a to the existing web admin page on another.
          > >
          > > I can't get the linksys page to see any of my data while virtual
          > > hosting is switched on, but I have found a way round the
          problem...
          > >
          > > I've switched off virtual hosting and gone back to the original
          > > setup. I've create a new index.html file in the /home/httpd/html
          > > directory for my home page. Your browser will go to index.html
          > > before trying index.cgi (which is what the linksys page uses).
          > > Thesefore I go to my web site, and just need to type /index.cgi
          to
          > > access the linksys page (or provide a link on my site to this).
          It
          > > means I can;t have multiple sites as possible under vistual
          hosting,
          > > but at leat I can have a web site plus full usability of the
          linksys
          > > pages.
          > >
          > > To ensure I don't screw anything up with the linksys pages I've
          only
          > > created index.html in the /html directory, and put everything
          else
          > > my site references in a new /content sub-directory. The only
          thing
          > > you need to do to ensure your new pages work is to chmod 775 them
          > > after copying them to the slug.
          > >
          > > By if anyone can access the data on your disk using virtual hosts
          > > I'd be very interested.
          > >
          > > With thanks, Jase.
          > >
          > > --- In nslu2-general@yahoogroups.com, Siles <siles.bazerman@>
          > > wrote:
          > >>
          > >> bty597733 wrote:
          > >>> Following the instructions at http://www.nslu2-
          > >>> linux.org/wiki/HowTo/VirtualHostingWithTHTTPD I have added a
          > > managed
          > >>> to host a web site on my slug. However; I now can't access my
          > > web
          > >>> admin page.
          > >>>
          > >>> I followed the instructions and set up the vhosts directory and
          > >>> user, followed all of the instructions to create a directory
          for
          > > my
          > >>> domain name, and set-up a test web site. I modified my
          > > thttpd.conf
          > >>> file as directed, and now when I go to my url (externally), my
          > >>> router forwards port 80 to my slug and I get my new page.
          > > However,
          > >>> if I try to access the linksys admin page (using /login.cgi
          > >>> or /sharename) I get the following message:
          > >>>
          > >>> The requested URL `%.80s' resolves to a file outside the
          > > permitted
          > >>> web server directory tree.
          > >>>
          > >>> I can access the linksys web page from my network, but when
          ever
          > > I
          > >>> login to my data, I don't see any information!
          > >>>
          > >>> For some reasons my thttpd can no longer see my data etc. Has
          > > any
          > >>> one else had this problem? Any ideas what it can be? Use the
          web
          > >>> page daily to access my data remotely so any advice is really
          > >>> appreciated.
          > >>>
          > >>> With thanks, Jase.
          > >>>
          > >>>
          > >>>
          > >>>
          > >> Hi Jase,
          > >>
          > >> I have had the same problem, not only using the vhosts but with
          the
          > >> others suggested in the "how to's".
          > >> What I did was to have two lines in thttpd.conf. One points to
          > >> /www/httpd/html and the other to /home/httpd/html. I comment out
          > > the
          > >> approptiate line and when I need to get into the admin pages I
          SSH
          > > in
          > >> and edit then reboot the slug. Not elegant but works.
          > >>
          > >> Complicating this is my ISP blocking port 80 and needing to port
          > > forward
          > >> to 8080. Of course they will kindly unblock 80 for $116 a month
          as
          > > a
          > >> commercial account. I also have had a problem with creating a
          new
          > > user
          > >> as outlined in the "how to" articles. Every time my web site is
          > > reached
          > >> a login password is requested. Never did find a workarounf fot
          > > that, so
          > >> I put my /www directory in ADMIN 2.
          > >>
          > >> BTW my website is running on an 8GB Sony flash drive as Disk 2
          and
          > > a 4GB
          > >> Memorex flash drive. Very lowpower and completely silent.
          > >>
          > >> Siles
          > >>
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.