Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Unslung nfs-utils server

Expand Messages
  • Marcel Nijenhof
    ... Why all these options? I don t have any problems with the default options which are: $ nfsstat -m /mnt/1 from paard:/share/flash/data Flags:
    Message 1 of 8 , Mar 4, 2007
    View Source
    • 0 Attachment
      On Sat, 2007-03-03 at 11:32 +0000, nick.ratbert wrote:
      > On my FC6 box I manually do:
      >
      > mount -o vers=3,tcp,sync,lock,intr,hard,rw
      > 192.168.1.77:/share/flash/data /mnt/slug
      >

      Why all these options?

      I don't have any problems with the default options which are:
      $ nfsstat -m
      /mnt/1 from paard:/share/flash/data
      Flags: rw,vers=3,rsize=32768,wsize=32768,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard

      This gives me a write performance of:
      # dd if=/dev/zero of=g1 bs=64k count=1024
      1024+0 records in
      1024+0 records out
      67108864 bytes (67 MB) copied, 19.622 seconds, 3.4 MB/s

      If i use your options:
      $ nfsstat -m
      /mnt/1 from paard:/share/flash/data
      Flags: rw,sync,vers=3,rsize=32768,wsize=32768,hard,intr,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard

      The performance drops:
      # dd if=/dev/zero of=g1 bs=64k count=128
      128+0 records in
      128+0 records out
      8388608 bytes (8.4 MB) copied, 76.4218 seconds, 110 kB/s

      So the performance is a factor 30 times slower.
      The main cause is the sync option which requires that every io is written
      to disk immediately.

      --
      marceln
    • Marcel Nijenhof
      ... Why all these options? I don t have any problems with the default options which are: $ nfsstat -m /mnt/1 from paard:/share/flash/data Flags:
      Message 2 of 8 , Mar 4, 2007
      View Source
      • 0 Attachment
        On Sat, 2007-03-03 at 11:32 +0000, nick.ratbert wrote:
        > On my FC6 box I manually do:
        >
        > mount -o vers=3,tcp,sync,lock,intr,hard,rw
        > 192.168.1.77:/share/flash/data /mnt/slug
        >

        Why all these options?

        I don't have any problems with the default options which are:
        $ nfsstat -m
        /mnt/1 from paard:/share/flash/data
        Flags: rw,vers=3,rsize=32768,wsize=32768,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard

        This gives me a write performance of:
        # dd if=/dev/zero of=g1 bs=64k count=1024
        1024+0 records in
        1024+0 records out
        67108864 bytes (67 MB) copied, 19.622 seconds, 3.4 MB/s

        If i use your options:
        $ nfsstat -m
        /mnt/1 from paard:/share/flash/data
        Flags: rw,sync,vers=3,rsize=32768,wsize=32768,hard,intr,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard

        The performance drops:
        # dd if=/dev/zero of=g1 bs=64k count=128
        128+0 records in
        128+0 records out
        8388608 bytes (8.4 MB) copied, 76.4218 seconds, 110 kB/s

        So the performance is a factor 30 times slower.
        The main cause is the sync option which requires that every io is written
        to disk immediately.

        --
        marceln
      • Stanley P. Miller
        Openslug at 266, it worked well at 133 too, a bit slower but no hangs going to Suse, Ubuntu and Knoppix systems. marceln, mentioned the sync option, not sure
        Message 3 of 8 , Mar 5, 2007
        View Source
        • 0 Attachment
          Openslug at 266, it worked well at 133 too, a bit slower but no hangs
          going to Suse, Ubuntu and Knoppix systems.

          marceln, mentioned the sync option, not sure why I have it since I
          just copied an example setup and tweaked it until I was happy without
          doing much research.

          --- In nslu2-general@yahoogroups.com, "nick.ratbert"
          <nick.ratbert@...> wrote:
          >
          > Read and write sizes don't seem to have any effect on my hangs. Can I
          > just ask, is your slug 133 or 266MHz? I wonder if a fast slug could do
          > a better job of keeping up. Maybe I'll just get my soldering iron
          out :-)
          >
          > Also your export ports (e.g. /public) look odd to me. Are you using
          > unslung or some other OS? I'd be happy to try e.g. OpenSlug as NFS was
          > the main reason I switched from the stock firmware in the first place.
          >
          > Thanks,
          > Nick.
          >
          > --- In nslu2-general@yahoogroups.com, "Stanley P. Miller"
          > <yahoo-01@> wrote:
          > >
          > > Not that I understand NFS... this is working fairly well for me. The
          > > biggest improvement was the rsize/wsize change.
          > >
          > > fstab:
          > > 192.168.2.251:/public /mnt/s1-1 nfs
          > > defaults,auto,rsize=8192,wsize=8192 0 0
          > > 192.168.2.252:/public /mnt/s2-1 nfs
          > > defaults,auto,rsize=8192,wsize=8192 0 0
          > > 192.168.2.251:/mnt/data2 /mnt/s1-2 nfs
          > > defaults,auto,rsize=8192,wsize=8192 0 0
          > > 192.168.2.251:/mnt/data3 /mnt/s1-3 nfs
          > > defaults,auto,rsize=8192,wsize=8192 0 0
          > >
          > > exports:
          > > /public 192.168.2.0/255.255.255.0(rw,sync,no_root_squash)
          > >
          > >
          > >
          > > --- In nslu2-general@yahoogroups.com, "nick.ratbert"
          > > <nick.ratbert@> wrote:
          > > >
          > > > Hi,
          > > >
          > > > Just got my first slug 4 days ago, but am not new to Linux. It's
          only
          > > > a 133MHz Slug, so I will be doing the 266MHz modification soon.
          So far
          > > > I'm impressed with what the developers have done. I'm using Unslung
          > > > 6.8 Beta, but would consider switching to OpenSlug.
          > > >
          > > > So far I have only added nfs-utils 1.0.7-5 for my Linux boxes to
          > > > access the slug, OpenSSH and sendmail (not in use yet). NFS seems to
          > > > work, but causes some issues with my FC6 Linux box.
          > > >
          > > > On the slug /opt/etc/exports has:
          > > >
          > > > /share/flash/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
          > > > /share/flash/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)
          > > >
          > > > On my FC6 box I manually do:
          > > >
          > > > mount -o vers=3,tcp,sync,lock,intr,hard,rw
          > > > 192.168.1.77:/share/flash/data /mnt/slug
          > > >
          > > > (not wrapped of course)
          > > >
          > > > Then I cd to /mnt/slug/public and copy a 2GB file to the slug
          from the
          > > > local disk in my FC6 box. The file copies fine and peak through-put
          > > > looks good (>4.5 MBytes/s). Even average through-put looks okay, but
          > > > the speed toggles from high to low (much less then 1 MByte/s)
          > > > randomly, but about every 5-20 seconds. And the worse bit: about
          every
          > > > 30-60 seconds, my FC6 machine becomes unresponsive (to mouse or
          > > > keyboard inputs) for 5-10 seconds.
          > > >
          > > > This could be an issue with my FC6 box, but mounting NFS from
          another
          > > > Linux PC seems not to cause these kind of issues.
          > > >
          > > > Has anybody else seen this or got some suggestions on how to fix it?
          > > >
          > > > Thanks,
          > > > Nick.
          > > >
          > >
          >
        • nick.ratbert
          I m running at 266MHz now as well and still have the problem. However, I think this is down to my desktops eth driver (forcedeth). I tried from a machine with
          Message 4 of 8 , Mar 6, 2007
          View Source
          • 0 Attachment
            I'm running at 266MHz now as well and still have the problem. However,
            I think this is down to my desktops eth driver (forcedeth). I tried
            from a machine with a realtek card and it works just fine - if a bit
            slower :-)

            Thanks for your help - I'm off to buy a new eth card :-(

            Nick.

            --- In nslu2-general@yahoogroups.com, "Stanley P. Miller"
            <yahoo-01@...> wrote:
            >
            > Openslug at 266, it worked well at 133 too, a bit slower but no hangs
            > going to Suse, Ubuntu and Knoppix systems.
            >
            > marceln, mentioned the sync option, not sure why I have it since I
            > just copied an example setup and tweaked it until I was happy without
            > doing much research.
            >
            > --- In nslu2-general@yahoogroups.com, "nick.ratbert"
            > <nick.ratbert@> wrote:
            > >
            > > Read and write sizes don't seem to have any effect on my hangs. Can I
            > > just ask, is your slug 133 or 266MHz? I wonder if a fast slug could do
            > > a better job of keeping up. Maybe I'll just get my soldering iron
            > out :-)
            > >
            > > Also your export ports (e.g. /public) look odd to me. Are you using
            > > unslung or some other OS? I'd be happy to try e.g. OpenSlug as NFS was
            > > the main reason I switched from the stock firmware in the first place.
            > >
            > > Thanks,
            > > Nick.
            > >
            > > --- In nslu2-general@yahoogroups.com, "Stanley P. Miller"
            > > <yahoo-01@> wrote:
            > > >
            > > > Not that I understand NFS... this is working fairly well for me. The
            > > > biggest improvement was the rsize/wsize change.
            > > >
            > > > fstab:
            > > > 192.168.2.251:/public /mnt/s1-1 nfs
            > > > defaults,auto,rsize=8192,wsize=8192 0 0
            > > > 192.168.2.252:/public /mnt/s2-1 nfs
            > > > defaults,auto,rsize=8192,wsize=8192 0 0
            > > > 192.168.2.251:/mnt/data2 /mnt/s1-2 nfs
            > > > defaults,auto,rsize=8192,wsize=8192 0 0
            > > > 192.168.2.251:/mnt/data3 /mnt/s1-3 nfs
            > > > defaults,auto,rsize=8192,wsize=8192 0 0
            > > >
            > > > exports:
            > > > /public 192.168.2.0/255.255.255.0(rw,sync,no_root_squash)
            > > >
            > > >
            > > >
            > > > --- In nslu2-general@yahoogroups.com, "nick.ratbert"
            > > > <nick.ratbert@> wrote:
            > > > >
            > > > > Hi,
            > > > >
            > > > > Just got my first slug 4 days ago, but am not new to Linux. It's
            > only
            > > > > a 133MHz Slug, so I will be doing the 266MHz modification soon.
            > So far
            > > > > I'm impressed with what the developers have done. I'm using
            Unslung
            > > > > 6.8 Beta, but would consider switching to OpenSlug.
            > > > >
            > > > > So far I have only added nfs-utils 1.0.7-5 for my Linux boxes to
            > > > > access the slug, OpenSSH and sendmail (not in use yet). NFS
            seems to
            > > > > work, but causes some issues with my FC6 Linux box.
            > > > >
            > > > > On the slug /opt/etc/exports has:
            > > > >
            > > > > /share/flash/data 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
            > > > > /share/flash/conf 192.168.0.0/255.255.0.0(ro,sync,no_root_squash)
            > > > >
            > > > > On my FC6 box I manually do:
            > > > >
            > > > > mount -o vers=3,tcp,sync,lock,intr,hard,rw
            > > > > 192.168.1.77:/share/flash/data /mnt/slug
            > > > >
            > > > > (not wrapped of course)
            > > > >
            > > > > Then I cd to /mnt/slug/public and copy a 2GB file to the slug
            > from the
            > > > > local disk in my FC6 box. The file copies fine and peak
            through-put
            > > > > looks good (>4.5 MBytes/s). Even average through-put looks
            okay, but
            > > > > the speed toggles from high to low (much less then 1 MByte/s)
            > > > > randomly, but about every 5-20 seconds. And the worse bit: about
            > every
            > > > > 30-60 seconds, my FC6 machine becomes unresponsive (to mouse or
            > > > > keyboard inputs) for 5-10 seconds.
            > > > >
            > > > > This could be an issue with my FC6 box, but mounting NFS from
            > another
            > > > > Linux PC seems not to cause these kind of issues.
            > > > >
            > > > > Has anybody else seen this or got some suggestions on how to
            fix it?
            > > > >
            > > > > Thanks,
            > > > > Nick.
            > > > >
            > > >
            > >
            >
          • nick.ratbert
            I have to say that I tried async as well and saw equally good performance - about 4.5MByte/s. And sync is safer of course. I don t normally use TCP either, as
            Message 5 of 8 , Mar 6, 2007
            View Source
            • 0 Attachment
              I have to say that I tried async as well and saw equally good
              performance - about 4.5MByte/s. And sync is safer of course. I don't
              normally use TCP either, as UDP seems to work well enough and should
              be slightly faster. But I went for belt and braces in my example, to
              make sure it wasn't the mount options that where causing any issues
              (lots of lost packet retries for example). Mind you I didn't use dd,
              just a simple cp.

              When I've fitted a more stable eth card, I'll put in a bit more effort
              and tweak it 'till it screams ;-)

              Nick.

              --- In nslu2-general@yahoogroups.com, Marcel Nijenhof <nslu2@...> wrote:
              >
              > On Sat, 2007-03-03 at 11:32 +0000, nick.ratbert wrote:
              > > On my FC6 box I manually do:
              > >
              > > mount -o vers=3,tcp,sync,lock,intr,hard,rw
              > > 192.168.1.77:/share/flash/data /mnt/slug
              > >
              >
              > Why all these options?
              >
              > I don't have any problems with the default options which are:
              > $ nfsstat -m
              > /mnt/1 from paard:/share/flash/data
              > Flags:
              rw,vers=3,rsize=32768,wsize=32768,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard
              >
              > This gives me a write performance of:
              > # dd if=/dev/zero of=g1 bs=64k count=1024
              > 1024+0 records in
              > 1024+0 records out
              > 67108864 bytes (67 MB) copied, 19.622 seconds, 3.4 MB/s
              >
              > If i use your options:
              > $ nfsstat -m
              > /mnt/1 from paard:/share/flash/data
              > Flags:
              rw,sync,vers=3,rsize=32768,wsize=32768,hard,intr,proto=tcp,timeo=600,retrans=2,sec=sys,addr=paard
              >
              > The performance drops:
              > # dd if=/dev/zero of=g1 bs=64k count=128
              > 128+0 records in
              > 128+0 records out
              > 8388608 bytes (8.4 MB) copied, 76.4218 seconds, 110 kB/s
              >
              > So the performance is a factor 30 times slower.
              > The main cause is the sync option which requires that every io is
              written
              > to disk immediately.
              >
              > --
              > marceln
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.