Loading ...
Sorry, an error occurred while loading the content.
 

RE: [nslu2-general] Previously working drive now showing NOT FORMATTED

Expand Messages
  • WRT54G.yg@datmail.com
    ... Until we have a different firmware, or linksys gets on the ball and get a firmware released that s at LEAST stable I think you are quite right. The 2-3
    Message 1 of 7 , Aug 26, 2004
      > Backup failed this evening and NSLU2 reports disk1 as NOT FORMATTED.
      > There was about 100GB of data on this disk that is recoverable
      > from other machines, but I am becoming concerned about the
      > reliability of the NSLU2 as a backup device.

      Until we have a different firmware, or linksys gets on the ball and get a
      firmware released that's at LEAST stable I think you are quite right.

      The 2-3 trivial fixes that they've added between r21 and r25 don't do
      anything for the stability of the box...which has been quite poor with the
      stock linksys stuff.

      David Troesch | Atlanta, GA | ICQ# 2333123
      Jawohl, mein heir. Vee vil crush dem like a bug. Sich Heil!
      http://tinyurl.com/2zwgd
      Funstuff: Yoda of Borg are we. Futile is resistance. Assimilate you, we
      will.
    • mgpager
      (Here is a follow to the my previous post. An abbreviated outtake of the original is included at the end for reference ) 9/6/04 My 300GB Maxtor on drive 1 has
      Message 2 of 7 , Sep 6, 2004
        (Here is a follow to the my previous post. An abbreviated outtake
        of the original is included at the end for reference )
        9/6/04
        My 300GB Maxtor on drive 1 has AGAIN spontaneously become
        "Not Formatted" as far as the NSLU-2 knows.
        As this is the same symptom as about a week ago (26-Aug),
        I have a high level of confidence that if I reformat the pack and re-
        copy the data, it will again work for some period of time.
        At this time, I have zero confidence in the NSLU-2 as a backup
        server. However, I do not know if the problem resides in the
        NSLU-2 (the most likely suspect) or if there is a problem with
        the Maxtor disk.
        Here is the de-bug plan:

        1) get a driver for Win XP that makes the ext3 formatted pack
        appear as an NTFS formatted, external USB drive to Windows.
        If the data is intact, then the problem is the NSLU-2
        I was a aware of such a driver for ext2.
        Does anyone know of such a driver for ext3 <-> NTFS?

        2) If it is the NSLU-2, is there anyone else who has had this
        identical problem with a disk drive suddenly becoming not formatted
        according to the NSLU-2? If this is a problem with this particular
        NSLU-2, then I am happy to replace it with a working one. If it is a
        weakness in the firmware, then I will return it.

        Any other comments/questions would be appreciated.

        Marc
        >>
        (26-Aug)
        --- In nslu2-general@yahoogroups.com, "mgpager" <nslu2@g...> wrote:
        > Been using the NSLU2 with a 300GB Maxtor on disk1 and a 60gb on
        > disk2 for a couple of weeks now.

        .... non relevant material deleted .....

        > Backup failed this evening and NSLU2 reports disk1 as NOT FORMATTED.
        > There was about 100GB of data on this disk that is recoverable
        > from other machines, but I am becoming concerned about the
        > reliability of the NSLU2 as a backup device.
        >
        > I've read a couple of posts that indicates power cycling the
        > NSLU2, the disk may solve the problem. This does not seem to
        > work here. It still indicates that the drive is not formatted.
      • Chuck Urwiler
        Marc, One thing to try before even getting the ext2 driver - shut down the NSLU2, power down your drive. Wait a minute. Then power up the drive, and the NSLU2,
        Message 3 of 7 , Sep 7, 2004
          Marc,

          One thing to try before even getting the ext2 driver - shut down the NSLU2,
          power down your drive. Wait a minute. Then power up the drive, and the
          NSLU2, and see if the drive shows up again.

          Barring this, look for an ext2 driver for WinXP with Google. you'll find it
          easily that way. Plug it in and check the drive to be sure your files exist.
          I will put money on it that your files are intact and just fine. Ext3 is the
          same as ext2 but with journaling, so no harm done reading with the ext2
          driver - but you will only read, not read and write. I think you have to pay
          to get one that does both.

          I'd guess that the problem you're seeing is some kind of weakness in the
          firmware for the NSLU2. I'm not certain of the exact cause, but I've seen
          this as well.

          Personally, I'm patiently waiting for the nslu2-linux group guys to finish
          testing their new firmware. They seem close to an answer, and will probably
          help make the NSLU2 a really useful device. But there's a lot of testing
          left to do before it's ready it seems, and can understand your frustration -
          I almost returned mine as well!

          Good luck.
          -Chuck
        • David Farrell
          Did you by chance have auto-scandisk scheduled? My NSLU/Drive has not failed since I turned it off. David. mgpager wrote: (Here is a follow
          Message 4 of 7 , Sep 7, 2004
            Did you by chance have auto-scandisk scheduled?
            My NSLU/Drive has not failed since I turned it off.
            David.

            mgpager <nslu2@...> wrote:
            (Here is a follow to the my previous post. An abbreviated outtake
            of the original is included at the end for reference )
            9/6/04
            My 300GB Maxtor on drive 1 has AGAIN spontaneously become
            "Not Formatted" as far as the NSLU-2 knows.
            As this is the same symptom as about a week ago (26-Aug),
            I have a high level of confidence that if I reformat the pack and re-
            copy the data, it will again work for some period of time.
            At this time, I have zero confidence in the NSLU-2 as a backup
            server. However, I do not know if the problem resides in the
            NSLU-2 (the most likely suspect) or if there is a problem with
            the Maxtor disk.
            Here is the de-bug plan:

            1) get a driver for Win XP that makes the ext3 formatted pack
            appear as an NTFS formatted, external USB drive to Windows.
            If the data is intact, then the problem is the NSLU-2
            I was a aware of such a driver for ext2.
            Does anyone know of such a driver for ext3 <-> NTFS?

            2) If it is the NSLU-2, is there anyone else who has had this
            identical problem with a disk drive suddenly becoming not formatted
            according to the NSLU-2? If this is a problem with this particular
            NSLU-2, then I am happy to replace it with a working one. If it is a
            weakness in the firmware, then I will return it.

            Any other comments/questions would be appreciated.

            Marc
            >>
            (26-Aug)
            --- In nslu2-general@yahoogroups.com, "mgpager" wrote:
            > Been using the NSLU2 with a 300GB Maxtor on disk1 and a 60gb on
            > disk2 for a couple of weeks now.

            .... non relevant material deleted .....

            > Backup failed this evening and NSLU2 reports disk1 as NOT FORMATTED.
            > There was about 100GB of data on this disk that is recoverable
            > from other machines, but I am becoming concerned about the
            > reliability of the NSLU2 as a backup device.
            >
            > I've read a couple of posts that indicates power cycling the
            > NSLU2, the disk may solve the problem. This does not seem to
            > work here. It still indicates that the drive is not formatted.






            Yahoo! Groups Links







            [Non-text portions of this message have been removed]
          • WRT54G.yg@datmail.com
            ... This is unfortunately a flaw with the Linksys firmware. Currently there are no known NSLU2 workaround for this, other than deleting all the partitions
            Message 5 of 7 , Sep 7, 2004
              > 2) If it is the NSLU-2, is there anyone else who has had this
              > identical problem with a disk drive suddenly becoming not formatted
              > according to the NSLU-2? If this is a problem with this particular
              > NSLU-2, then I am happy to replace it with a working one. If it is a
              > weakness in the firmware, then I will return it.

              This is unfortunately a flaw with the Linksys firmware. Currently there are
              no known NSLU2 workaround for this, other than deleting all the partitions
              under another computer, and reformatting the drive with the NSLU2 (which is
              rediculous...AND you will probably have the same problem again at some
              future time). Just hold on for one of the user-created firmwares, so we can
              get away from Linksys's hunk-o-junk-firmware and get a reliably-operational
              NSLU2.

              I don't think we'll make it to October without one of the in-development
              firmwares making it to official first release :)

              David Troesch | Atlanta, GA | ICQ# 2333123
              If you don't take action, someone else will. http://action.eff.org
              Funstuff: 4 types of miniskirts: mini, micro, don't bend over, and "nice
              view!"
            • Krusty The Clown
              If you are having this problem, make sure scandisk is off and not on a schedule. Then power off the drive and the NSLU2 for at least 10 minutes. The ten
              Message 6 of 7 , Sep 20, 2004
                If you are having this problem, make sure scandisk is off and not on
                a schedule. Then power off the drive and the NSLU2 for at least 10
                minutes. The ten minutes is very important if not longer because I
                tried it with two or three minutes and it didn't work, but then I
                got really fustrated and shut it all down and left the room for a
                while and then came back to try again and the problem went away. I
                didn't do anything different other than leaving it off for a long
                time, I'm not sure how long it takes but it worked for me.


                To prevent this from happening save your configuration files by
                downloading them to your computer.
              Your message has been successfully submitted and would be delivered to recipients shortly.