Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nslu2-general] Problems with ProFTPd

Expand Messages
  • Cory Megitt
    Thanks; I thought I had done this already ­ but I guess not! # ftp 192.168.1.77 Connected to 192.168.1.77. 220 ProFTPD 1.3.0a Server (ProFTPD Default
    Message 1 of 5 , Feb 26, 2007
      Thanks;


      I thought I had done this already ­ but I guess not!

      # ftp 192.168.1.77
      Connected to 192.168.1.77.
      220 ProFTPD 1.3.0a Server (ProFTPD Default Installation) [192.168.1.77]

      It¹s working now.


      On 2/25/07 7:05 PM, "Mike (mwester)" <mwester@...> wrote:

      >
      >
      >
      >
      > Change the line that says:
      > disable = yes
      > to:
      > disable = no
      >
      > Mike (mwester)
      >
      > ----- Original Message -----
      > From: "Cory Megitt" <cory@... <mailto:cory%40megitt.ca> >
      > To: <nslu2-general@yahoogroups.com <mailto:nslu2-general%40yahoogroups.com> >
      > Sent: Sunday, February 25, 2007 12:26 AM
      > Subject: [nslu2-general] Problems with ProFTPd
      >
      >> > Hi all;
      >> >
      >> > I installed XinetD and rebooted.
      >> > I am having issues with running ProFTPD from the optware packages.
      >> > I installed it fine, no errors occured.
      >> >
      >> > No matter what I do, I can't get it to run via xinetd.
      >> >
      >> > ps -aux | grep xinet
      >> > 500 root 2280 S /opt/sbin/xinetd
      >> >
      >> > /var/log/messages:
      >> > <31>Feb 26 00:53:41 xinetd[500]: Reading included configuration file:
      >> > /opt/etc/xinetd.d/ftp-sensor [file=/opt/etc/xinetd.conf] [line=15]
      >> > <31>Feb 26 00:53:41 xinetd[500]: Reading included configuration file:
      >> > /opt/etc/xinetd.d/proftpd [file=/opt/etc/xinetd.d/proftpd] [line=70]
      >> > <31>Feb 26 00:53:41 xinetd[500]: Reading included configuration file:
      >> > /opt/etc/xinetd.d/telnetd [file=/opt/etc/xinetd.d/telnetd] [line=16]
      >> > <31>Feb 26 00:53:41 xinetd[500]: removing ftp
      >> > <29>Feb 26 00:53:41 xinetd[500]: xinetd Version 2.3.14 started with no
      >> > options compiled in.
      >> > <29>Feb 26 00:53:41 xinetd[500]: Started working: 2 available services
      >> >
      >> > /opt/etc/xinetd.d/ftp-sensor has the following:
      >> >
      >> > service ftp
      >> > {
      >> > # This is for quick on or off of the service
      >> > disable = yes
      >> >
      >> > /opt/etc/proftpd.conf has the following:
      >> > ServerName "ProFTPD Default Installation"
      >> > ServerType inetd
      >> > DefaultServer on
      >> > WtmpLog off
      >> >
      >> > # Port 21 is the standard FTP port.
      >> > Port 21
      >> >
      >> > when trying to run proftpd from /etc/sbin, I get:
      >> >
      >> > # proftpd
      >> > LXXXXXX - fatal: Socket operation on non-socket
      >> >
      >> >
      >> >
      >> > Does anyone have any ideas or what's wrong and how to fix this?
      >> >
      >> > Thanks in advance.
      >
      >
      >




      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.