Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Error with MySQL & Jinzora

Expand Messages
  • Robert Hammond
    In message , Nick B writes ... I just installed this app to test if it
    Message 1 of 5 , Jan 2, 2007
    • 0 Attachment
      In message
      <f0370de70701011807w23f34197y6cda37f48a24409e@...>, Nick B
      <newsprofile@...> writes
      >Hi,
      >
      >I've been trying to install Jinzora all day with no luck. I have
      >installed Apache okay on port 8000 and PHP is also working correctly
      >(phpinfo file shows). I then visit the index.php in the Jinzora folder
      >and just receive a blank screen.

      I just installed this app to test if it installs and the index page
      loads just fine for me. I think that your problem is setting up the
      file and folder permissions correctly for PHP apps. The Wiki contains a
      section on this with some scripts that you can run to set the owners and
      permissions at the bottom of the web page :-

      <http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver>

      I hope that you report back with your progress with Jinzora because the
      list of requirements seems far larger than the capabilities of the
      NSLU2, things such as setting the PHP memory limit to 32mbite.



      --
      Robert Hammond
      PGP:0x154144DA
    • Nick B
      ... Thanks Robert That did work nicely. I tried with SQLite but it comes back with ... Backend Setup Creating Database - jinzora2 - Successful! could not
      Message 2 of 5 , Jan 2, 2007
      • 0 Attachment
        >
        > In message
        > <f0370de70701011807w23f34197y6cda37f48a24409e@...>, Nick B
        > <newsprofile@...> writes
        > >Hi,
        > >
        > >I've been trying to install Jinzora all day with no luck. I have
        > >installed Apache okay on port 8000 and PHP is also working correctly
        > >(phpinfo file shows). I then visit the index.php in the Jinzora folder
        > >and just receive a blank screen.
        >
        > I just installed this app to test if it installs and the index page
        > loads just fine for me. I think that your problem is setting up the
        > file and folder permissions correctly for PHP apps. The Wiki contains a
        > section on this with some scripts that you can run to set the owners and
        > permissions at the bottom of the web page :-
        >
        > <http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver>
        >
        > I hope that you report back with your progress with Jinzora because the
        > list of requirements seems far larger than the capabilities of the
        > NSLU2, things such as setting the PHP memory limit to 32mbite.


        Thanks Robert

        That did work nicely. I tried with SQLite but it comes back with ...

        " Backend Setup

        Creating Database
        - jinzora2 - Successful!

        could not connect to database."

        I guess I'd prefer to get MySQL working. Any idea how to fix this error?

        # mysql -p
        mysql: error while loading shared libraries: libmysqlclient.so.14:
        cannot open shared object file: No such file or directory

        Thanks

        Nick
      • Nick B
        ... Oh .. uNSLUng 6.8 beta.
        Message 3 of 5 , Jan 2, 2007
        • 0 Attachment
          On 1/2/07, Nick B <newsprofile@...> wrote:
          > >
          > > In message
          > > <f0370de70701011807w23f34197y6cda37f48a24409e@...>, Nick B
          > > <newsprofile@...> writes
          > > >Hi,
          > > >
          > > >I've been trying to install Jinzora all day with no luck. I have
          > > >installed Apache okay on port 8000 and PHP is also working correctly
          > > >(phpinfo file shows). I then visit the index.php in the Jinzora folder
          > > >and just receive a blank screen.
          > >
          > > I just installed this app to test if it installs and the index page
          > > loads just fine for me. I think that your problem is setting up the
          > > file and folder permissions correctly for PHP apps. The Wiki contains a
          > > section on this with some scripts that you can run to set the owners and
          > > permissions at the bottom of the web page :-
          > >
          > > <http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver>
          > >
          > > I hope that you report back with your progress with Jinzora because the
          > > list of requirements seems far larger than the capabilities of the
          > > NSLU2, things such as setting the PHP memory limit to 32mbite.
          >
          >
          > Thanks Robert
          >
          > That did work nicely. I tried with SQLite but it comes back with ...
          >
          > " Backend Setup
          >
          > Creating Database
          > - jinzora2 - Successful!
          >
          > could not connect to database."
          >
          > I guess I'd prefer to get MySQL working. Any idea how to fix this error?
          >
          > # mysql -p
          > mysql: error while loading shared libraries: libmysqlclient.so.14:
          > cannot open shared object file: No such file or directory
          >


          Oh .. uNSLUng 6.8 beta.
        • nigelswalker
          As root, create the following link: ln -s /opt/lib/mysql/libmysqlclient.so /lib/libmysqlclient.so.14 ... correctly ... Jinzora folder ... up the ... contains a
          Message 4 of 5 , Jan 13, 2007
          • 0 Attachment
            As root, create the following link:
            ln -s /opt/lib/mysql/libmysqlclient.so /lib/libmysqlclient.so.14

            --- In nslu2-general@yahoogroups.com, "Nick B" <newsprofile@...> wrote:
            >
            > On 1/2/07, Nick B <newsprofile@...> wrote:
            > > >
            > > > In message
            > > > <f0370de70701011807w23f34197y6cda37f48a24409e@...>, Nick B
            > > > <newsprofile@...> writes
            > > > >Hi,
            > > > >
            > > > >I've been trying to install Jinzora all day with no luck. I have
            > > > >installed Apache okay on port 8000 and PHP is also working
            correctly
            > > > >(phpinfo file shows). I then visit the index.php in the
            Jinzora folder
            > > > >and just receive a blank screen.
            > > >
            > > > I just installed this app to test if it installs and the index page
            > > > loads just fine for me. I think that your problem is setting
            up the
            > > > file and folder permissions correctly for PHP apps. The Wiki
            contains a
            > > > section on this with some scripts that you can run to set the
            owners and
            > > > permissions at the bottom of the web page :-
            > > >
            > > > <http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver>
            > > >
            > > > I hope that you report back with your progress with Jinzora
            because the
            > > > list of requirements seems far larger than the capabilities of the
            > > > NSLU2, things such as setting the PHP memory limit to 32mbite.
            > >
            > >
            > > Thanks Robert
            > >
            > > That did work nicely. I tried with SQLite but it comes back with ...
            > >
            > > " Backend Setup
            > >
            > > Creating Database
            > > - jinzora2 - Successful!
            > >
            > > could not connect to database."
            > >
            > > I guess I'd prefer to get MySQL working. Any idea how to fix this
            error?
            > >
            > > # mysql -p
            > > mysql: error while loading shared libraries: libmysqlclient.so.14:
            > > cannot open shared object file: No such file or directory
            > >
            >
            >
            > Oh .. uNSLUng 6.8 beta.
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.