Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] top Failure after upgrading to unslung 3.17

Expand Messages
  • Rod Whitby
    On Mon, 03 Jan 2005 17:11:47 -0600, Gerald L. Clark ... Unslung packages should never require any environment variables to be set to find libraries. Any that
    Message 1 of 4 , Jan 4, 2005
    • 0 Attachment
      On Mon, 03 Jan 2005 17:11:47 -0600, Gerald L. Clark
      <gerald_clark@...> wrote:
      > Gilles Cadrin wrote:
      > > When trying to run top, since upgrading to unslung 3.17 , I'm getting the
      > > following error
      > > top: error while loading shared libraries: libproc-3.2.3.so: cannot open
      > > shared
      > > Here is my environment variables
      > > LIBPATH='/lib:/opt/lib:'
      > LD_LIBRARY_PATH=/lib:/opt/lib

      Unslung packages should never require any environment variables to be
      set to find libraries. Any that do should be fixed to use the
      link-time options which set it to search /opt/lib in the ELF binary
      format.

      -- Rod
    Your message has been successfully submitted and would be delivered to recipients shortly.