Loading ...
Sorry, an error occurred while loading the content.

RE: [nslu2-general] top Failure after upgrading to unslung 3.17

Expand Messages
  • Gilles Cadrin
    Thanks II worked .. _____ From: Gerald L. Clark [mailto:gerald_clark@mindspring.com] Sent: Monday, January 03, 2005 6:12 PM To: nslu2-general@yahoogroups.com
    Message 1 of 4 , Jan 3, 2005
    • 0 Attachment
      Thanks



      II worked ..







      _____

      From: Gerald L. Clark [mailto:gerald_clark@...]
      Sent: Monday, January 03, 2005 6:12 PM
      To: nslu2-general@yahoogroups.com
      Subject: Re: [nslu2-general] top Failure after upgrading to unslung 3.17



      Gilles Cadrin wrote:
      >
      > Hi gang
      > When trying to run top, since upgrading to unslung 3.17 , I'm getting the
      > following error
      >
      > root@NAS:~ > top
      >
      > top: error while loading shared libraries: libproc-3.2.3.so: cannot open
      > shared
      >
      > object file: No such file or directory
      > Here is my environment variables
      > HISTFILE='/root/.ash_history'
      > HOME='/root'
      > IFS=''
      > LIBPATH='/lib:/opt/lib:'
      LD_LIBRARY_PATH=/lib:/opt/lib
      > LOGNAME='root'
      > MAIL='/var/spool/mail/root'
      > OPTIND='1'
      > PATH='/sbin:/bin:/usr/sbin:/usr/bin:.:/opt/bin:/opt/sbin:'
      > PPID='625'
      > PS1='\[\033[1;33m\]\u@\h\[\033[0;37m\]:\w > '
      > PS2='> '
      > PS4='+ '
      > PWD='/root'
      > SHELL='/opt/bin/sh'
      > TERM='xterm-pcolor'
      > TERMINFO='/opt/lib/terminfo'
      > USER='root'
      > Have anyone else seen this ?
      > Tia
      > Gilles Cadrin




      _____

      Yahoo! Groups Links

      * To visit your group on the web, go to:
      http://groups.yahoo.com/group/nslu2-general/

      * To unsubscribe from this group, send an email to:
      nslu2-general-unsubscribe@yahoogroups.com
      <mailto:nslu2-general-unsubscribe@yahoogroups.com?subject=Unsubscribe>

      * Your use of Yahoo! Groups is subject to the Yahoo!
      <http://docs.yahoo.com/info/terms/> Terms of Service.



      [Non-text portions of this message have been removed]
    • Rod Whitby
      On Mon, 03 Jan 2005 17:11:47 -0600, Gerald L. Clark ... Unslung packages should never require any environment variables to be set to find libraries. Any that
      Message 2 of 4 , Jan 4, 2005
      • 0 Attachment
        On Mon, 03 Jan 2005 17:11:47 -0600, Gerald L. Clark
        <gerald_clark@...> wrote:
        > Gilles Cadrin wrote:
        > > When trying to run top, since upgrading to unslung 3.17 , I'm getting the
        > > following error
        > > top: error while loading shared libraries: libproc-3.2.3.so: cannot open
        > > shared
        > > Here is my environment variables
        > > LIBPATH='/lib:/opt/lib:'
        > LD_LIBRARY_PATH=/lib:/opt/lib

        Unslung packages should never require any environment variables to be
        set to find libraries. Any that do should be fixed to use the
        link-time options which set it to search /opt/lib in the ELF binary
        format.

        -- Rod
      Your message has been successfully submitted and would be delivered to recipients shortly.