Loading ...
Sorry, an error occurred while loading the content.

Re: Disk access every 5 seconds prevents spindown.

Expand Messages
  • donotdespisethesnake
    Hmm, USB_Detect appears to be a red herring. I have installed the two recommended startup scripts, and now the disk spins down even with the USB processes
    Message 1 of 31 , Dec 4, 2006
    • 0 Attachment
      Hmm, USB_Detect appears to be a red herring. I have installed the two
      recommended startup scripts, and now the disk spins down even with the
      USB processes running.

      Must have been something else accessing the disk. Sorry for the bad info.

      --- In nslu2-general@yahoogroups.com, "donotdespisethesnake"
      <bobcousins34@...> wrote:
      >
      > I killed the two processes called USB_Detect, and the regular 5 second
      > accesses stopped. I couldn't find much info on USB_Detect, apart from
      > it handles new drives and mounts them, so I guess without them you
      > can't mount drives - e.g. on startup? I haven't done any further
      > investigation.
      >
      > I believe that USB can detect new devices at a hardware level, but I
      > suppose for whatever reason Linksys decided to poll for new devices.
      >
      > BTW, the wiki page
      > http://www.nslu2-linux.org/wiki/FAQ/SpinDownUSBHarddisks had been
      > spammed yet again, I reverted it.
      >
      > --- In nslu2-general@yahoogroups.com, "jinnan_tonnix"
      > <jinnan_tonnix@> wrote:
      > >
      > > Thanks for the info Peter - really helpful.
      > >
      > > Bit of a long shot here. Someone in this forum mentioned that it
      > > might be the USB scanning function. I also seem to remember that the
      > > two USB ports behave slightly differently (hubs etc).
      > >
      > > My disk is plugged into USB port 1. Taking a stab in the dark; Peter
      > > is yours plugged into port 2?
      >
    • Carl Lowenstein
      ... Presumably the disk access is caused by the journaling ext3 file system, which refreshes its journal every 5 seconds by default. One possible solution
      Message 31 of 31 , Nov 15, 2007
      • 0 Attachment
        On 11/15/07, Tomas Holmén <tomas.holmen@...> wrote:
        >
        > I had the same problem, i solved it by unslung to a usb stick and
        > not the disk.
        >
        > rgrds Tomas
        >
        > On Nov 14, 2007 2:12 AM, tangbotu <tangbotu@...> wrote:
        >
        > > Could anyone PLEASE summarize the solution here? I'm struggling
        > > with this not-spinning-down problem. I have Unslung 6.8 unslung
        > > to a WD MyBook on port 2. This thread seems to suggest this
        > > problem is solvable but various processes are responsible for
        > > accessing the disk. What are these processes? How to clean them
        > > up neatly?

        Presumably the disk access is caused by the journaling ext3 file
        system, which refreshes its journal every 5 seconds by default. One
        possible solution would be to put the journal on another (flash)
        drive.

        You can do this with the -J option to tune2fs.

        carl

        --
        carl lowenstein
        marine physical lab, u.c. san diego
        clowenstein@...
      Your message has been successfully submitted and would be delivered to recipients shortly.