Loading ...
Sorry, an error occurred while loading the content.

Re: Disk access every 5 seconds prevents spindown.

Expand Messages
  • caldna
    FWIW, I have a 500GB WD MyBook Premium (USB+Firewire) and it also does NOT spindown using unslung 6.8 + Andreas script (rc.bootbin) + noatime script
    Message 1 of 31 , Nov 20, 2006
    • 0 Attachment
      FWIW, I have a 500GB WD MyBook Premium (USB+Firewire) and it also does
      NOT spindown using unslung 6.8 + Andreas' script (rc.bootbin) +
      noatime script (rc.local). The slug also accesses the drive about
      every 5 seconds and it doesn't matter if the drive has been natively
      formatted by the slug, formatted in a Linux machine, or NTFS formatted
      in Windows.

      However, using unslung 5.5 and the other two scripts, the drive WILL
      spindown after 10 minutes as expected. I'm sticking to 5.5 until a
      solution for 6.8 is found.





      --- In nslu2-general@yahoogroups.com, Mat <mat@...> wrote:
      >
      > I can confirm that doing what you're doing (using Andreas's script and
      > the noatime script) on an unslung 6.8 slug, and getting same results as
      > you for the cat /proc/mounts and the mount commands ('cept I'm sda not
      > sdb), something is accessing the disk every 5 or so seconds.
      >
      > I've got a western digital mybook, with the circular disk access lights
      > on, so it's easy to see when it's being accessed. I am running quite a
      > bit on my slug at the moment though, and my next round of testing is to
      > disable everything and start up the services one by one.
      >
      > jinnan_tonnix wrote:
      > > Hi all,
      > >
      > > I'm having trouble getting my drive to spin down. It seems it's being
      > > accessed every 5 seconds by the journalling system.
      > >
      > > I've used Andreas's script and the 'noatime' script to remount var and
      > > dev in memory rather than disk, and to set the 'noatime' flag on
      the disk.
      > >
      > > Could someone check their system to see if they get the same result?
      > > Thanks. Please post back!
      > >
      > > 'cat /proc/mounts' shows:
      > > # cat /proc/mounts
      > > rootfs / rootfs rw 0 0
      > > /dev/root /initrd jffs2 rw 0 0
      > > /dev/sdb1 / ext3 rw,noatime 0 0
      > > /proc /proc proc rw 0 0
      > > usbdevfs /proc/bus/usb usbdevfs rw 0 0
      > > /dev/sdb1 /dev.state ext3 rw,noatime 0 0
      > > ramfs /dev ramfs rw 0 0
      > > /dev/sdb1 /var.state ext3 rw,noatime 0 0
      > > ramfs /var ramfs rw 0 0
      > > /dev/sdb1 /share/hdd/data ext3 rw,noatime 0 0
      > > /dev/sdb2 /share/hdd/conf ext3 rw,noatime 0 0
      > >
      > >
      > > 'Mount' shows
      > > # mount
      > > /dev/sdb1 on /initrd type jffs2 (rw)
      > > /dev/sdb1 on / type ext3 (rw,noatime)
      > > /proc on /proc type proc (rw)
      > > usbdevfs on /proc/bus/usb type usbdevfs (rw)
      > > /dev/sdb1 on /dev.state type ext3 (rw,noatime)
      > > ramfs on /dev type ramfs (rw)
      > > /dev/sdb1 on /var.state type ext3 (rw,noatime)
      > > ramfs on /var type ramfs (rw)
      > > /dev/sdb1 on /share/hdd/data type ext3 (rw,noatime)
      > > /dev/sdb2 on /share/hdd/conf type ext3 (rw,noatime)
      > >
      > >
      >
    • Carl Lowenstein
      ... Presumably the disk access is caused by the journaling ext3 file system, which refreshes its journal every 5 seconds by default. One possible solution
      Message 31 of 31 , Nov 15, 2007
      • 0 Attachment
        On 11/15/07, Tomas Holmén <tomas.holmen@...> wrote:
        >
        > I had the same problem, i solved it by unslung to a usb stick and
        > not the disk.
        >
        > rgrds Tomas
        >
        > On Nov 14, 2007 2:12 AM, tangbotu <tangbotu@...> wrote:
        >
        > > Could anyone PLEASE summarize the solution here? I'm struggling
        > > with this not-spinning-down problem. I have Unslung 6.8 unslung
        > > to a WD MyBook on port 2. This thread seems to suggest this
        > > problem is solvable but various processes are responsible for
        > > accessing the disk. What are these processes? How to clean them
        > > up neatly?

        Presumably the disk access is caused by the journaling ext3 file
        system, which refreshes its journal every 5 seconds by default. One
        possible solution would be to put the journal on another (flash)
        drive.

        You can do this with the -J option to tune2fs.

        carl

        --
        carl lowenstein
        marine physical lab, u.c. san diego
        clowenstein@...
      Your message has been successfully submitted and would be delivered to recipients shortly.