Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: Newb needs help with root password

Expand Messages
  • Mike (mwester)
    ... Ok, hold on just a moment here - this might be the problem! What didn t work as stated? You need to be more specific here, because this is a very
    Message 1 of 11 , Nov 5, 2006
      > I got the NSLU2 working by flashing it with fresh firmware. Everything
      > was going good; RedBoot was working, telnet was working (password got
      > reset), and after following all the instructions thus far, I was ready
      > to unsling to my USB drive. The command didn't work as stated,

      Ok, hold on just a moment here - this might be the problem! What didn't
      work as stated? You need to be more specific here, because this is a very
      critical operation, and if it did not work as expected, you'll have trouble.

      > but I
      > typed "unsling disk2" and it worked.

      Well, ok, but above you said it didn't work... I am confused now...

      > After waiting a couple minutes,
      > the telnet window said the process was finished, so I rebooted. Too
      > bad, it wasn't working anymore....

      Ok - first step is to unplug the drives and boot up from the internal flash
      (this is the "recovery mode" for the NSLU2)...

      > Now I booted the NSLU2 without the USB drive and it worked fine.
      > Status on main page was "running from internal flash".

      Yep, this is as expected. This indicates that there is a problem is with
      the device to which you unslung -- perhaps the device is not functional, or
      perhaps the unsling operation did not work correctly (which you imply may be
      the case, above).

      > Now it seems as
      > though the problem is that my usb flash drive (1gb) was not formatted.

      How did you determine this - what utility did you use to check? I'm
      guessing the Linksys Web GUI, which has that unfortunate message displayed
      for any number of problems, only one of which is that the device is truely

      > Well, I had clicked format and everything seemed OK in disk status,
      > but clicking the Log, you could see that it said "format failed" ...
      > why?? I tried 3 more times to format, even formating into FAT32 first
      > but nothing helped. Now I can't get the NSLU2 to format the USB drive.

      Well, this will give you problems; the unsling command would not have worked
      if the device was not formatted correctly, though. I'm now really wondering
      what the output from the original "unsling" command might have been.

      How did you format it back to FAT32? Did you check the size of the device
      when you formatted it to FAT32? It's possible that the device is formatted,
      but formatting it "back" doesn't actually do that -- it may just be writing
      a FAT32 format to the first partition on the device.

      BTW, a note here for other readers - your flash is a 1 GB unit; that's fine.
      It needs to be at least 512MB for Unslung 6.8-beta (you could actually get
      away with a 256MB device for Unslung 5.5-beta, but later tests have shown
      that the new partition sizes used by the R63 Linksys firmware make 256MB
      just too small to be usable, if they format at all on Unslung 6.8-beta.

      > I normally have a lot of patience but I'm a little frustrated here.
      > Mike et al, your help is very much appreciated, I followed the manual
      > exactly but maybe I'm missing some small detail. Thank you for your time.

      Yep, I think you're missing a small detail - we just need to find where it
      is. A key item is to not proceed if there is anything unexpected or not
      right; the unslinging process is very picky. I'd like to say that it could
      be otherwise (And I welcome any folks who can come up with improved
      techniques -- working and coded techniques -- for improving this). But the
      sad fact is that unslinging is all about "fooling" the Linksys firmware, and
      dodging around the rules and restrictions that firmware has placed on us.
      So I understand your frustration that it doesn't work better. But as the
      saying goes, the wonder is not in how well the bear dances, but that it
      dances at all.

      Let's focus on that memory device. It needs to be returned to a full 1 GB
      FAT32 device on a single partition before you proceed. That can be
      challenge on some Windows boxes, you may need a special tool to do the
      repartitioning and formatting - for example, I've used the "HP USB Disk
      Storage Format Tool" to do the job on one occasion. Once that's done,

      Boot the NSLU2 without any devices plugged in. Enable telnet and log in.
      type "ls -la /" and see if a file named ".sda1root" or ".sdb1root" is
      listed. If so, note this fact (its presence indicates that the slug thought
      that it actually *did* unsling successfully at one point), and then delete
      the file: "rm /.sda1root" and reboot. Repeat this step and ensure that
      this time around, the NSLU2 has booted without this flag file present, and
      then proceed.

      Execute the "mount" command, and record the output. That's your normal
      starting state in terms of what the OS has for filesystems.

      Go to the Web Disk admin page, and observe that there are no disk devices at
      all. Plug in the flash device. Observe that after a moment, the admin page
      identifies it as FAT32. Use the mount command again, and note that the
      flash device appears in the list as something like "HD_1_1_1" or such.

      On the admin web page, format the device.

      On the telnet session, execute the mount command again, every 10 or 15
      seconds. You should see the "HD_1_1_1" entry go away. After some time, you
      should observe other stuff happening: you may see filesystems mounted on
      /mnt/tmpmnt appear and then disappear. However, at some point, the web gui
      will say that the format is complete, and at that point you will note that
      two extra mounts will be present in the output: /share/flash/conf and
      /share/flash/data (or "flash" may be replaced by "hdd", depending on which
      USB port you are plugged into -- you did read the section in the wiki on
      selected the correct port to use for your purpose, right?).

      Assuming the two mounts are present, and the admin page says the format is
      complete, execute the "unsling disk2" command. Copy the output from your
      terminal emulator window, and save it for later reference. Then leave the
      memory stick plugged in, and reboot - it should boot into Unslung. If not,
      let us know -- this time armed with more precise information on the session,
      its more likely that someone will have a concrete suggestion or solution.

      What if the format failed, then? Well, it failed for a reason. Record the
      output from the mount command. Record the output from the end of the logs:
      "dmesg | tail -50" and "tail -50 /var/log/messages" are two commands that
      may be helpful for debugging. Let us know, and someone will probably have
      some advice or observations.

      Also, this list is a great way to get general questions answered, but it's
      not a great interactive debugging or assistance forum. That's handled on
      the IRC channels - drop in on the #nslu2-general channel, post your
      question, and be patient - someone will be along, and may be able to provide
      some assistance.

      Mike (mwester)
    Your message has been successfully submitted and would be delivered to recipients shortly.