Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: Infos about fstab..

Expand Messages
  • Mark Zander
    ... The reason you re seeing the /media/sda3 is due to the Udev automount script. When you insert a disk/device Udev will try to set it up and allows special
    Message 1 of 3 , Oct 22, 2006
    • 0 Attachment
      Simon wrote:
      >
      >
      > --- In nslu2-general@yahoogroups.com
      > <mailto:nslu2-general%40yahoogroups.com>, "synko_ndu" <synko_ndu@...> wrote:
      > >
      > > hello to everyone,
      > >
      > > ive found an issue with da fstab and mount command on OpenSlug:
      > >
      > > they unmatch their results
      > >
      > > cat fstab
      > > -------------------------------
      > > /dev/sda1 / ext3 defaults 1 1
      > > /dev/sda3 /var/www ext3 default 1 1
      > > proc /proc proc defaults 0 0
      > > tmpfs /media/ram tmpfs defaults 0 0
      > > usbfs /proc/bus/usb usbfs defaults 0 0
      > > -------------
      > >
      > >
      > > mount
      > > ------------------------------
      > > rootfs on / type rootfs (rw)
      > > /dev/root on /initrd type jffs2 (ro)
      > > /dev/sda1 on / type ext3 (rw,data=ordered)
      > > proc on /proc type proc (rw)
      > > sysfs on /sys type sysfs (rw)
      > > /dev/sda1 on /dev/.static/dev type ext3 (rw,data=ordered)
      > > tmpfs on /dev type tmpfs (rw)
      > > ------>>>/dev/sda3 on /media/sda3 type ext3 (rw,sync,data=ordered)
      > > /dev/sda3 on /var/www type ext3 (rw,sync,data=ordered)
      > > tmpfs on /media/ram type tmpfs (rw)
      > > usbfs on /proc/bus/usb type usbfs (rw)
      > > devpts on /dev/pts type devpts (rw)
      > > ----------------------------
      > >
      > > the mistake is composed by the /dev/sda3 partition with /media/sda3
      > > because i dont want to mount it in this way. But only mount sda3 in
      > > /var/www. Ive never set up it in this dir (/media/sda3) so i think its
      > > automatic setting that came up after a new installation, but i cannot
      > > disable it!
      > >
      > > Im sorry for my bad english but i hope this communication work.
      > >
      > >
      > > thanks to everyone
      > > Greetings
      > > SyNko
      > >
      >
      > typo in fstab? (default>>defaults)
      >

      The reason you're seeing the /media/sda3 is due to the Udev automount
      script. When you insert a disk/device Udev will try to set it up and
      allows special scripts to be run. There is just such a script in
      '/etc/udev/scripts' that will 'attempt' to mount the filesystems on any
      disk that you insert.
      If you don't want any disk to automount when it is inserted you will
      have to remove the '/etc/udev/scripts/mount.sh'


      Zander.
    Your message has been successfully submitted and would be delivered to recipients shortly.