Loading ...
Sorry, an error occurred while loading the content.

Problem mounting usb under openslug

Expand Messages
  • Dean Dodd
    I have just loaded openslug 3.10 from the binary, I have created 3 partitions on my usb memory stick but when I try to turnup or mount one of the partitions I
    Message 1 of 2 , Aug 2, 2006
    • 0 Attachment
      I have just loaded openslug 3.10 from the binary, I have created 3
      partitions on my usb memory stick but when I try to turnup or mount
      one of the partitions I get

      root@slug:/media/cf# mount /dev/sda1 /media/flash -t ext3
      mount: wrong fs type, bad option, bad superblock on /dev/sda1,
      missing codepage or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so

      Are there any kernal modules required or am I missing something?

      I have been following this wiki
      http://www.nslu2-linux.org/wiki/OpenSlug/InitialisingOpenSlug

      Thanks
    • Dean Dodd
      I have been able to use a hard drive no problem, samba works etc but everytime I try to mount the USB stick it fails with the same error. I can fdisk,
      Message 2 of 2 , Aug 3, 2006
      • 0 Attachment
        I have been able to use a hard drive no problem, samba works etc but
        everytime I try to mount the USB stick it fails with the same error.
        I can fdisk, mkfs.ext3 but mount does not want to work at all, also
        running a fsck on the stick finds lots of errors.

        Are there additional kernal modules missing that are required for usb
        sticks? Maybe my usb stick is broken? The USB stick worked ok under
        unslung.

        Any ideas anyone?!

        --- In nslu2-general@yahoogroups.com, "Dean Dodd" <dean_dodd@...> wrote:
        >
        > I have just loaded openslug 3.10 from the binary, I have created 3
        > partitions on my usb memory stick but when I try to turnup or mount
        > one of the partitions I get
        >
        > root@slug:/media/cf# mount /dev/sda1 /media/flash -t ext3
        > mount: wrong fs type, bad option, bad superblock on /dev/sda1,
        > missing codepage or other error
        > In some cases useful info is found in syslog - try
        > dmesg | tail or so
        >
        > Are there any kernal modules required or am I missing something?
        >
        > I have been following this wiki
        > http://www.nslu2-linux.org/wiki/OpenSlug/InitialisingOpenSlug
        >
        > Thanks
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.