Loading ...
Sorry, an error occurred while loading the content.

Re: Disk not recongized for unslinging

Expand Messages
  • oyvindwe
    ... address Problem solved! I realized that I also had the Fail to get Samba information problem, and followed the procedure of reflashing and then
    Message 1 of 2 , Jul 23, 2006
    • 0 Attachment
      --- In nslu2-general@yahoogroups.com, "oyvindwe" <oyvindwe@...> wrote:
      > Now, I am going to unsling. However, when I connect the disk after
      > telnetting into my slug, it does not show up. /var/log/messages
      > contains the following:
      >
      > <46>Jul 19 22:31:07 klogd: hub.c: new USB device 00:01.2-2, assigned
      > address 2
      > <44>Jul 19 22:31:07 klogd: Device descriptor:8 bytes received.
      > <44>Jul 19 22:31:07 klogd: Device descriptor:18 bytes received.
      > <44>Jul 19 22:31:07 klogd: Protocol: Transparent SCSI
      > <44>Jul 19 22:31:07 klogd: *** detect:usb-storage
      > <44>Jul 19 22:31:07 klogd: * scsi_register: usb-storage-0,
      > <44>Jul 19 22:31:07 klogd: * scsi_reg, hostno:0 prot is 50
      > <44>Jul 19 22:31:07 klogd: * scsi_reg, retval->host_no:0
      > <46>Jul 19 22:31:07 klogd: scsi0 : SCSI emulation for USB Mass Storage
      > devices
      > <44>Jul 19 22:31:07 klogd: ! scan_scsis
      > <42>Jul 19 22:31:42 klogd: usb-storage: host_reset() requested but not
      > implemented
      > <46>Jul 19 22:31:52 klogd: scsi: device set offline - command error
      > recover failed: host 0 channel 0 id 0 lun 0
      > <47>Jul 19 22:31:52 klogd: WARNING: USB Mass Storage data integrity
      > not assured
      > <47>Jul 19 22:31:52 klogd: USB Mass Storage device found at 2
      >
      > Trying to mount results in:
      > mount: Mounting /dev/sda1 on /mnt/tmpmnt failed: No such device or
      address

      Problem solved!

      I realized that I also had the "Fail to get Samba information"
      problem, and followed the procedure of reflashing and then immediatly
      reset the sysconfig, which cleared out both problems!

      I have now successfully unslung. However, the slug had some problems
      with mounting the disk during after being unslung, all resulting in
      the USB disk set offline. I ran fsck on it from a Linux PC, which
      claimed no errors, and gave it a final try; voila! and it booted from
      the disk!

      Now I'm gonna add some packages. :-)

      -√ėyvind
    Your message has been successfully submitted and would be delivered to recipients shortly.