Loading ...
Sorry, an error occurred while loading the content.
 

OpenSSH

Expand Messages
  • Niklas Söderberg
    Hi all! I m trying to get access to my slug using OpenSSH, but without success... I ve followed the instructions at
    Message 1 of 5 , Jul 5, 2006
      Hi all!
      I'm trying to get access to my slug using OpenSSH, but without success...
      I've followed the instructions at
      http://www.nslu2-linux.org/wiki/HowTo/UseOpenSSHForRemoteAccess, but when I
      connect with Putty the server keeps asking for my passphrase. I've checked
      and re-checked all permissions for /root, /root/.ssh and authorized_keys,
      I've tried fiddling with some options for OpenSSH, but I cant get it to stop
      asking for my passphrase. There is nothing in /var/log/messages indicating a
      failure of some sort. If I enter my passphrase I get logged in ok, but I
      thought the whole point with using my private key for logging in was to not
      having to enter the passphrase all the time?

      Got any ideas where I've gone wrong?

      Running Unslung 5.5.

      Thanks,
      Niklas


      [Non-text portions of this message have been removed]
    • Mark de Bokx
      It all depends on how you configure your SSH. The purpouse of public/private key authentication is that you have to enter your passphrase when you log in, if
      Message 2 of 5 , Jul 5, 2006
        It all depends on how you configure your SSH.

        The purpouse of public/private key authentication is that you have to enter your passphrase when you log in, if you dont want to use this kind of authentication use password based authentication.

        Regards,

        Mark.

        Niklas S�derberg <niklas.soderberg@...> wrote: Hi all!
        I'm trying to get access to my slug using OpenSSH, but without success...
        I've followed the instructions at
        http://www.nslu2-linux.org/wiki/HowTo/UseOpenSSHForRemoteAccess, but when I
        connect with Putty the server keeps asking for my passphrase. I've checked
        and re-checked all permissions for /root, /root/.ssh and authorized_keys,
        I've tried fiddling with some options for OpenSSH, but I cant get it to stop
        asking for my passphrase. There is nothing in /var/log/messages indicating a
        failure of some sort. If I enter my passphrase I get logged in ok, but I
        thought the whole point with using my private key for logging in was to not
        having to enter the passphrase all the time?

        Got any ideas where I've gone wrong?

        Running Unslung 5.5.

        Thanks,
        Niklas

        [Non-text portions of this message have been removed]





        __________________________________________________
        Do You Yahoo!?
        Tired of spam? Yahoo! Mail has the best spam protection around
        http://mail.yahoo.com

        [Non-text portions of this message have been removed]
      • Steve Gane
        You need an SSH Agent (such as Pageant that comes from the same place as Putty). This runs on your PC and automatically supplies your passphrase. You still
        Message 3 of 5 , Jul 5, 2006
          You need an SSH Agent (such as Pageant that comes from the same place
          as Putty). This runs on your PC and automatically supplies your
          passphrase. You still have to enter your passphrase once into pagaent
          every time you start your PC, but not at every login.

          --- In nslu2-general@yahoogroups.com, "Niklas Söderberg"
          <niklas.soderberg@...> wrote:
          >
          > Hi all!
          > I'm trying to get access to my slug using OpenSSH, but without
          success...
          > I've followed the instructions at
          > http://www.nslu2-linux.org/wiki/HowTo/UseOpenSSHForRemoteAccess, but
          when I
          > connect with Putty the server keeps asking for my passphrase. I've
          checked
          > and re-checked all permissions for /root, /root/.ssh and
          authorized_keys,
          > I've tried fiddling with some options for OpenSSH, but I cant get it
          to stop
          > asking for my passphrase. There is nothing in /var/log/messages
          indicating a
          > failure of some sort. If I enter my passphrase I get logged in ok, but I
          > thought the whole point with using my private key for logging in was
          to not
          > having to enter the passphrase all the time?
          >
          > Got any ideas where I've gone wrong?
          >
          > Running Unslung 5.5.
          >
          > Thanks,
          > Niklas
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • Matt McNeill
          Have you followed *Both* steps in the section Prevent Unauthorized User Access on the wiki page you quoted? With these changes it should not request a
          Message 4 of 5 , Jul 5, 2006
            Have you followed *Both* steps in the section "Prevent Unauthorized User
            Access" on the wiki page you quoted? With these changes it should not
            request a password (not same as passphrase).

            On another note, it may be a Putty problem. Your PRIVATE key will be
            encrypted locally with a passphrase. If it is not loaded into Pageant
            (icon in the system tray) then putty will ask you for your passphrase
            when you authenticate in order to locally decrypt the PRIVATE key and
            then begin the key-based authentication with the server.

            Try loading your key in pageant first, then connecting your putty terminal.

            Matt


            Niklas Söderberg wrote:
            > Hi all!
            > I'm trying to get access to my slug using OpenSSH, but without success...
            > I've followed the instructions at
            > http://www.nslu2-linux.org/wiki/HowTo/UseOpenSSHForRemoteAccess, but when I
            > connect with Putty the server keeps asking for my passphrase. I've checked
            > and re-checked all permissions for /root, /root/.ssh and authorized_keys,
            > I've tried fiddling with some options for OpenSSH, but I cant get it to stop
            > asking for my passphrase. There is nothing in /var/log/messages indicating a
            > failure of some sort. If I enter my passphrase I get logged in ok, but I
            > thought the whole point with using my private key for logging in was to not
            > having to enter the passphrase all the time?
            >
            > Got any ideas where I've gone wrong?
            >
            > Running Unslung 5.5.
            >
            > Thanks,
            > Niklas
            >
            >
            > [Non-text portions of this message have been removed]
            >
            >
            >
            >
          • Niklas Söderberg
            Matt, Thanks for the tip about Pageant, I d totally missed that! Everything works like expected now. Gonna put a line about it in the wiki, if there are more
            Message 5 of 5 , Jul 6, 2006
              Matt,

              Thanks for the tip about Pageant, I'd totally missed that! Everything works
              like expected now. Gonna put a line about it in the wiki, if there are more
              newbies like me around :-)

              //Niklas



              On 7/5/06, Matt McNeill <matt_mcneill@...> wrote:
              >
              > Have you followed *Both* steps in the section "Prevent Unauthorized User
              > Access" on the wiki page you quoted? With these changes it should not
              > request a password (not same as passphrase).
              >
              > On another note, it may be a Putty problem. Your PRIVATE key will be
              > encrypted locally with a passphrase. If it is not loaded into Pageant
              > (icon in the system tray) then putty will ask you for your passphrase
              > when you authenticate in order to locally decrypt the PRIVATE key and
              > then begin the key-based authentication with the server.
              >
              > Try loading your key in pageant first, then connecting your putty
              > terminal.
              >
              > Matt
              >
              >
              > Niklas Söderberg wrote:
              > > Hi all!
              > > I'm trying to get access to my slug using OpenSSH, but without
              > success...
              > > I've followed the instructions at
              > > http://www.nslu2-linux.org/wiki/HowTo/UseOpenSSHForRemoteAccess, but
              > when I
              > > connect with Putty the server keeps asking for my passphrase. I've
              > checked
              > > and re-checked all permissions for /root, /root/.ssh and
              > authorized_keys,
              > > I've tried fiddling with some options for OpenSSH, but I cant get it to
              > stop
              > > asking for my passphrase. There is nothing in /var/log/messages
              > indicating a
              > > failure of some sort. If I enter my passphrase I get logged in ok, but I
              > > thought the whole point with using my private key for logging in was to
              > not
              > > having to enter the passphrase all the time?
              > >
              > > Got any ideas where I've gone wrong?
              > >
              > > Running Unslung 5.5.
              > >
              > > Thanks,
              > > Niklas
              > >
              > >
              > > [Non-text portions of this message have been removed]
              > >
              > >
              > >
              > >
              >
              >
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >
              >


              [Non-text portions of this message have been removed]
            Your message has been successfully submitted and would be delivered to recipients shortly.