Loading ...
Sorry, an error occurred while loading the content.

makefile errors

Expand Messages
  • ubergeek_john
    Great work you ve all done and continue to do. I ve been running debianslug since January, and have just got around to rebuilding everything to the latest
    Message 1 of 1 , Jun 29, 2006
    • 0 Attachment
      Great work you've all done and continue to do.

      I've been running debianslug since January, and have just got around
      to rebuilding everything to the latest version. Using Ubuntu Dapper
      Drake on an nc6000 as my build machine, I have downloaded the latest
      Makefile (several times :) and get the following error every time I
      run 'make setup-host-ubuntu':
      <code>-su: -c: line 0: syntax error near unexpected token `('</code>

      I've managed to isolate the error to the following lines in the Makefile:
      <quote>
      bzip2 ;\
      echo You will have to install monotone separately. See
      http://venge.net/monotone/ \
      echo To get python2.4-psyco (Recommended to speed up builds), please
      read \
      echo http://ubuntuguide.org/#extrarepositories \
      "
      </quote>

      May I suggest the following change?
      <quote>
      bzip2 ;
      "
      @printf \\n"PLEASE NOTE:"\\n
      @printf "You will have to install monotone separately, see
      http://venge.net/monotone/"\\n
      @printf "To get python2.4-psyco (Recommended to speed up builds),
      please read"\\n
      @printf "http://ubuntuguide.org/#extrarepositories"\\n\\n
      </quote>

      If that works for everyone involved, I've also diffed (-Nau) the
      change, and am appending that here.
      -------------------------------------------------------------------
      --- Makefile 2006-06-16 20:10:20.000000000 -0400
      +++ Makefile.patched 2006-06-29 16:26:42.000000000 -0400
      @@ -475,11 +475,12 @@
      unzip \
      subversion \
      texinfo \
      - bzip2 ;\
      - echo You will have to install monotone separately. See
      http://venge.net/monotone/ \
      - echo To get python2.4-psyco (Recommended to speed up builds),
      please read \
      - echo http://ubuntuguide.org/#extrarepositories \
      + bzip2 ;
      "
      + @printf \\n"PLEASE NOTE:"\\n
      + @printf "You will have to install monotone separately, see
      http://venge.net/monotone/"\\n
      + @printf "To get python2.4-psyco (Recommended to speed up
      builds), please read"\\n
      + @printf "http://ubuntuguide.org/#extrarepositories"\\n\\n


      .PHONY: setup-host-gentoo
    Your message has been successfully submitted and would be delivered to recipients shortly.