Loading ...
Sorry, an error occurred while loading the content.

Re: Firmware update problems

Expand Messages
  • go4nslu2
    ... as ... I ... re- ... hi oo03par, i had my nslu2 hanging in a different way, firmware was not implanted right so my nslu2 gave me a green/red blinking
    Message 1 of 12 , Nov 1, 2004
    • 0 Attachment
      --- In nslu2-general@yahoogroups.com, "oo03par" <oo03par@y...> wrote:
      >
      >
      > I've just bought a brand new NSLU2, which I ultimately want to act
      as
      > an iTunes server.
      >
      > Trying firmware update [both uNSLUng and standard LinkSys] and all
      I
      > get after about 5 minutes is IE or Opera timing out.
      >
      > When I go back to 192.168.1.77 it all seems fine, but if I try to
      re-
      > start via the admin option [Administration|Status|Restart Now] it
      > says "A firmware upgrade is in progress".
      >
      > I have left it for hours, but to no avail, so I turn it off and on
      > [after which the box is fine] and the firmware still says v2.3R24.
      >
      > I've tried with and without Telnet access turned on, and with and
      > without a USB2 drive in there, but all to no avail.
      >
      > Help!

      hi oo03par,

      i had my nslu2 hanging in a different way, firmware was not
      implanted right so my nslu2 gave me a green/red blinking status
      light.
      simple man i am i searched on nslu2 green/red light and found a page
      telling me how to "unbrick" my nslu2 tru a backdoor.
      seems they found a way to connect into the nslu2 when he is starting
      up, without any password required u can access the nslu2 on telnet
      and upload the fiemware it's a bit trickey cuz u gotta connect at
      the right time and hit ctrl+c in a fast way (between the 2.0 and 0.1
      second) i messed abit with that and i actualy got it to work
      uploaded the firmware etc. now my nslu2 is as new :-)

      the link to that page is
      http://www.tongfamily.com/guide/pcs/2004/09/15/unbricking_your_nslu2.
      html

      suc6, and good luck
    • rwhitby
      ... You can find that and lots more useful information in the NSLU2-Linux wiki (www.nslu2-linux.org). Feel free to add any useful info you find out. -- Rod
      Message 2 of 12 , Nov 2, 2004
      • 0 Attachment
        On Mon, 01 Nov 2004 22:42:36 -0000, go4nslu2 <go4nslu2@...> wrote:
        > simple man i am i searched on nslu2 green/red light and found a page
        > telling me how to "unbrick" my nslu2 tru a backdoor.
        >
        > the link to that page is
        > http://www.tongfamily.com/guide/pcs/2004/09/15/unbricking_your_nslu2.
        > html

        You can find that and lots more useful information in the NSLU2-Linux
        wiki (www.nslu2-linux.org). Feel free to add any useful info you find
        out.

        -- Rod
      • oo03par
        ... Thanks go4nslu2 ! I ve tried that one already though - I can get to the telnet backdoor no problem [using PuTTY as my telnet client], but I can t see the
        Message 3 of 12 , Nov 3, 2004
        • 0 Attachment
          --- In nslu2-general@yahoogroups.com, "go4nslu2" <go4nslu2@y...>
          wrote:
          > i had my nslu2 hanging in a different way, firmware was not
          > implanted right so my nslu2 gave me a green/red blinking status
          > light.
          > simple man i am i searched on nslu2 green/red light and found a page
          > telling me how to "unbrick" my nslu2 tru a backdoor.

          Thanks "go4nslu2"!

          I've tried that one already though - I can get to the telnet backdoor
          no problem [using PuTTY as my telnet client], but I can't see the TFTP
          server running on my box. I've tried a couple of free / o/s TFTP
          servers, but the box can't see it.

          I'm still convinved it is something to do with my network card
          settings because of my second post [not able to copy files > 32K], but
          I've tried updating one of the pcs with the latest NForce drivers, and
          this didn't help.

          Anyone know of another TFTP server for WindowsXP I can try? TIA

          Phil
        • rwhitby
          ... You know that you can use a HTTP server instead of a TFTP server, right? Add -m http and give the URL pathname from / of the file on your HTTP server.
          Message 4 of 12 , Nov 3, 2004
          • 0 Attachment
            On Wed, 03 Nov 2004 11:06:11 -0000, oo03par <oo03par@...> wrote:
            > I've tried that one already though - I can get to the telnet backdoor
            > no problem [using PuTTY as my telnet client], but I can't see the TFTP
            > server running on my box. I've tried a couple of free / o/s TFTP
            > servers, but the box can't see it.

            You know that you can use a HTTP server instead of a TFTP server, right?

            Add "-m http" and give the URL pathname from / of the file on your HTTP server.

            http://www.nslu2-linux.org/wiki/HowTo/RecoverFromABadFlash

            -- Rod
          • go4nslu2
            ... page ... backdoor ... TFTP ... but ... and ... hey Phil, i used the solarwinds free tftp version on my xp machine for it and had no problems here is the
            Message 5 of 12 , Nov 3, 2004
            • 0 Attachment
              --- In nslu2-general@yahoogroups.com, "oo03par" <oo03par@y...> wrote:
              >
              > --- In nslu2-general@yahoogroups.com, "go4nslu2" <go4nslu2@y...>
              > wrote:
              > > i had my nslu2 hanging in a different way, firmware was not
              > > implanted right so my nslu2 gave me a green/red blinking status
              > > light.
              > > simple man i am i searched on nslu2 green/red light and found a
              page
              > > telling me how to "unbrick" my nslu2 tru a backdoor.
              >
              > Thanks "go4nslu2"!
              >
              > I've tried that one already though - I can get to the telnet
              backdoor
              > no problem [using PuTTY as my telnet client], but I can't see the
              TFTP
              > server running on my box. I've tried a couple of free / o/s TFTP
              > servers, but the box can't see it.
              >
              > I'm still convinved it is something to do with my network card
              > settings because of my second post [not able to copy files > 32K],
              but
              > I've tried updating one of the pcs with the latest NForce drivers,
              and
              > this didn't help.
              >
              > Anyone know of another TFTP server for WindowsXP I can try? TIA
              >
              > Phil

              hey Phil,

              i used the solarwinds free tftp version on my xp machine for it and
              had no problems here is the link for the download page on that 1
              http://support.solarwinds.net/updates/SelectProgramFree.cfm

              be sure to put the firmware file in your tftp directory or set the
              used tftp directory to the directory u hold the firmware in.

              hook up the nslu2 directly to your pc with a crosslink cable and
              shut down any firewall running (np there cuz u dont have connection
              to anything but the box) i used the standard telnet proggy of winxp
              and had more trouble pushing ctrl+c then to telnet to the box and/or
              use the solarwinds tftp server.

              suc6 Phil :-)

              Henk
            • oo03par
              ... Thanks Henk - managed to get the firmware update done via the TFTP now. Thanks to Rod as well for the HTTP tip [sadly didn t work as Tomcat didn t want to
              Message 6 of 12 , Nov 3, 2004
              • 0 Attachment
                --- In nslu2-general@yahoogroups.com, "go4nslu2" <go4nslu2@y...>
                wrote:
                > i used the solarwinds free tftp version on my xp machine for it and
                > had no problems here is the link for the download page on that 1
                > http://support.solarwinds.net/updates/SelectProgramFree.cfm
                >
                > be sure to put the firmware file in your tftp directory or set the
                > used tftp directory to the directory u hold the firmware in.
                >
                > hook up the nslu2 directly to your pc with a crosslink cable and
                > shut down any firewall running (np there cuz u dont have connection
                > to anything but the box) i used the standard telnet proggy of winxp
                > and had more trouble pushing ctrl+c then to telnet to the box and/or
                > use the solarwinds tftp server.
                >
                > suc6 Phil :-)
                >
                > Henk

                Thanks Henk - managed to get the firmware update done via the TFTP
                now. Thanks to Rod as well for the HTTP tip [sadly didn't work as
                Tomcat didn't want to serve the .bin file!]

                I'm still getting the same problem of "Unable to copy xxxx: The path
                is too deep" which looks like a Samba set up issue on my pc.

                I've upgraded my NForce drivers, but that hasn't fixed it. Drawing
                board here I come!

                Phil
              • go4nslu2
                ... anyone ... network ... have ... how do u connect to the share tru your webbrowser ? or tru a mapped network drive ?? i could connect fine tru the mapped
                Message 7 of 12 , Nov 3, 2004
                • 0 Attachment
                  --- In nslu2-general@yahoogroups.com, "oo03par" <oo03par@y...> wrote:
                  >
                  > I think I may have worked out why this is happening, in case
                  anyone
                  > else is getting the problem.
                  >
                  > When I connect to a share on the NSLU and copy a file, small files
                  > work fine, but large files [>32K] fail with the following message:
                  >
                  > "Cannot Copy <filename>: The path is too deep"
                  >
                  > Searching Google doesn't help much - people are saying it is a
                  network
                  > config issue [which it isn't, as I've tried two separate pcs, two
                  > different hubs and several different network configurations] or a
                  > driver issue [which it could be - haven't tried that yet].
                  >
                  > The pcs I am attempting to connect are both WinXP SP2, and both
                  have
                  > NVidia NForce motherboards, so it could be the NForce driver.
                  >
                  > I'll keep you informed...

                  how do u connect to the share tru your webbrowser ? or tru a mapped
                  network drive ??

                  i could connect fine tru the mapped drive but all hang when i did
                  tru webbrowser if i downloaded a file the nslu2 hang problem was the
                  chipset in my usb enclosure i have another 1 now and all is fine

                  Henk
                • oo03par
                  ... Tried via a mapped drive and just going straight to the ip-address [ 192.168.0.77 ] in Explorer. I can connect, and I can create and copy small files.
                  Message 8 of 12 , Nov 4, 2004
                  • 0 Attachment
                    --- In nslu2-general@yahoogroups.com, "go4nslu2" <go4nslu2@y...>
                    wrote:
                    > how do u connect to the share tru your webbrowser ? or tru a mapped
                    > network drive ??
                    >
                    > i could connect fine tru the mapped drive but all hang when i did
                    > tru webbrowser if i downloaded a file the nslu2 hang problem was the
                    > chipset in my usb enclosure i have another 1 now and all is fine
                    >
                    > Henk

                    Tried via a mapped drive and just going straight to the ip-address
                    [\\192.168.0.77\] in Explorer.

                    I can connect, and I can create and copy small files. Just not large
                    ones.

                    The drive I have is a Lacie 250Gb drive [ http://www.lacie.com/
                    products/product.htm?pid=10468 ] if that's any help - maybe there's
                    problems with it [in which case, bang goes that plan]

                    I do have another USB2 hard drive, but the drive itself is corrupted
                    so I am loathe to use it, but I'll give it a go.
                  • go4nslu2
                    ... mapped ... did ... the ... large ... there s ... corrupted ... did u use the lacie drive on your windows computer before u plugged it into the nslu2 ?? in
                    Message 9 of 12 , Nov 4, 2004
                    • 0 Attachment
                      --- In nslu2-general@yahoogroups.com, "oo03par" <oo03par@y...> wrote:
                      >
                      > --- In nslu2-general@yahoogroups.com, "go4nslu2" <go4nslu2@y...>
                      > wrote:
                      > > how do u connect to the share tru your webbrowser ? or tru a
                      mapped
                      > > network drive ??
                      > >
                      > > i could connect fine tru the mapped drive but all hang when i
                      did
                      > > tru webbrowser if i downloaded a file the nslu2 hang problem was
                      the
                      > > chipset in my usb enclosure i have another 1 now and all is fine
                      > >
                      > > Henk
                      >
                      > Tried via a mapped drive and just going straight to the ip-address
                      > [\\192.168.0.77\] in Explorer.
                      >
                      > I can connect, and I can create and copy small files. Just not
                      large
                      > ones.
                      >
                      > The drive I have is a Lacie 250Gb drive [ http://www.lacie.com/
                      > products/product.htm?pid=10468 ] if that's any help - maybe
                      there's
                      > problems with it [in which case, bang goes that plan]
                      >
                      > I do have another USB2 hard drive, but the drive itself is
                      corrupted
                      > so I am loathe to use it, but I'll give it a go.

                      did u use the lacie drive on your windows computer before u plugged
                      it into the nslu2 ?? in my case if i used the usb enclosure on my
                      winxp machine and copied large and/or many files to it it gave me
                      a "delayed write error" message. that was for me the sign to look
                      into things and i discovered the chipset was a genesys logic wich
                      wont work 100% with usb 2.0 connections the data seems to pile up
                      and cant be procesed (spell check).
                      i gues its best if u mail lacie and ask them what chipset drives
                      your drive enclosure and then look into the database here @ "devices
                      tested" and see if the chipset is mentioned there.

                      there are 2 lacie drives in the database that both work but u never
                      know if they changed chipsets along production.

                      Henk
                    • oo03par
                      Solved it!!!!!! [well the copying problem at least] This may also help Mike with his Problems with XP SP2 in the other thread. I ve just had my ISDN line
                      Message 10 of 12 , Nov 11, 2004
                      • 0 Attachment
                        Solved it!!!!!! [well the copying problem at least]

                        This may also help Mike with his "Problems with XP SP2" in the other
                        thread.

                        I've just had my ISDN line removed from home, as I am getting it
                        upgraded to ADSL, and so I removed the 3COM ISDN Lan Modem that I had
                        in my network and plugged everything directly into my 3COM 100Mb
                        Switch.

                        I also removed the "Default gateway" and "DNS Server" settings from
                        all devices on the network [NSLU2, other pcs] and a reboot later and
                        this has done the trick.

                        Able to copy large files across [CD images of 600Mb copied] with no
                        worries.

                        I'll post details of the drive I'm using when I get home tonight, and
                        I'll update the Wiki just in case anyone else gets the same issue.

                        Thanks everyone for the suggestions.

                        Phil
                      Your message has been successfully submitted and would be delivered to recipients shortly.