Loading ...
Sorry, an error occurred while loading the content.

RE: [nslu2-general] NSLU2 and IIS

Expand Messages
  • Phil Harris
    You may have IIS set up to use an anonymous user. This allows an anonymous user to browse to your website, however, any authetication is done as IUSR_Machine
    Message 1 of 3 , Feb 1, 2006
    • 0 Attachment
      You may have IIS set up to use an anonymous user. This allows an anonymous user to browse to your website, however, any authetication is done as IUSR_Machine name. You can force IIS to authenticate you by selecting the properties of your web server, then selecting the Directory security tab. Select the edit button in the authentication area, then clear the anonymous access check box (this is also where you can see the account being used by your anonymous user). Now when you brose to your web page you will be prompted for a user name and password. You will authenticate against your windows box. If your windows user name and passwor d match the username and password you have set on your Slug then all should work well. Play with the security settings a little bit and I am sure you can get it working.

      If you are still having problems let me know. I will fire up my IIS box and give you better directions.

      Good luck
      Phil

      -----Original Message-----
      From: shawnskc [mailto:shawncummins@...]
      Sent: Monday, January 30, 2006 8:38 PM
      To: nslu2-general@yahoogroups.com
      Subject: [nslu2-general] NSLU2 and IIS


      I have a question I have been researching for a few days now to no
      avail.

      I have a Nslu2 with the latest Linksys firmware installed with a
      shared folder called "web". Web contains all of my folders and files
      for my website. from the properties of my website in iis, i clicked
      on the "Home directory" tab and i checked the "A share location on
      another computer" radio button. In the "network directory" text box,
      i put "\\externaldrives\web" (externaldrives is the name of my
      nslu2). then i put the approporate permissions in the "connect as"
      form.

      Now, after this, i can view the directories from within IIS but when
      i go to the site, i get "you dont have authorization to view this
      site." error message.

      Has anyone tried to do this before? Did you get it to work?
      I would like to do this with the linksys firmware installed.

      I would appreciate any help/direction

      thank you very much,
      shawn
      [ads removed by moderator - please remove all ads from your reply messages]
    Your message has been successfully submitted and would be delivered to recipients shortly.