Loading ...
Sorry, an error occurred while loading the content.

CUPS Printer stopped working after addition of USB hub...

Expand Messages
  • jar240
    My Lexmark E210 was working flawlessly using CUPS and on /dev/usb/lp0 attached to the slug s USB DISK 2 port. One drive attached to USB DISK 1 port. Unslung
    Message 1 of 4 , Sep 1, 2005
    • 0 Attachment
      My Lexmark E210 was working flawlessly using CUPS and on /dev/usb/lp0
      attached to the slug's USB DISK 2 port. One drive attached to USB DISK
      1 port. Unslung 5.5 beta.

      After powering down the slug, I disconnected the the printer cable
      from USB DISK 2, and plugged in my D-Link USB 2.0 hub. I then
      connected a second drive and the printer to the hub.

      Powered it up, and it sees the second drive just fine; it's formatted
      now and has data on it. Printer is a no go. I tried a different port
      on the hub, but still no go. CUPS says there's no device
      on /dev/usb/lp0.

      I tried mknod /dev/usb/lp1...etc. but it didn't help. I tried
      removing all the usb lpX and recereating, but it didn't help. I also
      tried changing the printer's pointer to /dev/usb/lp1, etc. To no
      avail.

      Any ideas?

      Thanks,
      Chris
    • Inge B. Arnesen
      Yes - it is a FAQ - 2.0 hubs don t work well on Unslung
      Message 2 of 4 , Sep 1, 2005
      • 0 Attachment
        Yes - it is a FAQ - 2.0 hubs don't work well on Unslung <=5.5. This is not
        only storage devices, but any devices.

        Please add this to the FAQ if the last guy didn't do it.

        best,

        -- Inge



        > My Lexmark E210 was working flawlessly using CUPS and on /dev/usb/lp0
        > attached to the slug's USB DISK 2 port. One drive attached to USB DISK
        > 1 port. Unslung 5.5 beta.
        >
        > After powering down the slug, I disconnected the the printer cable
        > from USB DISK 2, and plugged in my D-Link USB 2.0 hub. I then
        > connected a second drive and the printer to the hub.
        >
        > Powered it up, and it sees the second drive just fine; it's formatted
        > now and has data on it. Printer is a no go. I tried a different port
        > on the hub, but still no go. CUPS says there's no device
        > on /dev/usb/lp0.
        >
        > I tried mknod /dev/usb/lp1...etc. but it didn't help. I tried
        > removing all the usb lpX and recereating, but it didn't help. I also
        > tried changing the printer's pointer to /dev/usb/lp1, etc. To no
        > avail.
        >
        > Any ideas?
        >
        > Thanks,
        > Chris
        >
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
      • jar240
        ... is not ... Ah, okay. I checked the FAQ, and it is in there. The strange thing is, why would the USB 2.0 hard drive I also have attached to the hub work
        Message 3 of 4 , Sep 1, 2005
        • 0 Attachment
          --- In nslu2-general@yahoogroups.com, "Inge B. Arnesen"
          <i.b.arnesen@f...> wrote:
          > Yes - it is a FAQ - 2.0 hubs don't work well on Unslung <=5.5. This
          is not
          > only storage devices, but any devices.
          >
          > Please add this to the FAQ if the last guy didn't do it.

          Ah, okay. I checked the FAQ, and it is in there. The strange thing
          is, why would the USB 2.0 hard drive I also have attached to the hub
          work without problem, while the printer doesn't?

          Here's my /proc/bus/usb/devices:

          # cat devices
          T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
          B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
          D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
          P: Vendor=0000 ProdID=0000 Rev= 0.00
          S: Product=USB OHCI Root Hub
          S: SerialNumber=c3880000
          C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
          I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
          E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
          T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 3
          B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
          D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
          P: Vendor=0000 ProdID=0000 Rev= 0.00
          S: Product=USB OHCI Root Hub
          S: SerialNumber=c387a000
          C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
          I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
          E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
          T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 5
          B: Alloc= 0/800 us ( 0%), #Int= 1, #Iso= 0
          D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
          P: Vendor=0000 ProdID=0000 Rev= 2.04
          S: Manufacturer=Linux 2.4.22-xfs ehci_hcd
          S: Product=NEC Corporation USB 2.0
          S: SerialNumber=00:01.2
          C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
          I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
          E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
          T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
          D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
          P: Vendor=06e1 ProdID=d804 Rev= 0.01
          S: Manufacturer=ADS Technologies
          S: Product=USB2.0 Drive Kit
          S: SerialNumber=DEF1098BE4C1
          C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
          I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
          E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
          E: Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
          T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 3 Spd=480 MxCh= 7
          D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
          P: Vendor=2001 ProdID=f103 Rev= 2.00
          S: Manufacturer=D-LINK DUB-H7 USB HUB
          S: Product=DUB-H7
          S: SerialNumber=947337877678 = wired support
          C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
          I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
          E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=256ms
          T: Bus=01 Lev=02 Prnt=03 Port=00 Cnt=01 Dev#= 6 Spd=480 MxCh= 0
          D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
          P: Vendor=14c2 ProdID=0001 Rev= 0.00
          S: Manufacturer=Gemlight
          S: Product=uPD720130
          C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
          I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
          E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
          E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
          T: Bus=01 Lev=02 Prnt=03 Port=03 Cnt=02 Dev#= 6 Spd=480 MxCh= 0
          D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
          P: Vendor=14c2 ProdID=0001 Rev= 0.00
          S: Manufacturer=Gemlight
          S: Product=uPD720130
          C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
          I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
          E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
          E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms


          Chris
        • Inge Bjørnvall Arnesen
          When I said don t work well , I hid some facts. It is not that it doesn t work at all, but the kernel has a local crash and has problems assigning local
          Message 4 of 4 , Sep 2, 2005
          • 0 Attachment
            When I said "don't work well", I hid some facts. It is not that it doesn't
            work at all, but the kernel has a local crash and has problems assigning
            local addresses to USB devices. Like you, I've had success with one device
            connected to a hub, but not two. Check out the log as you connect the second
            device.

            best,

            -- Inge


            ----Original Message----
            From: nslu2-general@yahoogroups.com
            [mailto:nslu2-general@yahoogroups.com] On Behalf Of jar240
            Sent: 2. september 2005 04:23 To:
            nslu2-general@yahoogroups.com Subject: [nslu2-general] Re:
            CUPS Printer stopped working after addition of USB hub...

            > --- In nslu2-general@yahoogroups.com, "Inge B. Arnesen"
            > <i.b.arnesen@f...> wrote:
            > > Yes - it is a FAQ - 2.0 hubs don't work well on Unslung
            > > <=5.5. This
            > is not
            > > only storage devices, but any devices.
            > >
            > > Please add this to the FAQ if the last guy didn't do it.
            >
            > Ah, okay. I checked the FAQ, and it is in there. The
            > strange thing is, why would the USB 2.0 hard drive I also
            > have attached to the hub work without problem, while the
            > printer doesn't?
            >
            > Here's my /proc/bus/usb/devices:
            >
            > # cat devices
            > T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12
            > MxCh= 2
            > B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
            > D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs=
            > 1
            > P: Vendor=0000 ProdID=0000 Rev= 0.00
            > S: Product=USB OHCI Root Hub
            > S: SerialNumber=c3880000
            > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
            > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00
            > Driver=hub
            > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
            > T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12
            > MxCh= 3
            > B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
            > D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs=
            > 1
            > P: Vendor=0000 ProdID=0000 Rev= 0.00
            > S: Product=USB OHCI Root Hub
            > S: SerialNumber=c387a000
            > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
            > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00
            > Driver=hub
            > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
            > T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480
            > MxCh= 5
            > B: Alloc= 0/800 us ( 0%), #Int= 1, #Iso= 0
            > D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs=
            > 1
            > P: Vendor=0000 ProdID=0000 Rev= 2.04
            > S: Manufacturer=Linux 2.4.22-xfs ehci_hcd
            > S: Product=NEC Corporation USB 2.0
            > S: SerialNumber=00:01.2
            > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
            > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00
            > Driver=hub
            > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
            > T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480
            > MxCh= 0
            > D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=
            > 1
            > P: Vendor=06e1 ProdID=d804 Rev= 0.01
            > S: Manufacturer=ADS Technologies
            > S: Product=USB2.0 Drive Kit
            > S: SerialNumber=DEF1098BE4C1
            > C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
            > I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50
            > Driver=usb-storage
            > E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            > E: Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            > T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 3 Spd=480
            > MxCh= 7
            > D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs=
            > 1
            > P: Vendor=2001 ProdID=f103 Rev= 2.00
            > S: Manufacturer=D-LINK DUB-H7 USB HUB
            > S: Product=DUB-H7
            > S: SerialNumber=947337877678 = wired support
            > C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
            > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00
            > Driver=hub
            > E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=256ms
            > T: Bus=01 Lev=02 Prnt=03 Port=00 Cnt=01 Dev#= 6 Spd=480
            > MxCh= 0
            > D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=
            > 1
            > P: Vendor=14c2 ProdID=0001 Rev= 0.00
            > S: Manufacturer=Gemlight
            > S: Product=uPD720130
            > C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
            > I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50
            > Driver=usb-storage
            > E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            > E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            > T: Bus=01 Lev=02 Prnt=03 Port=03 Cnt=02 Dev#= 6 Spd=480
            > MxCh= 0
            > D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=
            > 1
            > P: Vendor=14c2 ProdID=0001 Rev= 0.00
            > S: Manufacturer=Gemlight
            > S: Product=uPD720130
            > C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
            > I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50
            > Driver=usb-storage
            > E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            > E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
            >
            >
            > Chris
            >
            >
            >
            >
            > ------------------------ Yahoo! Groups Sponsor
            > --------------------~-->
            > Most low income households are not online. Help bridge
            > the digital divide today!
            > http://us.click.yahoo.com/cd_AJB/QnQLAA/TtwFAA/CFFolB/TM
            > --------------------------------------------------------------------~->
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.