Loading ...
Sorry, an error occurred while loading the content.
 

RE: [nslu2-general] USB Hub Question

Expand Messages
  • tonymy01
    I have one of these: http://www.peridyme.com.au/index.php?fuseaction=product.view&productid=156 That looks (physically) the same as:
    Message 1 of 6 , Aug 2 8:09 AM
      I have one of these:
      http://www.peridyme.com.au/index.php?fuseaction=product.view&productid=156
      That looks (physically) the same as:
      http://www.targus.com/us/product_details.asp?sku=PAUH217U
      And it has no probs with unslung (apart from the number of the device
      incrementing when hot plugging...)
      I had to mix and match having the hub, HDD, Topfield and usb-serial_pl2303
      cable though. The serial cable is plugged into the 2nd disk/flash port by
      itself (as the driver didn't work for it when plugged into the hub if I
      remember correctly), the hub is in disk1 port with the HDD and Topfield
      plugged into the hub to get it all working together.
      Here is some info that the slug reports about my USB:

      bash-2.05b# pwd
      /proc/bus/usb
      bash-2.05b# cat devices
      T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
      B: Alloc= 18/900 us ( 2%), #Int= 1, #Iso= 0
      D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
      P: Vendor=0000 ProdID=0000 Rev= 0.00
      S: Product=USB OHCI Root Hub
      S: SerialNumber=c3880000
      C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
      I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
      E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
      T: Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
      D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
      P: Vendor=067b ProdID=2303 Rev= 2.02
      C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
      I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=serial
      E: Ad=81(I) Atr=03(Int.) MxPS= 10 Ivl=1ms
      E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
      E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
      T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 3
      B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
      D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
      P: Vendor=0000 ProdID=0000 Rev= 0.00
      S: Product=USB OHCI Root Hub
      S: SerialNumber=c387a000
      C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
      I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
      E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
      T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 5
      B: Alloc= 0/800 us ( 0%), #Int= 1, #Iso= 0
      D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
      P: Vendor=0000 ProdID=0000 Rev= 2.04
      S: Manufacturer=Linux 2.4.22-xfs ehci_hcd
      S: Product=NEC Corporation USB 2.0
      S: SerialNumber=00:01.2
      C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
      I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
      E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
      T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 4
      D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
      P: Vendor=05e3 ProdID=0605 Rev= 6.0b
      S: Product=USB2.0 Hub
      C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=100mA
      I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
      E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=256ms
      T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=113 Spd=480 MxCh= 0
      D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
      P: Vendor=11db ProdID=1000 Rev= 1.01
      S: Manufacturer=Topfield Co., Ltd.
      S: Product=Topfield (http://www.topfield.co.kr)
      S: SerialNumber=1000
      C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
      I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
      E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
      E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
      T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#= 3 Spd=480 MxCh= 0
      D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
      P: Vendor=05e3 ProdID=0702 Rev= 0.33
      S: Product=USB TO IDE
      C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 96mA
      I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
      E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
      E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
      T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 2 Spd=12 MxCh= 0
      D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
      P: Vendor=067b ProdID=2303 Rev= 2.02
      C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
      I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=serial
      E: Ad=81(I) Atr=03(Int.) MxPS= 10 Ivl=1ms
      E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
      E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

      Here is a bit from /var/log/messages
      <46>Aug 2 18:36:59 klogd: hub.c: new USB device 00:01.2-1.3, assigned
      address 112
      <44>Aug 2 18:36:59 klogd: usb.c: USB device 112 (vend/prod 0x11db/0x1000)
      is not claimed by any active driver.
      <46>Aug 2 18:37:06 klogd: usb.c: USB disconnect on device 00:01.2-1.3
      address 112
      <46>Aug 2 18:37:32 klogd: hub.c: new USB device 00:01.2-1.3, assigned
      address 113
      <44>Aug 2 18:37:32 klogd: usb.c: USB device 113 (vend/prod 0x11db/0x1000)
      is not claimed by any active driver.

      (So each time my Topfield powers up, it "double hits" the usb and causes the
      above, I don't think there are detrimental issues at this stage however..)

      Cheers
      Tonymy01
      http://tonyspage.abock.de for Topfield Information



      -----Original Message-----
      From: nslu2-general@yahoogroups.com [mailto:nslu2-general@yahoogroups.com]
      On Behalf Of grahame@...
      Sent: Tuesday, 2 August 2005 11:19 PM
      To: nslu2-general@yahoogroups.com
      Subject: [nslu2-general] USB Hub Question


      Is there anywhere a list of USB hubs that have been tested and known to work
      with Unslung, or should I just go to Openslug? If I could source a hub that
      is known to work then I'll just go buy it just to get this working.

      Gra
    • grahame@falvey.net
      Hi Tony, Thanks for the info. I should be able to source the Targus one here in Austria. Maybe we should start adding the USB hubs and results in the yahoo
      Message 2 of 6 , Aug 3 4:20 AM
        Hi
        Tony,

        Thanks for the info. I should be able to source the Targus one here in
        Austria.

        Maybe we should start adding the USB hubs and results in the yahoo database?

        Gra

        > I have one of these:
        > http://www.peridyme.com.au/index.php?fuseaction=product.view&productid=156
        > That looks (physically) the same as:
        > http://www.targus.com/us/product_details.asp?sku=PAUH217U
        > And it has no probs with unslung (apart from the number of the device
        > incrementing when hot plugging...)
        > I had to mix and match having the hub, HDD, Topfield and
        > usb-serial_pl2303
        > cable though. The serial cable is plugged into the 2nd disk/flash port by
        > itself (as the driver didn't work for it when plugged into the hub if I
        > remember correctly), the hub is in disk1 port with the HDD and Topfield
        > plugged into the hub to get it all working together.
        > Here is some info that the slug reports about my USB:
        >
        > bash-2.05b# pwd
        > /proc/bus/usb
        > bash-2.05b# cat devices
        > T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
        > B: Alloc= 18/900 us ( 2%), #Int= 1, #Iso= 0
        > D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
        > P: Vendor=0000 ProdID=0000 Rev= 0.00
        > S: Product=USB OHCI Root Hub
        > S: SerialNumber=c3880000
        > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
        > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
        > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
        > T: Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
        > D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
        > P: Vendor=067b ProdID=2303 Rev= 2.02
        > C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
        > I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=serial
        > E: Ad=81(I) Atr=03(Int.) MxPS= 10 Ivl=1ms
        > E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
        > E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
        > T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 3
        > B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
        > D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
        > P: Vendor=0000 ProdID=0000 Rev= 0.00
        > S: Product=USB OHCI Root Hub
        > S: SerialNumber=c387a000
        > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
        > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
        > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
        > T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 5
        > B: Alloc= 0/800 us ( 0%), #Int= 1, #Iso= 0
        > D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
        > P: Vendor=0000 ProdID=0000 Rev= 2.04
        > S: Manufacturer=Linux 2.4.22-xfs ehci_hcd
        > S: Product=NEC Corporation USB 2.0
        > S: SerialNumber=00:01.2
        > C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
        > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
        > E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
        > T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 4
        > D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
        > P: Vendor=05e3 ProdID=0605 Rev= 6.0b
        > S: Product=USB2.0 Hub
        > C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=100mA
        > I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
        > E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=256ms
        > T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=113 Spd=480 MxCh= 0
        > D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
        > P: Vendor=11db ProdID=1000 Rev= 1.01
        > S: Manufacturer=Topfield Co., Ltd.
        > S: Product=Topfield (http://www.topfield.co.kr)
        > S: SerialNumber=1000
        > C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
        > I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
        > E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
        > E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
        > T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#= 3 Spd=480 MxCh= 0
        > D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
        > P: Vendor=05e3 ProdID=0702 Rev= 0.33
        > S: Product=USB TO IDE
        > C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 96mA
        > I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
        > E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
        > E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
        > T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 2 Spd=12 MxCh= 0
        > D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
        > P: Vendor=067b ProdID=2303 Rev= 2.02
        > C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
        > I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=serial
        > E: Ad=81(I) Atr=03(Int.) MxPS= 10 Ivl=1ms
        > E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
        > E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
        >
        > Here is a bit from /var/log/messages
        > Aug 2 18:36:59 klogd: hub.c: new USB device 00:01.2-1.3, assigned
        > address 112
        > Aug 2 18:36:59 klogd: usb.c: USB device 112 (vend/prod 0x11db/0x1000)
        > is not claimed by any active driver.
        > Aug 2 18:37:06 klogd: usb.c: USB disconnect on device 00:01.2-1.3
        > address 112
        > Aug 2 18:37:32 klogd: hub.c: new USB device 00:01.2-1.3, assigned
        > address 113
        > Aug 2 18:37:32 klogd: usb.c: USB device 113 (vend/prod 0x11db/0x1000)
        > is not claimed by any active driver.
        >
        > (So each time my Topfield powers up, it "double hits" the usb
        > and causes the
        > above, I don't think there are detrimental issues at this stage
        > however..)
        >
        > Cheers
        > Tonymy01
        > http://tonyspage.abock.de for Topfield Information
        >
        >
        >
        > -----Original Message-----
        > From: nslu2-general@yahoogroups.com
        > [mailto:nslu2-general@yahoogroups.com]
        > On Behalf Of grahame@...
        > Sent: Tuesday, 2 August 2005 11:19 PM
        > To: nslu2-general@yahoogroups.com
        > Subject: [nslu2-general] USB Hub Question
        >
        >
        > Is there anywhere a list of USB hubs that have been tested and known to
        > work
        > with Unslung, or should I just go to Openslug? If I could source a hub
        > that
        > is known to work then I'll just go buy it just to get this working.
        >
        > Gra
        >
        >
        >
        >
        > YAHOO! GROUPS LINKS
        > Visit your group "nslu2-general" on the web.
        > To unsubscribe from this group, send an email to:
        > nslu2-general-unsubscribe@yahoogroups.com
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.