Loading ...
Sorry, an error occurred while loading the content.

Re: Too many problems with NSLU2

Expand Messages
  • w5sdc
    ... provide ... linux? ... Here s an example from my system running RH 9 [root@linux root]# mount //192.168.1.77/public /backup -o password= [root@linux root]#
    Message 1 of 8 , Aug 22, 2004
    • 0 Attachment
      > I have a linux box that I'm experimenting with. Can anyone
      provide
      > some step-by-step instructions for accessing the NSLU2 from
      linux?
      > I'd prefer to start using it from Linux.

      Here's an example from my system running RH 9

      [root@linux root]# mount //192.168.1.77/public /backup -o password=

      [root@linux root]# ls /backup

      boot.txt filesys mac NSLU2 board
      rear.jpg
      Family Pictures Grand Canyon NSLU2 board front.jpg wed

      [root@linux root]#

      public is the name of a share I defined on the NSLU2 that is
      accesible to the world. The ip address is the factory default of the
      box as well. (I have been too lazy to put the NSLU2 in the hosts
      file)

      If you prefer an X-11 frontend, may I suggest LinNeighborhood.

      works great with my NSLU2 and the rest of the machines on my network.

      http://java.thn.htu.se/~toor/misc/rpms/

      good luck!
    • greg_martin_iii
      Steve, Thanks. Have tried your suggestion and it doesn t work for me. My linus is RedHat AS 2.1. The command I type is mount //192.168.2.103/gcmartin3 /san
      Message 2 of 8 , Aug 23, 2004
      • 0 Attachment
        Steve,

        Thanks. Have tried your suggestion and it doesn't work for me. My
        linus is RedHat AS 2.1. The command I type is

        mount //192.168.2.103/gcmartin3 /san -o password=xyx

        It reports a message "special devise //192.168.2.103/gcmartin3' does
        not exist. That's the share that's on the NSLU2 and the proper
        password. I've also tried to mount disk1 but received the same
        message. I can ping 192.168.2.103 with no problem.

        Help!

        Thanks

        Regards
        Greg

        --- In nslu2-general@yahoogroups.com, "w5sdc" <steve@w...> wrote:
        > > I have a linux box that I'm experimenting with. Can anyone
        > provide
        > > some step-by-step instructions for accessing the NSLU2 from
        > linux?
        > > I'd prefer to start using it from Linux.
        >
        > Here's an example from my system running RH 9
        >
        > [root@linux root]# mount //192.168.1.77/public /backup -o password=
        >
        > [root@linux root]# ls /backup
        >
        > boot.txt filesys mac NSLU2 board
        > rear.jpg
        > Family Pictures Grand Canyon NSLU2 board front.jpg wed
        >
        > [root@linux root]#
        >
        > public is the name of a share I defined on the NSLU2 that is
        > accesible to the world. The ip address is the factory default of
        the
        > box as well. (I have been too lazy to put the NSLU2 in the hosts
        > file)
        >
        > If you prefer an X-11 frontend, may I suggest LinNeighborhood.
        >
        > works great with my NSLU2 and the rest of the machines on my
        network.
        >
        > http://java.thn.htu.se/~toor/misc/rpms/
        >
        > good luck!
      • Scott J. Lopez
        well i m able to mount mine, out of the box, on a linux box (running gentoo) with the following command: mount -t smbfs //192.168.1.70/Disk 1 /mnt/nslu2 -o
        Message 3 of 8 , Aug 23, 2004
        • 0 Attachment
          well i'm able to mount mine, out of the box, on a linux box (running gentoo) with the following command:

          mount -t smbfs "//192.168.1.70/Disk 1" /mnt/nslu2 -o username=name,password=pass

          you'll have to modify the command for your situation, but here's a breakdown:

          mount -t smbfs <<- standard mount command, filesystem type "smbfs" for samba

          "//192.168.1.70/Disk 1" <<- the address the server is at and the share I am mounting. Yes, you need the quotes if the share has a space or other funny character in the name to keep the shell from interperting it. "Disk 1" was the default name my nslu2 set up and I haven't gotten around to changing it.

          /mnt/nslu2 <<- where you want it mounted

          -o username=name,password=pass <<- tells the mount command some options, this being the user name i want to log in with as well as the password. doesn't hurt to provide both unless you're using all guest accounts.

          hope this helps

          --scott

          On Mon, Aug 23 2004, greg_martin_iii wrote:

          > Steve,
          >
          > Thanks. Have tried your suggestion and it doesn't work for me. My
          > linus is RedHat AS 2.1. The command I type is
          >
          > mount //192.168.2.103/gcmartin3 /san -o password=xyx
          >
          > It reports a message "special devise //192.168.2.103/gcmartin3' does
          > not exist. That's the share that's on the NSLU2 and the proper
          > password. I've also tried to mount disk1 but received the same
          > message. I can ping 192.168.2.103 with no problem.
          >
          > Help!
          >
          > Thanks
          >
          > Regards
          > Greg
        • steve@w5sdc.net
          try smbmount
          Message 4 of 8 , Aug 23, 2004
          • 0 Attachment
            try smbmount


            > Steve,
            >
            > Thanks. Have tried your suggestion and it doesn't work for me. My
            > linus is RedHat AS 2.1. The command I type is
            >
            > mount //192.168.2.103/gcmartin3 /san -o password=xyx
            >
            > It reports a message "special devise //192.168.2.103/gcmartin3' does
            > not exist. That's the share that's on the NSLU2 and the proper
            > password. I've also tried to mount disk1 but received the same
            > message. I can ping 192.168.2.103 with no problem.
            >
            > Help!
            >
            > Thanks
            >
            > Regards
            > Greg
            >
            > --- In nslu2-general@yahoogroups.com, "w5sdc" wrote:
            > > > I have a linux box that I'm experimenting with. Can anyone
            > > provide
            > > > some step-by-step instructions for accessing the NSLU2 from
            > > linux?
            > > > I'd prefer to start using it from Linux.
            > >
            > > Here's an example from my system running RH 9
            > >
            > > [root@linux root]# mount //192.168.1.77/public /backup -o password=
            > >
            > > [root@linux root]# ls /backup
            > >
            > > boot.txt filesys mac NSLU2 board
            > > rear.jpg
            > > Family Pictures Grand Canyon NSLU2 board front.jpg wed
            > >
            > > [root@linux root]#
            > >
            > > public is the name of a share I defined on the NSLU2 that is
            > > accesible to the world. The ip address is the factory default of
            > the
            > > box as well. (I have been too lazy to put the NSLU2 in the hosts
            > > file)
            > >
            > > If you prefer an X-11 frontend, may I suggest LinNeighborhood.
            > >
            > > works great with my NSLU2 and the rest of the machines on my
            > network.
            > >
            > > http://java.thn.htu.se/~toor/misc/rpms/
            > >
            > > good luck!
            >
            >
            > Yahoo! Groups Sponsor ADVERTISEMENT
            >
            > Yahoo! Groups Links
            > To visit your group on the web, go to:
            > http://groups.yahoo.com/group/nslu2-general/
            > To unsubscribe from this group, send an email to:
            > nslu2-general-unsubscribe@yahoogroups.com
            > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
          • greg_martin_iii
            Scott, Thanks. That did the trick. Works great for me. I d like to mount it automatically. Can you tell me what the entry will be for fstab? Thanks Regards
            Message 5 of 8 , Aug 24, 2004
            • 0 Attachment
              Scott,

              Thanks. That did the trick. Works great for me.

              I'd like to mount it automatically. Can you tell me what the entry
              will be for fstab?

              Thanks

              Regards
              Greg

              --- In nslu2-general@yahoogroups.com, "Scott J. Lopez"
              <scott.yahoo@c...> wrote:
              >
              > well i'm able to mount mine, out of the box, on a linux box
              (running gentoo) with the following command:
              >
              > mount -t smbfs "//192.168.1.70/Disk 1" /mnt/nslu2 -o
              username=name,password=pass
              >
              > you'll have to modify the command for your situation, but here's a
              breakdown:
              >
              > mount -t smbfs <<- standard mount command, filesystem type "smbfs"
              for samba
              >
              > "//192.168.1.70/Disk 1" <<- the address the server is at and the
              share I am mounting. Yes, you need the quotes if the share has a
              space or other funny character in the name to keep the shell from
              interperting it. "Disk 1" was the default name my nslu2 set up and I
              haven't gotten around to changing it.
              >
              > /mnt/nslu2 <<- where you want it mounted
              >
              > -o username=name,password=pass <<- tells the mount command some
              options, this being the user name i want to log in with as well as
              the password. doesn't hurt to provide both unless you're using all
              guest accounts.
              >
              > hope this helps
              >
              > --scott
              >
              > On Mon, Aug 23 2004, greg_martin_iii wrote:
              >
              > > Steve,
              > >
              > > Thanks. Have tried your suggestion and it doesn't work for me.
              My
              > > linus is RedHat AS 2.1. The command I type is
              > >
              > > mount //192.168.2.103/gcmartin3 /san -o password=xyx
              > >
              > > It reports a message "special devise //192.168.2.103/gcmartin3'
              does
              > > not exist. That's the share that's on the NSLU2 and the proper
              > > password. I've also tried to mount disk1 but received the same
              > > message. I can ping 192.168.2.103 with no problem.
              > >
              > > Help!
              > >
              > > Thanks
              > >
              > > Regards
              > > Greg
            Your message has been successfully submitted and would be delivered to recipients shortly.