Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: Difficulty Exiting Maint. Mode

Expand Messages
  • Gerald L. Clark
    ... then you are in maintenance mode. Use the instructions to get out of maintenance mode or nothing will work correctly. If you have filled your jffs2 you
    Message 1 of 16 , Jun 1, 2005
    • 0 Attachment
      Homer Stanford wrote:
      > On May 31, 2005, at 5:00 PM, Gerald L. Clark wrote:
      >
      >
      >>Homer Stanford wrote:
      >>
      >>>I have the same problem, can't get out of maintance mode and only
      >>
      >>can
      >>
      >>>boot from NSLU2 not attached disk.
      >>
      >>
      >>http://www.nslu2-linux.org/wiki/Unslung/GetOutOfMaintMode
      >>
      >
      > Tried that and ended up with a NSLU2 that would not boot if hard disk
      > was attached and on. Would boot without hard disk. Could then plug
      > in hard disk and mount shares. Web page still says I am in
      > maintance mode.
      >
      >
      > If you boot without disks, and the web says you are in maintenance mode,
      then you are in maintenance mode.
      Use the instructions to get out of maintenance mode or nothing will work
      correctly.
      If you have filled your jffs2 you will have to reflash.

      --
      nslu-linux - glc
    • David Ondzes
      ... I am having the same problem but I am not sure how to Exit maintenance mode through web interface as you normally would . # df Filesystem
      Message 2 of 16 , Jun 1, 2005
      • 0 Attachment
        On 6/1/05, Homer Stanford <hcstanford@...> wrote:
        >
        > On May 31, 2005, at 5:00 PM, Gerald L. Clark wrote:
        >
        > > Homer Stanford wrote:
        > > > I have the same problem, can't get out of maintance mode and only
        > > can
        > > > boot from NSLU2 not attached disk.
        > >
        > >
        > > http://www.nslu2-linux.org/wiki/Unslung/GetOutOfMaintMode
        > >
        > Tried that and ended up with a NSLU2 that would not boot if hard disk
        > was attached and on. Would boot without hard disk. Could then plug
        > in hard disk and mount shares. Web page still says I am in
        > maintance mode.

        I am having the same problem but I am not sure how to "Exit
        maintenance mode through web interface as you normally would".

        # df
        Filesystem 1k-blocks Used Available Use% Mounted on
        rootfs 6528 5312 1216 81% /
        /dev/mtdblock4 6528 5312 1216 81% /
        # cd /mnt
        # ls
        backup repair sda1 tmpmnt
        # ls repair
        #
      • David Ondzes
        ... I forgot to mention that there was no mention of maintenance mode on nslu2 web interface and I haven t installed any pacakges...haven t been able to boot
        Message 3 of 16 , Jun 2, 2005
        • 0 Attachment
          > > > http://www.nslu2-linux.org/wiki/Unslung/GetOutOfMaintMode
          > > >
          > > Tried that and ended up with a NSLU2 that would not boot if hard disk
          > > was attached and on. Would boot without hard disk. Could then plug
          > > in hard disk and mount shares. Web page still says I am in
          > > maintance mode.
          >
          > I am having the same problem but I am not sure how to "Exit
          > maintenance mode through web interface as you normally would".
          >
          > # df
          > Filesystem 1k-blocks Used Available Use% Mounted on
          > rootfs 6528 5312 1216 81% /
          > /dev/mtdblock4 6528 5312 1216 81% /
          > # cd /mnt
          > # ls
          > backup repair sda1 tmpmnt
          > # ls repair
          > #

          I forgot to mention that there was no mention of maintenance mode on
          nslu2 web interface and I haven't installed any pacakges...haven't
          been able to boot with my flash disk attached.I
        • David Ondzes
          Still looking for some help on how to solve this problem. I was all set reflash 4.20 last night when I noticed the Exit Maintenance Mode link on the upgrade
          Message 4 of 16 , Jun 3, 2005
          • 0 Attachment
            Still looking for some help on how to solve this problem. I was all
            set reflash 4.20 last night when I noticed the "Exit Maintenance Mode"
            link on the upgrade page. I had no idea where it was until last night.
            Note - to author of "GetOutOfMaintMode" howto, you might want to
            mention where the link is.

            Ok, so I now know where the link is and I tried following the howto.
            The problem was I already had a /mnt/repair directory and when I
            clicked on "Exit Maintenance Mode" I got a message about rebooting in
            Maintenance Mode. When the slug came up I still had the 81% full df
            output. So I telnet back in, made /mnt/repair (it wasn't there this
            time) and clicked on "Exit Maintenance Mode" again. The message now
            said something about rebooting in normal mode. So after slug came up.
            I shutdown and tried booting with my flash disk and it never finished
            booting.

            Where do I go from here ? Do I reflash ? Format my usb drive and unsling again ?
          • Gerald L. Clark
            ... I have; many times. Perhaps you should read the archives and the wiki. ... 1. Boot without disks. 2. Delete .sda1root. 3. Plug in drive. 4. Wait for drive
            Message 5 of 16 , Jun 3, 2005
            • 0 Attachment
              David Ondzes wrote:
              > Still looking for some help on how to solve this problem. I was all
              > set reflash 4.20 last night when I noticed the "Exit Maintenance Mode"
              > link on the upgrade page. I had no idea where it was until last night.
              > Note - to author of "GetOutOfMaintMode" howto, you might want to
              > mention where the link is.
              I have; many times. Perhaps you should read the archives and the wiki.
              >
              > Ok, so I now know where the link is and I tried following the howto.
              > The problem was I already had a /mnt/repair directory and when I
              > clicked on "Exit Maintenance Mode" I got a message about rebooting in
              > Maintenance Mode. When the slug came up I still had the 81% full df
              > output. So I telnet back in, made /mnt/repair (it wasn't there this
              > time) and clicked on "Exit Maintenance Mode" again. The message now
              > said something about rebooting in normal mode. So after slug came up.
              > I shutdown and tried booting with my flash disk and it never finished
              > booting.
              >
              > Where do I go from here ? Do I reflash ? Format my usb drive and unsling again ?
              1. Boot without disks.
              2. Delete .sda1root.
              3. Plug in drive.
              4. Wait for drive to be mounted read-write. If you do not wait,
              unsling will fail, but .sda1root will be created.
              This leaves the slug unbootable with the drive plugged in.
              5. When the drive is mounted read-write, unsling.
              6. Reboot.
              >

              --
              nslu-linux - glc
            Your message has been successfully submitted and would be delivered to recipients shortly.