Loading ...
Sorry, an error occurred while loading the content.

7829Re: SLugOS/BE as NFS client

Expand Messages
  • beerman_wendel
    May 13, 2009
    • 0 Attachment
      --- In nslu2-general@yahoogroups.com, "beerman_wendel" <beerman_wendel@...> wrote:
      >
      > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@>
      > wrote:
      > >
      > > beerman_wendel wrote:
      > > > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@>
      > > > wrote:
      > > >> beerman_wendel wrote:
      > > >>> Well ... here comes the message again - I think it has all the
      > > >>> necessary details ...
      > > >>>
      > > >>> Rigas
      > > >>>
      > > >>>
      > > >>> Hello,
      > > >>>
      > > >>> I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
      > > >>> SLUG1 (Openslug 3.10) to it.
      > > >>>
      > > >>> I exported the share in SLUG1 (added the following line to
      > > > etc\exports:)
      > > >>> /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
      > > >>>
      > > >>> On SLUG2 im tried to mount that share with:
      > > >>>
      > > >>> mount SLUG1:/opt/mp3 /opt/music
      > > >>>
      > > >>> I received:
      > > >>>
      > > >>> mount: unknown filesystem type 'nfs'
      > > >>>
      > > >>> Does that mean, that SLUGOS/BE does not support NFS?
      > > >>> Or do I just have to install some packages?
      > > >> It means you need to install packages.
      > > >> http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS
      > > >>
      > > >> Mike (mwester)
      > > >>
      > > >
      > > > Thanks for the answer.
      > > >
      > > > I had worked through that howto and all the packages listed there have
      > > > been installed on the NFS-Server (Slug1, OpenSlug 3.1) and the
      > > > NFS-client (Slug2, SlugOSBE).
      > > >
      > > > The server part works fine; the question is , whether the client slug
      > > > with SlugOS/BE is at all able to mount a NFS share from an NFS server.
      > > >
      > > > On the client I get the message: "mount: unknown filesystem type
      > 'nfs'"
      > > >
      > > > I installed the nfsd kernel module on the client. Do I have to
      > > > activate it somehow?
      > >
      > > You need to install the package named "kernel-module-nfs" to get the
      > > client side of things. Once you do that, it should know about the nfs
      > > filesystem. If that doesn't do it, there have been reports that a
      > > "depmod -a" command is required and/or a reboot to get the system to
      > > recognize the new kernel module.
      > >
      > > As I poke about, though, I notice that the rpcbind executable has gone
      > > AWOL -- so if your mount command appears to hang, <ctrl>-c out of it,
      > > and try it again with the "-o nolock" option, e.g.:
      > >
      > > mount -o nolock myserver:/bigfilesystem /mnt
      > >
      > > > Rigas
      > >
      > > Mike (mwester)
      > >
      >
      > Hi Mike,
      >
      > THANK YOU VERY MUCH!!
      >
      > I installed "kernel-module-nfs", did depmode -a ...
      > and voila, it works.
      >
      > Many happy thanx from Munich,
      >
      > Rigas
      >

      After many month of perfect and stable nfs operation, both slugs crushed during a power outage the other day.

      Both run ok now, but when I try to establish the nfs connection from the client side, I get this in return:

      "mount: RPC: Program not registered"

      (The same message also comes when the slug starts ... as I can tell from dmesg.)

      /sbin/portmap is running


      Any ideas?

      Rigas
    • Show all 11 messages in this topic