Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nservicebus] NServiceBus 3.0.0 Beta1 dependency hell with log4net

Expand Messages
  • Andreas Öhlund
    Or the log4net team should take contril over their nuget package:) Anyways thanks for the clarification! Nsb beta 2 and forwards will be locked to 1.2.10 so
    Message 1 of 10 , Dec 23, 2011
      Or the log4net team should take contril over "their" nuget package:)

      Anyways thanks for the clarification! Nsb beta 2 and forwards will be locked to 1.2.10 so that will solve the issue for now.

      Sent from my iPhone

      On 23 dec 2011, at 09:24, Ramon Smits <ramon.smits@...> wrote:

       


      No there is not so then you should just download the releases from the official site as you can't validate anything in a package.

      On Fri, Dec 23, 2011 at 9:21 AM, Andreas Öhlund <andreasohlund2@...> wrote:


      Is there a official feed from apache?

      Sent from my iPhone

      On 23 dec 2011, at 09:18, Ramon Smits <ramon.smits@...> wrote:

       

      Dunno, but the didn't push it as a pre-release to nuget.

      You ment this release : http://nuget.org/packages/log4net

      That is not from Apache I guess so probably best not to use packages from unofficial parties.







      --
      Ramon

    • Roy
      Hi, We re actually running into this issue at the moment. We are using another component in our system that takes an explicit dependency on log4net 1.2.11, so
      Message 2 of 10 , Apr 2, 2012
        Hi,

        We're actually running into this issue at the moment. We are using another component in our system that takes an explicit dependency on log4net 1.2.11, so this ends up giving us conflicts. We tried solving it with assembly version redirects, but at runtime somehow these two log4net are competing, giving us deadlocks on the log file.

        Are there plans to upgrade to log4net 1.2.11? Or can you explain why you explicitly stay on 1.2.10?

        Thanks.

        Roy

        --- In nservicebus@yahoogroups.com, Andreas Öhlund <andreasohlund2@...> wrote:
        >
        > Or the log4net team should take contril over "their" nuget package:)
        >
        > Anyways thanks for the clarification! Nsb beta 2 and forwards will be
        > locked to 1.2.10 so that will solve the issue for now.
        >
        > Sent from my iPhone
        >
        > On 23 dec 2011, at 09:24, Ramon Smits <ramon.smits@...> wrote:
        >
        >
        >
        >
        > No there is not so then you should just download the releases from the
        > official site as you can't validate anything in a package.
        >
        > On Fri, Dec 23, 2011 at 9:21 AM, Andreas Öhlund <andreasohlund2@...>wrote:
        >
        > >
        > >
        > > Is there a official feed from apache?
        > >
        > > Sent from my iPhone
        > >
        > > On 23 dec 2011, at 09:18, Ramon Smits <ramon.smits@...> wrote:
        > >
        > >
        > >
        > > Dunno, but the didn't push it as a pre-release to nuget.
        > >>
        > >
        > > You ment this release : http://nuget.org/packages/log4net
        > >
        > > That is not from Apache I guess so probably best not to use packages from
        > > unofficial parties.
        > >
        > >
        > >
        > >
        > >
        >
        >
        > --
        > Ramon
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.