Loading ...
Sorry, an error occurred while loading the content.
 

binary conversion inhibits "Strip HTML"

Expand Messages
  • Tom Gudan
    Every now and then in NoteTab Pro when I open an HTML file I get the pop-up that says Warning: ... may be a binary file. ... non-text characters have been
    Message 1 of 4 , Sep 6, 2000
      Every now and then in NoteTab Pro when I open an HTML file I get the
      pop-up that says
      Warning: ... may be a binary file.
      ... non-text characters have been converted to ..."

      I understand why this happens: I am allowing NoteTab to filter binary
      codes because I don't want to take a chance of part of the file being
      missing.

      The problem I have is that when this happens, the "Strip HTML" icon is
      grayed out. If I want to strip the HTML out of a web page (which I do A
      LOT) I don't care what happens to the non-text characters -- I don't
      want them anyway.

      To get around the problem, I have to do a "Save As ..." to another file
      name then open this second file to strip the HTML code from it in order
      to get the text I want.

      Why is NoteTab designed to not allow "Strip HTML" or "Save" in this
      case?

      Is there any easier way to get around the problem?
    • Jody
      Hi Tom, ... For the same reason as anytime I suppose, to help users not destroy their files. ... In the Document menu uncheck Read-Only. NoteTab marks it as
      Message 2 of 4 , Sep 6, 2000
        Hi Tom,

        >Every now and then in NoteTab Pro when I open an HTML file I get
        >the pop-up that says
        > Warning: ... may be a binary file.
        > ... non-text characters have been converted to ..."
        >
        >I understand why this happens: I am allowing NoteTab to filter
        >binary codes because I don't want to take a chance of part of the
        >file being missing.

        >Why is NoteTab designed to not allow "Strip HTML" or "Save" in this
        >case?

        For the same reason as anytime I suppose, to help users not
        destroy their files.

        >Is there any easier way to get around the problem?

        In the Document menu uncheck Read-Only. NoteTab marks it as
        that. In HTML files when that happens I normally see the
        replacement character at the bottom of the document, FWIW.

        Happy NoteTab'n,
        Jody Adair

        The NoteTabbers Assistant Page
        http://www.sureword.com/notetab

        The NoteTab Basic Discussion List
        mailto:NoteTab-Subscribe@...
        mailto:NoteTab-UnSubscribe@...
        http://www.egroups.com/group/notetab
      • Tom Gudan
        ... Thanks for the response, Jody. What could Strip HTML destroy? It always creates a completely separate .txt file and never touches (and even
        Message 3 of 4 , Sep 7, 2000
          > >Every now and then in NoteTab Pro when I open an HTML file I get
          > >the pop-up that says
          > > Warning: ... may be a binary file.
          > > ... non-text characters have been converted to ..."
          > >
          > >I understand why this happens: I am allowing NoteTab to filter
          > >binary codes because I don't want to take a chance of part of the
          > >file being missing.
          >
          > >Why is NoteTab designed to not allow "Strip HTML" or "Save" in this
          > >case?
          >
          > For the same reason as anytime I suppose, to help users not
          > destroy their files.
          >
          > >Is there any easier way to get around the problem?
          >
          > In the Document menu uncheck Read-Only. NoteTab marks it as
          > that. In HTML files when that happens I normally see the
          > replacement character at the bottom of the document, FWIW.

          Thanks for the response, Jody.

          What could "Strip HTML" destroy? It always creates a completely separate
          .txt file and never touches (and even automatically closes) the original
          .html file.

          On my version of NoteTab (4.82) the document is not checked as Read-Only.
          Clicking Read-Only on and off doesn't make any difference.
        • Jody
          Hi Tom, ... Oops! :) You are correct in that case. ... I am talking about the original HTML file when you first open it. I have all three of the following
          Message 4 of 4 , Sep 7, 2000
            Hi Tom,

            >What could "Strip HTML" destroy?

            Oops! :) You are correct in that case.

            >On my version of NoteTab (4.82) the document is not checked as
            >Read-Only. Clicking Read-Only on and off doesn't make any
            >difference.

            I am talking about the original HTML file when you first open it.
            I have all three of the following checked. Perhaps that makes a
            difference:

            Filter Binary Codes: By default, if you try to load a file that
            contains null characters (a character with a decimal value of 0),
            NoteTab will treat the first occurring null as the end of the
            file. This option lets you override this behavior by allowing
            NoteTab to substitute null characters with another character –
            defined in the "Substitute Binary Character" field. When set, you
            can load the full content of any type of file (including
            binaries). Important: saving files which have had characters
            substituted will not restore the control character! This option
            slows the loading of large files, so do not set it if you use
            only true text files.

            Warn Partial Loading: Warns if a file has only been partially
            loaded due to the presence of null characters. This option has no
            effect if "Filter Binary Codes" is set.

            Warn Binaries Substituted: Displays a warning message if binary
            characters have been substituted in the loaded document.

            -----

            You get the warning, it is not marked as Read-Only, but yet you
            cannot edit the file. Is that correct? Do you see your binary
            substitution character? Look down at the bottom of the file.
            The default is a dot --> · <-- centered in the line.

            You can use Document | Insert File... to put the text into a new
            document and if I remember correctly it will not add the binary
            portion of it.

            Happy NoteTab'n,
            Jody Adair

            The NoteTabbers Assistant Page
            http://www.sureword.com/notetab

            The NoteTab Basic Discussion List
            mailto:NoteTab-Subscribe@...
            mailto:NoteTab-UnSubscribe@...
            http://www.egroups.com/group/notetab
          Your message has been successfully submitted and would be delivered to recipients shortly.