Loading ...
Sorry, an error occurred while loading the content.
 

Simple copy and paste gone in Std 6.2?

Expand Messages
  • twoodho
    I may have made a mistake buying NoteTab Std 6.2. I have used the free version for years mainly to copy a paragraph from an email and paste it into a text
    Message 1 of 6 , Jun 26, 2012
      I may have made a mistake buying NoteTab Std 6.2. I have used the free version for years mainly to copy a paragraph from an email and paste it into a text document in NoteTab. This is very useful for collecting quotations, for example. I apparently cannot do this in 6.2. Now when I copy the text to the Win7 clipboard as usual, the Paste capability in NoteTab is greyed out, preventing me from pasting it into my text document.
      I note that the only copy/paste I can find in NoteTab Std 6.2 is now under the "Without Clipboard" utility which evidently prevents me from copying from Win7 into the NoteTab document. What am I doing wrong?
    • Art Kocsis
      ... That does not sound like a NTB 6.2 problem but a problem with your system/settings. The NTB paste would be greyed out (only?) if the clipboard was empty or
      Message 2 of 6 , Jun 26, 2012
        At 6/26/2012 06:52 AM, twoodho wrote:
        >I may have made a mistake buying NoteTab Std 6.2. I have used the free
        >version for years mainly to copy a paragraph from an email and paste it
        >into a text document in NoteTab. This is very useful for collecting
        >quotations, for example. I apparently cannot do this in 6.2. Now when I
        >copy the text to the Win7 clipboard as usual, the Paste capability in
        >NoteTab is greyed out, preventing me from pasting it into my text document.
        >I note that the only copy/paste I can find in NoteTab Std 6.2 is now under
        >the "Without Clipboard" utility which evidently prevents me from copying
        >from Win7 into the NoteTab document. What am I doing wrong?

        That does not sound like a NTB 6.2 problem but a problem with your
        system/settings.

        The NTB paste would be greyed out (only?) if the clipboard was empty or if
        the document was flagged as read-only.

        Assuming your did a valid copy that leaves the second alternative.

        A doc will be flagged read-only in NTB if the file attributes are set to R,
        S, or H or if the file contains UTF-16 characters (this was new in NTB 5).
        NTB 4.95 would load (and edit), a Unicode file without marking it
        read-only. You didn't say which version of NTB Lite you were using but it
        sounds like v4 or earlier.

        You can check the Read/Write status of a doc by clicking on Document in the
        menu bar.
        The last entry is the R/W status. If checked you probably need to convert
        the doc to UTF-8 before
        editing it. NTB will automatically convert any clipboard text to UTF-8 when
        pasting to a new doc. So one way to convert a doc to UTF-8 is to copy it
        (Copy-All) and then paste it into a new document.

        A clip I wrote does this with one click on a clipbar icon (see below)

        BTW - I suspect that you are collecting your quotations the hard way.
        Click on the tab that is to receive the text,
        Click on Document | Use as Paste Board (or press Shft+Cntl+P or add it to
        the Toolbar).
        Now any text that you "copy" from any app will automatically will be pasted
        into the NTB doc.
        MUCH easier! ;-)

        Namaste', Art

        ============ Begin Clip Code ============================
        Cnvrt to ANSI

        ;01-18-12 Created clip
        ;
        ;This clip converts a Unicode (UTF-16) document to
        ; ANSI (UTF-8) using the NTB built in conversion
        ; when pasting into a new document.

        ^!SetDebug off

        ^!Set %docname%=^$GetDocName$
        ^!Select ALL
        ^!SetClipboard ^$GetSelection$
        ^!Close
        ^!TOOLBAR New Document
        ^!Paste
        ^!Save AS ^%docname%
        ============ End Clip Code ============================
      • John Shotsky
        A word of warning – not all conversions will give what you want. For example, certain fractions are not supported in Windows, such as 1/3, 1/5, 1/5, 1/8,
        Message 3 of 6 , Jun 26, 2012
          A word of warning � not all conversions will give what you want. For example, certain fractions are not supported in
          Windows, such as 1/3, 1/5, 1/5, 1/8, (each as a single character) but they are supported in unicode. Thus, if your text
          may have such things, you need to parse the text in Unicode format first, to convert those to ascii, three-character
          entities before allowing the copy/paste to occur. Failure to do so will result in question marks for those entities.
          Since I work with recipes, this is a real issue for me, but others may find other characters that they are interested in
          that need preprocessing before the copy/paste.

          When this is done, it is before NoteTab is allowed to save the document � if you open and save, it will break the
          Unicode and save question marks for special characters. So, you can 'look' at such a document in NoteTab, but don't
          save. I have written code to locate such entities and warn that preprocessing is needed before using the file. The easy
          way to do that is to search for question marks all by themselves.

          Regards,
          John
          RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

          From: notetab@yahoogroups.com [mailto:notetab@yahoogroups.com] On Behalf Of Art Kocsis
          Sent: Tuesday, June 26, 2012 18:41
          To: NoteTab-Basic
          Subject: Re: [NTB] Simple copy and paste gone in Std 6.2?


          At 6/26/2012 06:52 AM, twoodho wrote:
          >I may have made a mistake buying NoteTab Std 6.2. I have used the free
          >version for years mainly to copy a paragraph from an email and paste it
          >into a text document in NoteTab. This is very useful for collecting
          >quotations, for example. I apparently cannot do this in 6.2. Now when I
          >copy the text to the Win7 clipboard as usual, the Paste capability in
          >NoteTab is greyed out, preventing me from pasting it into my text document.
          >I note that the only copy/paste I can find in NoteTab Std 6.2 is now under
          >the "Without Clipboard" utility which evidently prevents me from copying
          >from Win7 into the NoteTab document. What am I doing wrong?

          That does not sound like a NTB 6.2 problem but a problem with your
          system/settings.

          The NTB paste would be greyed out (only?) if the clipboard was empty or if
          the document was flagged as read-only.

          Assuming your did a valid copy that leaves the second alternative.

          A doc will be flagged read-only in NTB if the file attributes are set to R,
          S, or H or if the file contains UTF-16 characters (this was new in NTB 5).
          NTB 4.95 would load (and edit), a Unicode file without marking it
          read-only. You didn't say which version of NTB Lite you were using but it
          sounds like v4 or earlier.

          You can check the Read/Write status of a doc by clicking on Document in the
          menu bar.
          The last entry is the R/W status. If checked you probably need to convert
          the doc to UTF-8 before
          editing it. NTB will automatically convert any clipboard text to UTF-8 when
          pasting to a new doc. So one way to convert a doc to UTF-8 is to copy it
          (Copy-All) and then paste it into a new document.

          A clip I wrote does this with one click on a clipbar icon (see below)

          BTW - I suspect that you are collecting your quotations the hard way.
          Click on the tab that is to receive the text,
          Click on Document | Use as Paste Board (or press Shft+Cntl+P or add it to
          the Toolbar).
          Now any text that you "copy" from any app will automatically will be pasted
          into the NTB doc.
          MUCH easier! ;-)

          Namaste', Art

          ============ Begin Clip Code ============================
          Cnvrt to ANSI

          ;01-18-12 Created clip
          ;
          ;This clip converts a Unicode (UTF-16) document to
          ; ANSI (UTF-8) using the NTB built in conversion
          ; when pasting into a new document.

          ^!SetDebug off

          ^!Set %docname%=^$GetDocName$
          ^!Select ALL
          ^!SetClipboard ^$GetSelection$
          ^!Close
          ^!TOOLBAR New Document
          ^!Paste
          ^!Save AS ^%docname%
          ============ End Clip Code ============================



          [Non-text portions of this message have been removed]
        • Art Kocsis
          ... You re right, of course. I was concentrating on testing the various versions of NTB to avoid posting incorrect info and forgot to comment on the possible
          Message 4 of 6 , Jun 26, 2012
            At 6/26/2012 06:56 PM, John wrote:
            >A word of warning ­ not all conversions will give what you want. For
            >example, certain fractions are not supported in
            >Windows, such as 1/3, 1/5, 1/5, 1/8, (each as a single character) but they
            >are supported in unicode. Thus, if your text
            >may have such things, you need to parse the text in Unicode format first,
            >to convert those to ascii, three-character
            >entities before allowing the copy/paste to occur. Failure to do so will
            >result in question marks for those entities.
            >Since I work with recipes, this is a real issue for me, but others may
            >find other characters that they are interested in
            >that need preprocessing before the copy/paste.

            You're right, of course. I was concentrating on testing the various
            versions of NTB to avoid posting incorrect info and forgot to comment on
            the possible loss of content. My Unicode content is almost 100% UTF-8
            "embedded" in UTF-16 files so content loss is a non-issue for me. But, as
            you said, that is not true for everyone.

            My comments about Read-only conditions and disabled paste should still be
            true however.

            BTW, although I tend to use ANSI and ASCII synonymously, for any purists
            reading this, there is a distinct difference: (English) Windows uses ANSI
            while DOS uses ASCII. They are both 8 bit characters but with slightly
            different encodings.

            Sheeesh! It's hard enough keeping up with 8 bit characters let alone
            becoming cognizant of 16 bit characters, glyphs, code sets, symbol tables,
            etc, etc. Whole careers exist on just the 64K character mappings for Unicode.

            Namaste',

            Art
          • John Shotsky
            And Unicode supports 1.1 million characters, amounting to every character in every language on earth! It can stretch out to 4 bytes in some languages.
            Message 5 of 6 , Jun 26, 2012
              And Unicode supports 1.1 million characters, amounting to every character in every language on earth! It can stretch out
              to 4 bytes in some languages. Mentioned before, BabelMap is the finest character mapping tool I have ever seen. It is
              invaluable in assessing characters in any language.

              Also, EditPad Pro, the trial version (which is the pro version that simply nags you) is probably the best way to
              evaluate any non-pure ASCII file, bar none. It easily switches between code pages, and even to hex edit mode, with full
              Unicode support. It is my backup text editor, which I often use to monitor notepro.ini as I run NoteTab Pro. It reflects
              changes in real time, so I can see exactly when NoteTab writes its changes to its ini files. You would be surprised at
              some of them. Most don't take place until you close NoteTab, unless you explicitly write them out and reload them. And,
              if you edit the .ini file extermally, those changes will be lost when you close NoteTab, when it always overwrites
              whatever else was in its .ini file. Just sayin'.
              Babelmap:
              http://www.babelstone.co.uk/software/babelmap.html
              EditPad Pro
              http://www.editpadpro.com/

              Regards,
              John
              RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

              From: notetab@yahoogroups.com [mailto:notetab@yahoogroups.com] On Behalf Of Art Kocsis
              Sent: Tuesday, June 26, 2012 20:12
              To: NoteTab-Basic
              Subject: RE: [NTB] Simple copy and paste gone in Std 6.2?


              At 6/26/2012 06:56 PM, John wrote:
              >A word of warning � not all conversions will give what you want. For
              >example, certain fractions are not supported in
              >Windows, such as 1/3, 1/5, 1/5, 1/8, (each as a single character) but they
              >are supported in unicode. Thus, if your text
              >may have such things, you need to parse the text in Unicode format first,
              >to convert those to ascii, three-character
              >entities before allowing the copy/paste to occur. Failure to do so will
              >result in question marks for those entities.
              >Since I work with recipes, this is a real issue for me, but others may
              >find other characters that they are interested in
              >that need preprocessing before the copy/paste.

              You're right, of course. I was concentrating on testing the various
              versions of NTB to avoid posting incorrect info and forgot to comment on
              the possible loss of content. My Unicode content is almost 100% UTF-8
              "embedded" in UTF-16 files so content loss is a non-issue for me. But, as
              you said, that is not true for everyone.

              My comments about Read-only conditions and disabled paste should still be
              true however.

              BTW, although I tend to use ANSI and ASCII synonymously, for any purists
              reading this, there is a distinct difference: (English) Windows uses ANSI
              while DOS uses ASCII. They are both 8 bit characters but with slightly
              different encodings.

              Sheeesh! It's hard enough keeping up with 8 bit characters let alone
              becoming cognizant of 16 bit characters, glyphs, code sets, symbol tables,
              etc, etc. Whole careers exist on just the 64K character mappings for Unicode.

              Namaste',

              Art



              [Non-text portions of this message have been removed]
            • Bob McAllister
              ... NT (7, in my case) just after skimming the thread. The cause (at least in my case) was user error. Paste will not be available from the Win clipboard if
              Message 6 of 6 , Jun 26, 2012
                > At 6/26/2012 06:52 AM, twoodho wrote:
                > >I may have made a mistake buying NoteTab Std 6.2. I have used the free
                > >version for years mainly to copy a paragraph from an email and paste it
                > >into a text document in NoteTab. This is very useful for collecting
                > >quotations, for example. I apparently cannot do this in 6.2. Now when I
                > >copy the text to the Win7 clipboard as usual, the Paste capability in
                > >NoteTab is greyed out, preventing me from pasting it into my text
                > document.
                > >I note that the only copy/paste I can find in NoteTab Std 6.2 is now under
                > >the "Without Clipboard" utility which evidently prevents me from copying
                > >from Win7 into the NoteTab document. What am I doing wrong?
                >
                > I have had the happy accident to come across an instance of this in my own
                NT (7, in my case) just after skimming the thread.

                The cause (at least in my case) was user error. Paste will not be available
                from the Win clipboard if you have an empty doc open in the Clip Editor.

                Place cursor on whitespace in the Clipbook (F4) window; right click and
                select Edit Clip. Shift cursor to main window (which appears empty) and
                right click.

                How or why I did it, I do not know but I hope it helps.

                Bob


                [Non-text portions of this message have been removed]
              Your message has been successfully submitted and would be delivered to recipients shortly.