Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NTB] NoteTab and the Sticky "I"

Expand Messages
  • Don Daugherty
    Unless you use Regular Expressions and really want to avoid learning the (new) more powerful PCRE version, I d suggest you get the latest version of NoteTab
    Message 1 of 8 , Oct 22, 2010
      Unless you use Regular Expressions and really want to avoid learning
      the (new) more powerful PCRE version, I'd suggest you
      get the latest version of NoteTab Light and see if the problem persists.

      I have one or two other thoughts, which are interspersed below.

      On 10/22/2010 12:07 PM, S or J wrote:
      > The sticky "I".
      >
      > When inserting line breaks and a break is needed in any sentence after
      > the word I in a text string like:
      > Sentence .... I word1 word2 word3....
      >
      > my first step is to remove the space after the I so we now have:
      > Sentence .... Iword1 word2 word3....
      > and now with the cursor after I press Enter.
      >
      > For the result we should expect to see:
      > Sentence .... I
      > word1 word2 word3....
      I don't understand why you wouldn't expect to see either
      Sentence .... Iword1
      word2 word3....
      or
      Sentence ....
      Iword1 word2 word3....

      > But NoteTab makes it into
      > Sentence .... Iwo
      > rd1 word2 word3....
      This is indeed mysterious! Does your NoteTab have a spell-checker that
      somehow gets involved in the definition "words" and regards Iwo (or
      whatever the actual Ixxx might be) as a word? I know..., that's a
      stretch!

      Are you using a clip and/or RegExp in doing the editing?
    • S or J
      ... John, thanks for that info. ... have a spell-checker that somehow gets involved in the definition words and regards Iwo (or whatever the actual Ixxx
      Message 2 of 8 , Oct 23, 2010
        John Shotsky wrote:
        > It works correctly in the current version.

        John, thanks for that info.

        >> But NoteTab makes it into
        >> Sentence .... Iwo
        >> rd1 word2 word3....

        Don Daugherty wrote:
        > This is indeed mysterious! Does your NoteTab
        have a spell-checker that somehow gets involved
        in the definition "words" and regards Iwo (or
        whatever the actual Ixxx might be) as a word? I know...,
        that's a stretch!
        Are you using a clip and/or RegExp in doing the editing? <

        Don, no there is no spellchecker involved nor any clip. This problem
        occurs in just the regular NoteTab Light 4.95 totally unmodified.

        >Unless you use Regular Expressions and really want
        to avoid learning the (new) more powerful PCRE version,
        I'd suggest you get the latest version of NoteTab Light
        and see if the problem persists. <

        Until now I have not updated the program because (with the exception
        of this bug) it works well. But I think I will move to the Pro version
        to use colours to assist my HTML editing and have a spell checker, as
        well as eliminate this sticky "I" behaviour. And I'll download and
        test drive it first.

        Thanks folks. This is a great community.

        Steve in Thunder Bay, Ontario
      • loro
        ... While I think that s a great idea, I don t think any version of Notetab has had a bug like the one you describe. We sure would have heard about it here.
        Message 3 of 8 , Oct 23, 2010
          Steve wrote:
          >Until now I have not updated the program because (with the exception
          >of this bug) it works well. But I think I will move to the Pro version
          >to use colours to assist my HTML editing and have a spell checker, as
          >well as eliminate this sticky "I" behaviour. And I'll download and
          >test drive it first.

          While I think that's a great idea, I don't think any version of
          Notetab has had a bug like the one you describe. We sure would have
          heard about it here. There must be something fishy going on.

          Du you have a clipbook open? Does it use autoreplace? Or have you
          accidently turned on Auto-replace Mode (fourth item on the tools
          menu)? Check that and then close the clipbook window (F4) and see if
          the problem goes away or not.

          Lotta
        • Art Kocsis
          Steve, Just checked your problem out in NTB 4.95/full and I get the expected behavior. Your description implies that the cursor is off by two positions. I
          Message 4 of 8 , Oct 24, 2010
            Steve,

            Just checked your problem out in NTB 4.95/full and I get the expected
            behavior.

            Your description implies that the cursor is off by two positions. I assume
            that you are being careful how you place your cursor but are you using a
            non-standard cursor? What happens if you place the cursor after the "n" in
            "longword", for example, and press enter?

            It sounds like you are manually editing each line and want to avoid
            trailing spaces. If so, I suggest do your editing without regard to
            trailing spaces and, when done, select the entire document and use the Menu
            command "Modify | Lines | Trim Blanks" to remove all trailing blanks in the
            doc at once.

            Better yet would be to automate the process using a clip with RegEx.
            One click and your entire document would be processed. (Unless you really
            like manual editing of course! <g>) If you need help with the clip post a
            request in the NTB Clip forum.

            You mentioned in a later post that you wanted color highlighting for HTML.
            Although NTB is a good text editor and the clips are powerful it is not the
            best HTML editor. I suggest you look at PSPad (http://www.pspad.com/en/) or
            Notepad++ (http://notepad-plus-plus.org/). Both are specifically designed
            to be HTML editors. They are freeware, and feature not only syntax
            highlighting and spell checking but a multitude of HTML code editing tools
            to make programming much easier. If you are willing to spend a little $$
            then try Ultra edit (http://www.ultraedit.com/).

            Good luck. HTH

            Namaste', Art


            At 23-10-2010 10:48, you wrote:
            > >> But NoteTab makes it into
            > >> Sentence .... Iwo
            > >> rd1 word2 word3....
            >Don, no there is no spellchecker involved nor any clip. This problem
            >occurs in just the regular NoteTab Light 4.95 totally unmodified.
            >
            > >Unless you use Regular Expressions and really want
            >to avoid learning the (new) more powerful PCRE version,
            >I'd suggest you get the latest version of NoteTab Light
            >and see if the problem persists. <
            >
            >Until now I have not updated the program because (with the exception
            >of this bug) it works well. But I think I will move to the Pro version
            >to use colours to assist my HTML editing and have a spell checker, as
            >well as eliminate this sticky "I" behaviour. And I'll download and
            >test drive it first.
          • S or J
            ... Notetab has had a bug like the one you describe. We sure would have heard about it here. There must be something fishy going on. Du you have a clipbook
            Message 5 of 8 , Oct 24, 2010
              Steve wrote:
              >Until now I have not updated the program because (with the exception
              >of this bug) it works well. But I think I will move to the Pro
              >version
              >to use colours to assist my HTML editing and have a spell checker, as
              >well as eliminate this sticky "I" behaviour. And I'll download and
              >test drive it first.

              Lotta wrote:
              > While I think that's a great idea, I don't think any version of
              Notetab has had a bug like the one you describe. We sure would have
              heard about it here. There must be something fishy going on.
              Du you have a clipbook open? Does it use autoreplace? Or have you
              accidently turned on Auto-replace Mode (fourth item on the tools
              menu)? Check that and then close the clipbook window (F4) and see if
              the problem goes away or not. <

              Hi Lotta,
              You are correct on both suggestions. The bad behaviour disappears when
              Auto-replace is turned off, and also disappears with Auto-replace on
              (or off) with the clipbook window closed. I have no idea what the
              program thought it was auto-correcting, and thankfully I don't need
              that function.

              Hi Art,
              Your program and programming suggestions are well thought out and I
              will consider all of them carefully.

              Yes I do trim all line trailing spaces and mostly do it after
              finishing the editing with a simple select-all command and a replace
              function.

              The manual editing of each line certainly could be automated but takes
              little or no extra time as I am vetting the text for spelling and
              grammar or technical contractions that might need minor editing to
              preserve the writers' intended technical meaning. Many of my machinist
              readers are from overseas with English not their first language, so
              some slang or writing slips (whose correct meaning would be obvious to
              native English speakers) could cause misinterpretations.

              Thank you all for taking the time to help.

              Steve in Thunder Bay, Ontario
            • loro
              ... OK. Then in that library that you had opened you have clip titled I and in that clip is the explanation. ENTER is one of the triggers for auto-replace.
              Message 6 of 8 , Oct 24, 2010
                Steve, wrote:
                >You are correct on both suggestions. The bad behaviour disappears when
                >Auto-replace is turned off, and also disappears with Auto-replace on
                >(or off) with the clipbook window closed. I have no idea what the
                >program thought it was auto-correcting, and thankfully I don't need
                >that function.

                OK. Then in that library that you had opened you have clip titled "I"
                and in that clip is the explanation. ENTER is one of the triggers for
                auto-replace. When you hit enter just after the letter "I" Notetab
                runs the "I" clip. If auto-replace mode is on, that is.

                Lotta
              Your message has been successfully submitted and would be delivered to recipients shortly.