Loading ...
Sorry, an error occurred while loading the content.

Re: Language: month names

Expand Messages
  • helvetica_switzerland
    Many thanks to everyone who has helped. I don t understand the H... bit at the beginning though. Is that simply the name of the clip ? And to use it, do I
    Message 1 of 10 , May 11, 2010
    • 0 Attachment
      Many thanks to everyone who has helped. I don't understand the "H..." bit at the beginning though.

      Is that simply the name of the clip ?

      And to use it, do I need to use my usual
      > >, ^$GetDate(mmm, yyyy)$
      clip first and then run e.g. the one from Lotta ?
    • helvetica_switzerland
      Ignore my last message, everyone, I noticed that there were several line-breaks denoted by a So one of the clip now looks like this: (If there are any
      Message 2 of 10 , May 11, 2010
      • 0 Attachment
        Ignore my last message, everyone, I noticed that there were several line-breaks denoted by a "\"

        So one of the clip now looks like this:
        (If there are any "\" in the lines below - perhaps yahoo splits lines, then you need to delete them)

        ^!Set %month%=^$GetDate(mmm)$
        ^!Set %year%=^$GetDate(yyyy)$

        ^!Set %month%=^$StrReplace("Dezember";"December";^$StrReplace("November";"November";^$StrReplace("oktober";"October";^$StrReplace("september";"September";^$StrReplace("August";"August";^$StrReplace("Juli";"July";^$StrReplace("Juni";"June";^$StrReplace("Mai";"May";^$StrReplace("April";"April";^$StrReplace("März";"March";^$StrReplace("Februar";"February";^$StrReplace("Januar";"January";"^%month%";false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$;false;true)$

        Image Courtesy of Timeline Originals, ^%month%, ^%year%

        and it works great !

        Many many thanks!
      • Brian Mailman
        ... Do you think the folks on the clip list are missing out on this discussion here on the basic use list? B/
        Message 3 of 10 , May 11, 2010
        • 0 Attachment
          helvetica_switzerland wrote:
          > Many thanks to everyone who has helped. I don't understand the "H..."
          > bit at the beginning though.
          >
          > Is that simply the name of the clip ?

          Do you think the folks on the clip list are missing out on this
          discussion here on the basic use list?

          B/
        • loro
          ... I saw you figured it out later, but just to explain... Yes, the H= ... is the heading, the name of the clip. If you right-click in the combo box at the
          Message 4 of 10 , May 11, 2010
          • 0 Attachment
            helvetica_switzerland wrote:
            >Many thanks to everyone who has helped. I don't understand the
            >"H..." bit at the beginning though.
            >
            >Is that simply the name of the clip ?
            >
            >And to use it, do I need to use my usual
            > > >, ^$GetDate(mmm, yyyy)$
            >clip first and then run e.g. the one from Lotta ?

            I saw you figured it out later, but just to explain... Yes, the
            H="..." is the heading, the name of the clip. If you right-click in
            the combo box at the top of the clipbook and chose 'Open as
            Document', you see the clips just like that. Including the heading in
            our email examples also means you can copy the whole thing,
            right-click in the clipbook window and chose 'Add from Clipboard' and
            the whole thing will be added without further ado.

            First now I realize that this is the basic list and we aren't
            supposed to talk about clips here. Oops!

            Lotta
          • Hugo Paulissen
            Hi, Big chance that you have a space in that line. Hugo BTW: this should be discussed on the clips list. Lotta, I am getting a Syntax error message with the
            Message 5 of 10 , May 12, 2010
            • 0 Attachment
              Hi,

              Big chance that you have a space in that line.

              Hugo

              BTW: this should be discussed on the clips list.




              Lotta, I am getting a Syntax error message with the line
              ^!Set %month%=^$GetDate( mmmm)$




              [Non-text portions of this message have been removed]
            • brother.gabriel
              Hello! I wrote a powerpro script that does this...
              Message 6 of 10 , May 17, 2010
              • 0 Attachment
                Hello! I wrote a powerpro script that does this...

                --- In notetab@yahoogroups.com, "John Shotsky" <jshotsky@...> wrote:
                >
                > You might want \b after each, and R in the options. This will make sure there is not a longer word
                > that starts with any of those three objects. (Although if you were working on selection only, that
                > wouldn't be a problem.)
                > H="months"
                > ^!Replace "Mai\b" >> "May" RS
                > ^!Replace "Juni\b" >> "June" RS
                > ^!Replace "Juli\b" >> "July" RS
                >
                >
                > If you want to perform this globally for your entire document, make the options ARSTW. As long as
                > you know you don't want any occurrences of those months in German, this will fix everything with one
                > click.
                >
                > Regards,
                > John
                >
                > From: notetab@yahoogroups.com [mailto:notetab@yahoogroups.com] On Behalf Of Dave
                > Sent: 09 May, 2010 06:21 AM
                > To: notetab@yahoogroups.com
                > Subject: Re: [NTB] Language: month names
                >
                >
                > Hi
                > try this one should work
                > H="months"
                > ^!Replace "Mai" >> "May" S
                > ^!Replace "Juni" >> "June" S
                > ^!Replace "Juli" >> "July" S
                >
                > THANKYOU DAVE M
                >
                > ----- Original Message -----
                > From: "helvetica_switzerland" <z7dane@... <mailto:z7dane%40bluemail.ch> >
                > To: <notetab@yahoogroups.com <mailto:notetab%40yahoogroups.com> >
                > Sent: Sunday, May 09, 2010 8:40 AM
                > Subject: [NTB] Language: month names
                >
                > > Hi all. I have to use the Swiss-German version of Windows but my NoteTab
                > > Pro is English of course. I have a little clip which just asks me for a
                > > name then inserts a line into the txt I am working on, which will give the
                > > name of the person who has contributed an image to a website I look after,
                > > and the month and year.
                > > Problem is, when I use the
                > > , ^$GetDate(mmm, yyyy)$
                > > to add the month and year, it appears to look in the Windows default and
                > > gives the month in German. April, September, November are the same in both
                > > languages but May is written as Mai, June as Juni, July as Juli and seeing
                > > as my website is primarily used by English-speaking people as an academic
                > > reference site, the months should be in English.
                > > Can anyone think of any lines that I can add to the clip to make it write
                > > the months in English ?
                > >
                > > Thanks for any suggestions !
                > >
                > >
                > >
                > > ------------------------------------
                > >
                > > Fookes Software: http://www.fookes.com/
                > > NoteTab website: http://www.notetab.com/
                > > NoteTab Discussion Lists: http://www.notetab.com/groups.php
                > >
                > > ***
                > > Yahoo! Groups Links
                > >
                > >
                > >
                >
                >
                >
                > [Non-text portions of this message have been removed]
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.