Loading ...
Sorry, an error occurred while loading the content.

Change Text File Encoding

Expand Messages
  • Jono
    Hello - I am using NoteTab Pro 5.61 full. I also use a backup application called Cobian Backup. Every day I get a backup report emailed to me from the Cobian
    Message 1 of 9 , Jun 28, 2008
    • 0 Attachment
      Hello - I am using NoteTab Pro 5.61 full. I also use a backup
      application called Cobian Backup. Every day I get a backup report
      emailed to me from the Cobian app; it arrives as a text file. At the
      end of every month, I use TXTcollector to combine that month's backup
      reports into a single text file and store it away.

      This is where the problem comes in. TXTcollector will only combine
      text files that are encoded as ANSI, but Cobian emails me a Unicode
      encoded txt file. I chose to have NoteTab Pro replace the MS Notepad
      since that's what I prefer to use. MS Notepad, however, gives the
      option to "Save As..." with different encoding, but I can't find that
      option in NoteTab.

      As it is now, I have to save the file from the email, open it with MS
      Notepad, and Save As... with the ANSI encoding rather than just
      opening it from the email (default app being NoteTab) and doing a Save
      As... with the correct encoding. This adds several more steps to the
      process everyday.

      Is there a way to change the text file encoding using NoteTab?

      Thanks for any help on this.

      Jono
    • loro
      ... I ve also struggled with this. There s a clip command called ^!Export and one of its options is ANSI. Alas it doesn t do what you d think at all. I use the
      Message 2 of 9 , Jun 28, 2008
      • 0 Attachment
        Jono wrote:
        >This is where the problem comes in. TXTcollector will only combine
        >text files that are encoded as ANSI, but Cobian emails me a Unicode
        >encoded txt file. I chose to have NoteTab Pro replace the MS Notepad
        >since that's what I prefer to use. MS Notepad, however, gives the
        >option to "Save As..." with different encoding, but I can't find that
        >option in NoteTab.

        I've also struggled with this. There's a clip command called ^!Export
        and one of its options is ANSI. Alas it doesn't do what you'd think
        at all. I use the below clip. Maybe there is a more obvious way, but
        it escapes me.

        P.S. This should really go on the clip list. My fault, you certainly
        didn't ask for a clip! But I don't know if you are on that list. If
        you are not and you don't know how to run clips, please sign up and
        we'll continue there. :-)
        <mailto:ntb-Clips-Subscribe@yahoogroups.com>

        ------------------------
        h="ExportToAnsi"
        ;This clip will send the focused doc to the bin
        ;and replace it with a new ANSI doc with the
        ; same name and content.
        ^!Set %name%=^$GetDocName$
        ^!Set %text%=^$GetText$
        ^!DestroyDoc
        ^!AppendToFile "^%name%" ^%text%
        ^!Open ^%name%
        ------------------------

        Lotta
      • Jono
        Thanks Lotta. That works very well. I ve never done much with clips outside of easy ones like the utilities and HTML tagging. Is there a way to place the
        Message 3 of 9 , Jun 28, 2008
        • 0 Attachment
          Thanks Lotta. That works very well. I've never done much with clips
          outside of easy ones like the utilities and HTML tagging.

          Is there a way to place the clip up on the toolbar as a button? If
          that's possible, I could apply it to the text files without having to
          show the clip bar, therefore saving real estate.

          Thanks again!

          Jono

          --- In notetab@yahoogroups.com, loro <loro-spam01-@...> wrote:
          >
          > Jono wrote:
          > >This is where the problem comes in. TXTcollector will only combine
          > >text files that are encoded as ANSI, but Cobian emails me a Unicode
          > >encoded txt file. I chose to have NoteTab Pro replace the MS Notepad
          > >since that's what I prefer to use. MS Notepad, however, gives the
          > >option to "Save As..." with different encoding, but I can't find that
          > >option in NoteTab.
          >
          > I've also struggled with this. There's a clip command called ^!Export
          > and one of its options is ANSI. Alas it doesn't do what you'd think
          > at all. I use the below clip. Maybe there is a more obvious way, but
          > it escapes me.
          >
          > P.S. This should really go on the clip list. My fault, you certainly
          > didn't ask for a clip! But I don't know if you are on that list. If
          > you are not and you don't know how to run clips, please sign up and
          > we'll continue there. :-)
          > <mailto:ntb-Clips-Subscribe@yahoogroups.com>
          >
          > ------------------------
          > h="ExportToAnsi"
          > ;This clip will send the focused doc to the bin
          > ;and replace it with a new ANSI doc with the
          > ; same name and content.
          > ^!Set %name%=^$GetDocName$
          > ^!Set %text%=^$GetText$
          > ^!DestroyDoc
          > ^!AppendToFile "^%name%" ^%text%
          > ^!Open ^%name%
          > ------------------------
          >
          > Lotta
          >
        • Jono
          Copied over to the Clips group (awaiting approval).
          Message 4 of 9 , Jun 28, 2008
          • 0 Attachment
            Copied over to the Clips group (awaiting approval).

            --- In notetab@yahoogroups.com, "Jono" <GeoJono@...> wrote:
            >
            > Thanks Lotta. That works very well. I've never done much with clips
            > outside of easy ones like the utilities and HTML tagging.
            >
            > Is there a way to place the clip up on the toolbar as a button? If
            > that's possible, I could apply it to the text files without having to
            > show the clip bar, therefore saving real estate.
            >
            > Thanks again!
            >
            > Jono
            >
            > --- In notetab@yahoogroups.com, loro <loro-spam01-@...> wrote:
            > >
            > > Jono wrote:
            > > >This is where the problem comes in. TXTcollector will only combine
            > > >text files that are encoded as ANSI, but Cobian emails me a Unicode
            > > >encoded txt file. I chose to have NoteTab Pro replace the MS Notepad
            > > >since that's what I prefer to use. MS Notepad, however, gives the
            > > >option to "Save As..." with different encoding, but I can't find that
            > > >option in NoteTab.
            > >
            > > I've also struggled with this. There's a clip command called ^!Export
            > > and one of its options is ANSI. Alas it doesn't do what you'd think
            > > at all. I use the below clip. Maybe there is a more obvious way, but
            > > it escapes me.
            > >
            > > P.S. This should really go on the clip list. My fault, you certainly
            > > didn't ask for a clip! But I don't know if you are on that list. If
            > > you are not and you don't know how to run clips, please sign up and
            > > we'll continue there. :-)
            > > <mailto:ntb-Clips-Subscribe@yahoogroups.com>
            > >
            > > ------------------------
            > > h="ExportToAnsi"
            > > ;This clip will send the focused doc to the bin
            > > ;and replace it with a new ANSI doc with the
            > > ; same name and content.
            > > ^!Set %name%=^$GetDocName$
            > > ^!Set %text%=^$GetText$
            > > ^!DestroyDoc
            > > ^!AppendToFile "^%name%" ^%text%
            > > ^!Open ^%name%
            > > ------------------------
            > >
            > > Lotta
            > >
            >
          • ebbtidalflats
            I m all for using clips, when they can solve a problem. However, perhaps there is another solution. NoteTab has an option to change how it saves files. You can
            Message 5 of 9 , Jun 29, 2008
            • 0 Attachment
              I'm all for using clips, when they can solve a problem.

              However, perhaps there is another solution.

              NoteTab has an option to change how it saves files.
              You can elect to save files as DOS/Windows, rather
              than the default "Original".

              I don't know how that will affect Unicode files.
              It may just affect the line endings.

              But before I would set up a clip, I would check
              into a confirutation that gave the desired results
              automatically.


              See the View menu, Options, Documents, Format, Save as (pull-down list).


              Cheers,


              Eb



              --- In notetab@yahoogroups.com, "Jono" <GeoJono@...> wrote:
              >
              > Thanks Lotta. That works very well. I've never done much with clips
              > outside of easy ones like the utilities and HTML tagging.
              >
              > Is there a way to place the clip up on the toolbar as a button? If
              > that's possible, I could apply it to the text files without having to
            • loro
              ... Yes, that s exactly what it does. Lotta
              Message 6 of 9 , Jun 29, 2008
              • 0 Attachment
                ebbtidalflats wrote:
                >NoteTab has an option to change how it saves files.
                >You can elect to save files as DOS/Windows, rather
                >than the default "Original".
                >
                >I don't know how that will affect Unicode files.
                >It may just affect the line endings.

                Yes, that's exactly what it does.

                Lotta
              • fw7oaks
                What happens when you go into Cobain Backup | Tools | Options | SMTP | and uncheck Unicode headers and also Unicode body ? fw ... From: ebbtidalflats
                Message 7 of 9 , Jun 29, 2008
                • 0 Attachment
                  What happens when you go into Cobain Backup | Tools | Options | SMTP | and uncheck Unicode headers and also Unicode body ?

                  fw

                  --- On Sun, 6/29/08, ebbtidalflats <ebbtidalflats@...> wrote:
                  From: ebbtidalflats <ebbtidalflats@...>
                  Subject: [NTB] Re: Change Text File Encoding
                  To: notetab@yahoogroups.com
                  Date: Sunday, June 29, 2008, 4:33 PM











                  I'm all for using clips, when they can solve a problem.



                  However, perhaps there is another solution.



                  NoteTab has an option to change how it saves files.

                  You can elect to save files as DOS/Windows, rather

                  than the default "Original".



                  I don't know how that will affect Unicode files.

                  It may just affect the line endings.



                  But before I would set up a clip, I would check

                  into a confirutation that gave the desired results

                  automatically.



                  See the View menu, Options, Documents, Format, Save as (pull-down list).



                  Cheers,



                  Eb



                  --- In notetab@yahoogroups .com, "Jono" <GeoJono@... > wrote:

                  >

                  > Thanks Lotta. That works very well. I've never done much with clips

                  > outside of easy ones like the utilities and HTML tagging.

                  >

                  > Is there a way to place the clip up on the toolbar as a button? If

                  > that's possible, I could apply it to the text files without having to
                • Jono
                  ... Thanks fw. I went into the options and unchecked both boxes. I ll wait until tomorrow s email to see what happens; I ll post the results here. Thanks
                  Message 8 of 9 , Jul 1 6:28 AM
                  • 0 Attachment
                    --- In notetab@yahoogroups.com, fw7oaks <fw7oaks@...> wrote:
                    >
                    > What happens when you go into Cobain Backup | Tools | Options | SMTP
                    | and uncheck Unicode headers and also Unicode body ?
                    >
                    > fw
                    >

                    Thanks fw. I went into the options and unchecked both boxes. I'll
                    wait until tomorrow's email to see what happens; I'll post the results
                    here.

                    Thanks again!
                    Jono
                  • Jono
                    Posted reply in the Off Topic group (http://tech.groups.yahoo.com/group/ntb-OffTopic/) since this has turned into a conversation about Cobian Backup software.
                    Message 9 of 9 , Jul 4 4:59 AM
                    • 0 Attachment
                      Posted reply in the Off Topic group
                      (http://tech.groups.yahoo.com/group/ntb-OffTopic/) since this has
                      turned into a conversation about Cobian Backup software.

                      --- In notetab@yahoogroups.com, "Jono" <GeoJono@...> wrote:
                      >
                      > --- In notetab@yahoogroups.com, fw7oaks <fw7oaks@> wrote:
                      > >
                      > > What happens when you go into Cobain Backup | Tools | Options | SMTP
                      > | and uncheck Unicode headers and also Unicode body ?
                      > >
                      > > fw
                      > >
                      >
                      > Thanks fw. I went into the options and unchecked both boxes. I'll
                      > wait until tomorrow's email to see what happens; I'll post the results
                      > here.
                      >
                      > Thanks again!
                      > Jono
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.