Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] Clip help

Expand Messages
  • hsavage
    ... ; %FileOutput%=^?{Output filename}; %SFA%=^?{(T=D)Output ... duke, The first thing that sticks out is the missing, leading caret, in %firstline%. When you
    Message 1 of 1 , Jun 14, 2007
    View Source
    • 0 Attachment
      duke_nukem_time wrote:
      > Hey all,
      >
      > I need some basic help understanding how NoteTab
      > deals with programming. To start off, I am trying
      > to make my code open a file, where it will read each
      > line and output the line into html code to be saved.
      > My problem is that I don't understand why the clip isn't
      > working as I intended to. Here is a post of it:
      >
      > ; Menu
      > ^!Set %FileInput%=^?{(T=O)Select the filelist to use}
      ; %FileOutput%=^?{Output filename}; %SFA%=^?{(T=D)Output
      > file directory}
      > ;End procedure if the user canceled the Clip wizard
      > ^!IfCancel Exit
      >
      > Basic menu here with an input and output file to be
      > selected and named....
      >
      > ;Open the file
      > ^!OpenReadOnly ^%FileInput%
      >
      > Open the file for reading....
      >
      > ;Declare the special interger and string to be set to zero
      > ^!Set %Int%=1
      >
      > Set an interger called Int to equate to one for a loop...
      >
      > ^!Set %firstline%= ^$GetLine( 1)$
      > ^!InsertHtml <title>%firstline%</title>
      >
      > Store the first line in the opened file to the string
      > firstline. Here when I try the insert html, i want it
      > to output inserted html in the other file i created
      > called %FileOutput%. I cannot go any further until I am
      > able to solve this problem.
      >
      > A better explanation of this is that I have two files:
      > a and b. I want to take the input of file a, convert it
      > to html, and then output it to file b using strings and a loop.
      > Can anyone guide me on what to do next? I don't expect
      > someone to write the rest of it for me but I need some general
      > guidance as to where to look to solve my problem. Thanks.

      duke,

      The first thing that sticks out is the missing, leading caret, in
      %firstline%. When you assign a variable you do not use the caret, when
      you want to use the value of an assigned variable it must have a leading
      caret.

      If you need further assistance you should probably post the complete
      clip, or, at least, a lot more of it. There may be other oversights we
      would spot using a minimum of messages.

      ºvº SL-6-111 -created- 2007.06.14 - 18.09.16

      Newspaper HeadLine...
      "Panda Mating Fails; Veterinarian Takes Over"
      ¤ ø ¤ hrs ø hsavage@...
    Your message has been successfully submitted and would be delivered to recipients shortly.