Loading ...
Sorry, an error occurred while loading the content.

Select Text --> Ctrl-J ---> Ctrl-Shift-J Behavior in 5.1

Expand Messages
  • Richard
    Recently I got around to updating to Std 5.1 from 4.x (.95 in this case) which I have used for years. I use an app-specific .ini which has default document
    Message 1 of 4 , Jan 18, 2007
    • 0 Attachment
      Recently I got around to updating to Std 5.1 from 4.x (.95 in this
      case) which I have used for years. I use an app-specific .ini which
      has default document editing settings of Word Wrap [ON}, Wrap to
      Column [64], Auto Indent [OFF], and Trim White Spaces [ON].

      The sample data:
      =================================================================
      [Original text; lines joined using Ctrl-J (wrapped by my email client;
      read as a single line)]
      Hello from Lacey, WA. This small amount of snow (I'm guessing no more
      than 2") caused them to cancel school today. The big worry now is for
      it to freeze in time for the evening commute. Betti Avant, (69)

      [Text with lines split by using Ctrl-Shift-J -- ver 4.95]
      Hello from Lacey, WA. This small amount of snow (I'm guessing no
      more than 2") caused them to cancel school today. The big worry
      now is for it to freeze in time for the evening commute. Betti
      Avant, (69)

      [Text with lines split by using Ctrl-Shift-J -- ver 5.1]
      Hello from Lacey, WA. This small amount of snow (I'm guessing no
      more than 2") caused them to cancel school today. The big worry
      now is for it to freeze in time for the evening commute. Betti
      Avant, (69)
      =================================================================

      As you can see Ver 5.1 has decided to indent all lines subsequent to
      the first by one column. This is a serious bug! In fact, I had to
      revert to 4.95 almost immediately. I use the sequence
      1) select text
      2) single space selected text
      3) join lines
      4) split lines
      to format paragraphs in my newsletter. The 1-column indent makes this
      sequence useless.

      Perhaps somebody in this group can suggest to me what I ought to do to
      overcome the bug.

      Thanks,
      Richard
    • buralex@gmail.com
      ... I ve seen that too - not sure how it slipped through the beta-testing cycle :-( Interestingly, I notice it works fine with lines that start with a number.
      Message 2 of 4 , Jan 18, 2007
      • 0 Attachment
        Hi Richard:
        > As you can see Ver 5.1 has decided to indent all lines subsequent to
        > the first by one column. This is a serious bug! In fact, I had to
        > revert to 4.95 almost immediately. I use the sequence
        > 1) select text
        > 2) single space selected text
        > 3) join lines
        > 4) split lines
        > to format paragraphs in my newsletter. The 1-column indent makes this
        > sequence useless.
        >
        > Perhaps somebody in this group can suggest to me what I ought to do to
        > overcome the bug.
        I've seen that too - not sure how it slipped through the beta-testing
        cycle :-(
        Interestingly, I notice it works fine with lines that start with a number.
        I don't recall ever seeing an option that makes the "hanging paragraph"
        controllable.

        There is a work-around but it requires using a clip. Its a one line
        regex so (begging Jody's forbearance) I'll post it here rather than
        forcing this discussion to the clips list.

        ^!replace "^ " >> "" rhsia
        or from the Replace dialog, turn on Regular expressions, set Find="^ "
        (w/o quotes caret+space) and leave Replace empty and click Replace All
        button

        If you are familiar with the clipbar you can create that clip and drag
        it to the clipbar so it only requires 1-click to execute.
        You could also replace steps 2,3,4 above by a three line clip (using
        ^!Menu commands) and add the fixup regexp as the fourth line. It would
        still be a 1-click operation after doing the selection.

        If an ALL-Keyboard method is needed/desirable you could use Sheri's
        clipkey shortcuts but discussion of that really would have to take place
        on the clips list.
        Note though, that you don't have to do it with each paragraph as you go
        through the Select, Single-line-space, Join, Split routine but can
        instead do it on the whole document at the end. (Assuming there are no
        lines that are SUPPOSED to start with a single-space indent.)

        Regards ... Alec -- buralex-gmail
        --
      • abairheart
        ... The quick fix is to do SHIFT+CTRL+J SHIFT+CTRL+I Which will UN-join and then OUTDENT the spaces Abair
        Message 3 of 4 , Jan 19, 2007
        • 0 Attachment
          --- In notetab@yahoogroups.com, "Richard" <anderson@...> wrote:


          > As you can see Ver 5.1 has decided to indent all lines subsequent to
          > the first by one column. This is a serious bug! In fact, I had to


          > to format paragraphs in my newsletter. The 1-column indent makes this
          > sequence useless.
          >
          > Perhaps somebody in this group can suggest to me what I ought to do to
          > overcome the bug.
          >


          The quick fix is to do

          SHIFT+CTRL+J SHIFT+CTRL+I

          Which will UN-join and then OUTDENT the spaces


          Abair
        • buralex@gmail.com
          Abair: MUCH better than my clumsy solution :-) ... Regards ... Alec -- buralex-gmail -- [Non-text portions of this message have been removed]
          Message 4 of 4 , Jan 20, 2007
          • 0 Attachment
            Abair: MUCH better than my clumsy solution :-)

            > --- In notetab@yahoogroups.com, "Richard" <anderson@...> wrote:
            >
            >
            >> > As you can see Ver 5.1 has decided to indent all lines subsequent to
            >> > the first by one column. This is a serious bug! In fact, I had to
            >
            >
            >> > to format paragraphs in my newsletter. The 1-column indent makes this
            >> > sequence useless.
            >> >
            >> > Perhaps somebody in this group can suggest to me what I ought to do to
            >> > overcome the bug.
            >> >
            >>
            >
            >
            > The quick fix is to do
            >
            > SHIFT+CTRL+J SHIFT+CTRL+I
            >
            > Which will UN-join and then OUTDENT the spaces
            >
            >
            > Abair


            Regards ... Alec -- buralex-gmail
            --



            [Non-text portions of this message have been removed]
          Your message has been successfully submitted and would be delivered to recipients shortly.