Loading ...
Sorry, an error occurred while loading the content.
 

Trouble with Quick List

Expand Messages
  • xtx222003
    Hi, I m having trouble displaying files with the Quick List on a mapped networked computer. 1/3 of the time it doesn t display the files that the Quick List is
    Message 1 of 9 , Sep 19, 2006
      Hi,

      I'm having trouble displaying files with the Quick List on a mapped
      networked computer. 1/3 of the time it doesn't display the files that
      the Quick List is pointing to, and the only way I get it to display
      again is to browse to another folder, and then come back to the one I
      need.

      This is the mapped path V:\_Working Files\*.*

      I'm using NTP 5.1, with Windows XP Home SP2.

      Any insight will be greatly appreciated.

      Corl
    • xtx222003
      Hi, Could this be a bug with NTP 5.1? I never noticed it with 4.95. Thanks, Corl
      Message 2 of 9 , Sep 25, 2006
        Hi,

        Could this be a bug with NTP 5.1? I never noticed it with 4.95.

        Thanks,
        Corl

        --- In notetab@yahoogroups.com, "xtx222003" <xtx222003@...> wrote:
        >
        > Hi,
        >
        > I'm having trouble displaying files with the Quick List on a mapped
        > networked computer. 1/3 of the time it doesn't display the files that
        > the Quick List is pointing to, and the only way I get it to display
        > again is to browse to another folder, and then come back to the one I
        > need.
        >
        > This is the mapped path V:\_Working Files\*.*
        >
        > I'm using NTP 5.1, with Windows XP Home SP2.
        >
        > Any insight will be greatly appreciated.
        >
        > Corl
        >
      • Alec Burgess(g)
        Corl: Its always possible :). Do you still have Notetab 4.95 available in an executable mode (and/or do you still have the wrapper for 4.95 which would allow
        Message 3 of 9 , Sep 25, 2006
          Corl:

          Its always possible :). Do you still have Notetab 4.95 available in an
          executable mode (and/or do you still have the wrapper for 4.95 which
          would allow you to reinstall it if necessary). If so could you
          confirm/refute that the problem exists in both or only one version?

          Note: I recall fairly recent discussion wrt. 4.95 (I don't think 5.0 was
          out at the time) about long and slow opening times in Notetab compared
          to (say) Notepad, Wordpad, Word or Excel. The resolution then was to map
          the networked drive.

          Possibly this is a variant of that problem?

          Regards ... Alec buralex(@gmail)
          --

          xtx222003 said the following on 2006-09-25 19:19:
          > Hi,
          >
          > Could this be a bug with NTP 5.1? I never noticed it with 4.95.
          >
          > Thanks,
          > Corl
          >
          > --- In notetab@yahoogroups.com, "xtx222003" <xtx222003@...> wrote:
          >
          >> Hi,
          >>
          >> I'm having trouble displaying files with the Quick List on a mapped
          >> networked computer. 1/3 of the time it doesn't display the files that
          >> the Quick List is pointing to, and the only way I get it to display
          >> again is to browse to another folder, and then come back to the one I
          >> need.
          >>
          >> This is the mapped path V:\_Working Files\*.*
          >>
          >> I'm using NTP 5.1, with Windows XP Home SP2.
          >>
          >> Any insight will be greatly appreciated.
          >>
          >> Corl
          >
        • xtx222003
          Hi Alec, Yes mapping the network drive did resolve the problem of files opening very slowly, Quick List is pointing at that mapped drive. I ll test 4.95 and
          Message 4 of 9 , Sep 26, 2006
            Hi Alec,

            Yes mapping the network drive did resolve the problem of files
            opening very slowly, Quick List is pointing at that mapped drive.

            I'll test 4.95 and see what happens over the next week. I'll let you
            know what I find out. Shall I let you know here or at your your gmail
            account?

            Thanks,
            Corl

            --- In notetab@yahoogroups.com, "Alec Burgess(g)" <buralex@...> wrote:
            >
            > Corl:
            >
            > Its always possible :). Do you still have Notetab 4.95 available in
            an
            > executable mode (and/or do you still have the wrapper for 4.95
            which
            > would allow you to reinstall it if necessary). If so could you
            > confirm/refute that the problem exists in both or only one version?
            >
            > Note: I recall fairly recent discussion wrt. 4.95 (I don't think
            5.0 was
            > out at the time) about long and slow opening times in Notetab
            compared
            > to (say) Notepad, Wordpad, Word or Excel. The resolution then was
            to map
            > the networked drive.
            >
            > Possibly this is a variant of that problem?
            >
            > Regards ... Alec buralex(@gmail)
            > --
            >
            > xtx222003 said the following on 2006-09-25 19:19:
            > > Hi,
            > >
            > > Could this be a bug with NTP 5.1? I never noticed it with 4.95.
            > >
            > > Thanks,
            > > Corl
            > >
            > > --- In notetab@yahoogroups.com, "xtx222003" <xtx222003@> wrote:
            > >
            > >> Hi,
            > >>
            > >> I'm having trouble displaying files with the Quick List on a
            mapped
            > >> networked computer. 1/3 of the time it doesn't display the files
            that
            > >> the Quick List is pointing to, and the only way I get it to
            display
            > >> again is to browse to another folder, and then come back to the
            one I
            > >> need.
            > >>
            > >> This is the mapped path V:\_Working Files\*.*
            > >>
            > >> I'm using NTP 5.1, with Windows XP Home SP2.
            > >>
            > >> Any insight will be greatly appreciated.
            > >>
            > >> Corl
            > >
            >
          • Alec Burgess(g)
            Hi Corl: I remembered the problem, but was too lazy (tired) to check the yahoo-archive and/or my personal gmail archive to see if you were in fact the Original
            Message 5 of 9 , Sep 26, 2006
              Hi Corl:

              I remembered the problem, but was too lazy (tired) to check the
              yahoo-archive and/or my personal gmail archive to see if you were in
              fact the Original Poster on that one:(

              It's much better if the communication takes place on one of the Notetab
              lists so everyone can see what's going on and/or offer suggestions. If
              the back-and-forth gets too lengthy Jody may request it get moved to
              off-topic or next-release lists but for now I can't see any reason NOT
              to do it on the main list.

              Hopefully this one won't take as long to resolve as the first
              incarnation did :)

              Regards ... Alec buralex(@gmail)
              --

              xtx222003 said the following on 2006-09-26 13:31:
              > Hi Alec,
              >
              > Yes mapping the network drive did resolve the problem of files
              > opening very slowly, Quick List is pointing at that mapped drive.
              >
              > I'll test 4.95 and see what happens over the next week. I'll let you
              > know what I find out. Shall I let you know here or at your your gmail
              > account?
            • xtx222003
              Hi Alec, I reinstalled NTP 4.95, Quick List had no problems connecting to the folder, even after opening and closing the program dozens of times, and neither
              Message 6 of 9 , Sep 27, 2006
                Hi Alec,

                I reinstalled NTP 4.95, Quick List had no problems connecting to the
                folder, even after opening and closing the program dozens of times,
                and neither did 5.1 during this test. But, when I rebooted they BOTH
                had the same trouble with QL not showing me what was in the folder it
                was pointing at until I browsed to another folder and then selected
                the file path I really wanted off the "drop down" of the most
                recently used file paths.

                It has become an essential part of my work with 5.1 that I use Search
                Disk to Find in Files through the Network to the same folder that QL
                is pointing to, and I realized that I could never go back to 4.95 as
                my ability to work came to an immediate halt since it doesn't even
                recognize the mapped drive through Search Disk.

                Thanks for looking at this,
                Corl

                --- In notetab@yahoogroups.com, "Alec Burgess(g)" <buralex@...> wrote:
                >
                > Hi Corl:
                >
                > I remembered the problem, but was too lazy (tired) to check the
                > yahoo-archive and/or my personal gmail archive to see if you were
                in
                > fact the Original Poster on that one:(
                >
                > It's much better if the communication takes place on one of the
                Notetab
                > lists so everyone can see what's going on and/or offer suggestions.
                If
                > the back-and-forth gets too lengthy Jody may request it get moved
                to
                > off-topic or next-release lists but for now I can't see any reason
                NOT
                > to do it on the main list.
                >
                > Hopefully this one won't take as long to resolve as the first
                > incarnation did :)
                >
                > Regards ... Alec buralex(@gmail)
                > --
                >
                > xtx222003 said the following on 2006-09-26 13:31:
                > > Hi Alec,
                > >
                > > Yes mapping the network drive did resolve the problem of files
                > > opening very slowly, Quick List is pointing at that mapped drive.
                > >
                > > I'll test 4.95 and see what happens over the next week. I'll let
                you
                > > know what I find out. Shall I let you know here or at your your
                gmail
                > > account?
                >
              • Alec Burgess(g)
                ... This is a genuine WAG (wild-a?s-guess) :) Long winded dissertation follows. Maybe your problem has something to do with Windows OS file-caching? In earlier
                Message 7 of 9 , Sep 27, 2006
                  Corl said the following on 2006-09-27 15:40:
                  > I reinstalled NTP 4.95, Quick List had no problems connecting to the
                  > folder, even after opening and closing the program dozens of times,
                  > and neither did 5.1 during this test. But, when I rebooted they BOTH
                  > had the same trouble with QL not showing me what was in the folder it
                  > was pointing at until I browsed to another folder and then selected
                  > the file path I really wanted off the "drop down" of the most
                  > recently used file paths.
                  >
                  This is a genuine WAG (wild-a?s-guess) :) Long winded dissertation follows.
                  Maybe your problem has something to do with Windows OS file-caching?

                  In earlier versions of Notetab 5.0 (beta-pre-5.0 release) there was a
                  problem with Clipbar libraries showing up very slowly the first time a
                  Clipbar was activated (one icon would appear, wait, next would appear,
                  wait etc. ,etc.)
                  If you then changed to another Clipbar its icons would show up slowly
                  but if you switched back to the first, its icons would appear "instantly".

                  It turned out that this had been a "bug"/"feature" of 4.9x series as well.
                  Eric worked his magic and made the bug go-away in the next beta :)

                  *Here's the guess*: maybe he's changed the initialization logic (in I
                  suspect a background thread) to force ALL possible clipbar icons into
                  the Windows file cache so that when requested they appear "instantly"

                  In the event that I've guessed correctly, I think you would see that if
                  after opening and getting the slow (or rereading what you said the
                  non-appearance) of QuickList items and then switch to another
                  folder/QuickList and then going back to the first, the first would now
                  appear "instantly".

                  Please try and test variants on this:)

                  Here's a possible workaround: (Definitely not tested, but it may follow
                  from the above)
                  Windows will reopen any Windows Explorer folders that were open at
                  shutdown after reboot.
                  Could you try a test: Before Shutdown open a Windows explorer folder(s)
                  view so that all possible mapped-files that will appear in any Quick
                  List you might invoke, will be shown. Then Shutdown, reboot, observe how
                  long it takes for the Windows Explorer folder views to "repopulate".

                  Now try going into Notetab and see if there is any improvement:

                  Note(1): If there is "some improvement" but not enough that would
                  suggest we're on the right track - "somewhere" in Control Panel - System
                  there is (I believe) a parameter that you can tweak to control how much
                  memory Windows uses for file caching. Tweaking this "might" give
                  improvement at the possible expense of other programs swapping out more
                  ofter, hence impacting performance.

                  Note(2): You say "rebooting". If you're running WinXP you can select
                  Logout instead of shutdown, and Logout then immediately Login again.
                  This (my observation - no authoritative source) does about 95% of the
                  work that a shutdown would do but depending on circumstances somewhat
                  faster.
                  If any of the above works - try redoing and instead of full Shutdown,
                  just do a Logout-Login and see if it works the same.

                  I've typed way more than I intended based on just a guess - but one more
                  guess: If this all works as I'm supposing, your workaround during
                  day-to-day work would be any time you intend to switch to a QuickList
                  (who's files are mapped and you haven't used recently) would be to open
                  a Windows Explorer folder. You could even create a clip and/or clipbar
                  shortcut that given a file or folder spec of one of the files in the
                  QuickList would force open a Windows Explorer folder view.

                  Anyway -- let me know what results if any you get!
                  > It has become an essential part of my work with 5.1 that I use Search
                  > Disk to Find in Files through the Network to the same folder that QL
                  > is pointing to, and I realized that I could never go back to 4.95 as
                  > my ability to work came to an immediate halt since it doesn't even
                  > recognize the mapped drive through Search Disk.

                  Regards ... Alec buralex(@gmail)
                  --
                • xtx222003
                  Hi Alec, The last time I had troubles with Quick List, I used Windows Explorer to go to the desired folder. As soon as I got there the QL immediately populated
                  Message 8 of 9 , Oct 4, 2006
                    Hi Alec,

                    The last time I had troubles with Quick List, I used Windows Explorer
                    to go to the desired folder. As soon as I got there the QL
                    immediately populated itself. I made a shortcut to the folder on my
                    desktop in case I ever need it as "panic button", but so far I
                    haven't needed it, hopefully this will work in the future.

                    I haven't been getting slow populating windows since I moved to XP,
                    but it was the reason I moved from 98 one year ago.

                    Logging out didn't do anything for the situation.

                    I've been very cautious about tweaking my system.

                    All I know about clip programming is wrapping text with the ^& . I'm
                    not even close to being able to write a clip that would force open a
                    Windows Explorer folder view, and too little time to learn how.

                    Thanks,
                    Corl
                  • Alec Burgess\(g\)
                    Hi Corl: Can you confirm (or otherwise) that you now have a workaround that (albeit requiring running Explorer first to force bad folders into the file
                    Message 9 of 9 , Oct 5, 2006
                      Hi Corl:

                      Can you confirm (or otherwise) that you now have a "workaround" that
                      (albeit requiring running Explorer first to force "bad" folders into
                      the file cache) "seems" to work once you get into Notetab (having done
                      the preparatory work) functions "reasonably" quickly?

                      If you could write up a brief reproducible problem statement (explaining
                      what your setup is), what happens if you don't do the preparatory
                      setup, what happens if you do (sample times both ways) I'll pass it on
                      to the beta group. Feel free to include anything I said in past missives
                      if it "passes the smell test" from your own experience.

                      Note: if you could, please respond to the Next Release yahoo-group [NRN]
                      rather than here - Jody (and probably 1,000's of other readers may be
                      getting bored with this :( )

                      Any other readers (especially the 'guru's) if you could have a look for
                      reasonableness and comment I'd appreciate another set of eyes on this.
                      Even better would be someone else who can reproduce from Corl's problem
                      statement / bug report when he creates it. :)

                      Unfortunately, my current system is non-Networked so I can't help with
                      the reproducibility issue.

                      Note: I suspect that the eventual answer may be something like
                      constraints in "whatever" make it impossible to correct this in short
                      (or long-term) but we shall see what we shall see!

                      Regards ... Alec -- buralex(@gmail))
                      --



                      xtx222003 said the following on 2006-10-04 16:29:
                      > Hi Alec,
                      >
                      > The last time I had troubles with Quick List, I used Windows Explorer
                      > to go to the desired folder. As soon as I got there the QL
                      > immediately populated itself. I made a shortcut to the folder on my
                      > desktop in case I ever need it as "panic button", but so far I
                      > haven't needed it, hopefully this will work in the future.
                      >
                      > I haven't been getting slow populating windows since I moved to XP,
                      > but it was the reason I moved from 98 one year ago.
                      >
                      > Logging out didn't do anything for the situation.
                      >
                      > I've been very cautious about tweaking my system.
                      >
                      > All I know about clip programming is wrapping text with the ^& . I'm
                      > not even close to being able to write a clip that would force open a
                      > Windows Explorer folder view, and too little time to learn how.
                      >
                      > Thanks,
                      > Corl
                      >
                      >
                      >
                      >
                      >
                      > The NoteTab Clips List: http://groups.yahoo.com/group/ntb-clips/
                      > The NoteTab Off Topic List: http://groups.yahoo.com/group/ntb-offtopic/
                      > Fookes Software: http://www.fookes.us, http://www.fookes.com
                      >
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.