Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NTB] Re: Bug: ^P different in replace between Pro/Light/Standard ?

Expand Messages
  • Alec Burgess(g)
    ... Have you tried regexp, ie: (sorry, not tested but might be worth a shot) ^!Replace n | RAIWS Regards ... Alec -- ... From: Website Managers
    Message 1 of 2 , Mar 14, 2006
      dpassng:

      > > ^!Replace "^P" >> "|" ATIWS

      Have you tried regexp, ie: (sorry, not tested but might be worth a shot)

      ^!Replace "\n" >> "|" RAIWS

      Regards ... Alec
      --
      ----- Original Message -----
      From: "Website Managers" <jim@...>
      To: <notetab@yahoogroups.com>
      Sent: Tuesday, March 14, 2006 12:22 AM
      Subject: [NTB] Re: Bug: ^P different in replace between Pro/Light/Standard ?


      > --- In notetab@yahoogroups.com, "dpasseng" <don@...> wrote:
      > >
      > > I think I recall prior discussion on this issue. I wrote a clip that
      > > does this:
      > >
      > > ^!Replace "^P" >> "|" ATIWS
      > >
      > > I guess I consider this to be a bug, probably created by the
      > > "control". It should behave the same. Worse yet, I cannot figure
      > out
      > > what the characters are I am searching for because if I highlight the
      > > "return" it appears to show some extra character (that looks like a
      > > space at the end of the line) but if I copy after highlighting and
      > put
      > > in a search in replace window it is just a ^P character, but it
      > > doesn't work.
      >
      > Since ^P is [supposedly] a carriage return/line feed pair (^C^L) have
      > you tried using those instead of ^P? When testing in PRO, using them
      > totogether produces an extra line, while using either ^C or ^L
      > produces the same results as ^P.
      >
      > Jim
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > The NoteTab Clips List: http://groups.yahoo.com/group/ntb-clips/
      > The NoteTab Off Topic List: http://groups.yahoo.com/group/ntb-offtopic/
      > Fookes Software: http://www.fookes.us, http://www.fookes.com
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
    • Don - htmlfixit.com
      ... Hi Alec, Thanks for adding to this thread! Unfortunately that doesn t work because of the same defect I am referring to! It does work in pro of course.
      Message 2 of 2 , Mar 15, 2006
        Alec Burgess(g) wrote:
        >>>^!Replace "^P" >> "|" ATIWS
        > Have you tried regexp, ie: (sorry, not tested but might be worth a shot)
        >
        > ^!Replace "\n" >> "|" RAIWS
        Hi Alec,

        Thanks for adding to this thread! Unfortunately that doesn't work
        because of the same defect I am referring to! It does work in pro of
        course.

        Also, I am working on a file in excess of 10,000 lines, so I am
        concerned about what a regex might do for speed/memory useage even if it
        did work. My solution was to replace the ^P with a pipe. The result is
        that it doesn't really replace the ^P but does add the pipe. So I wound
        up then with |^P. I put my cursor at the end of each line and used
        keyboard DELETE to dump out the ^P's. It works ... but should not have
        been required. It is essentially like there is a hidden ^P in there.

        Don
      Your message has been successfully submitted and would be delivered to recipients shortly.