Loading ...
Sorry, an error occurred while loading the content.
 

Bug: ^P different in replace between Pro/Light/Standard ?

Expand Messages
  • dpasseng
    I think I recall prior discussion on this issue. I wrote a clip that does this: ^!Replace ^P | ATIWS It works on a file that looks like this: one two
    Message 1 of 6 , Mar 13, 2006
      I think I recall prior discussion on this issue. I wrote a clip that
      does this:

      ^!Replace "^P" >> "|" ATIWS

      It works on a file that looks like this:
      one
      two
      three
      four
      five

      In Pro it comes out:
      one|two|three|four|five

      In Light it comes out:
      one|
      two|
      three|
      four|
      five|

      I guess I consider this to be a bug, probably created by the
      "control". It should behave the same. Worse yet, I cannot figure out
      what the characters are I am searching for because if I highlight the
      "return" it appears to show some extra character (that looks like a
      space at the end of the line) but if I copy after highlighting and put
      in a search in replace window it is just a ^P character, but it
      doesn't work.

      I think we discussed this a while ago, but I cannot find it. Any
      suggestions for how I write my clip to work regardless of the version
      of notetab I am in? Can I check for Pro vs Standard vs Light in the
      application name and then vary the input in that search term?

      Can someone with standard tell me does it show standard in the
      application name at the top when it is running?

      What do I need to put in there for standard? Will it be the same as
      light?

      Help ... anybody remember this discussion and the solution?
    • dpasseng
      ... I found the prior discussion ... and the only solution I see is mine ... pop for the cost of notetab pro ...
      Message 2 of 6 , Mar 13, 2006
        --- In notetab@yahoogroups.com, "dpasseng" <don@...> wrote:
        >
        > I think I recall prior discussion on this issue.

        I found the prior discussion ... and the only solution I see is mine
        ... pop for the cost of notetab pro ...
        http://groups.yahoo.com/group/notetab/message/17883

        Is there any other suggestions or solutions?
      • Website Managers
        ... out ... put ... Since ^P is [supposedly] a carriage return/line feed pair (^C^L) have you tried using those instead of ^P? When testing in PRO, using them
        Message 3 of 6 , Mar 13, 2006
          --- In notetab@yahoogroups.com, "dpasseng" <don@...> wrote:
          >
          > I think I recall prior discussion on this issue. I wrote a clip that
          > does this:
          >
          > ^!Replace "^P" >> "|" ATIWS
          >
          > I guess I consider this to be a bug, probably created by the
          > "control". It should behave the same. Worse yet, I cannot figure
          out
          > what the characters are I am searching for because if I highlight the
          > "return" it appears to show some extra character (that looks like a
          > space at the end of the line) but if I copy after highlighting and
          put
          > in a search in replace window it is just a ^P character, but it
          > doesn't work.

          Since ^P is [supposedly] a carriage return/line feed pair (^C^L) have
          you tried using those instead of ^P? When testing in PRO, using them
          totogether produces an extra line, while using either ^C or ^L
          produces the same results as ^P.

          Jim
        • Jody
          Hi dpasseng, I passed this over to the Clips list. Please look for replies over there. See the footer to join Clips the list or go to
          Message 4 of 6 , Mar 15, 2006
            Hi dpasseng,

            I passed this over to the Clips list. Please look for replies
            over there. See the footer to join Clips the list or go to
            http://www.fookes.us/maillist.htm

            >I think I recall prior discussion on this issue. I wrote a clip that
            >does this:
            >
            >^!Replace "^P" >> "|" ATIWS
            >
            >It works on a file that looks like this:
            >one
            >two
            >three
            >four
            >five
            >
            >In Pro it comes out:
            >one|two|three|four|five
            >
            >In Light it comes out:
            >one|
            >two|
            >three|
            >four|
            >five|
            >
            >I guess I consider this to be a bug, probably created by the
            >"control". It should behave the same. Worse yet, I cannot figure out
            >what the characters are I am searching for because if I highlight the
            >"return" it appears to show some extra character (that looks like a
            >space at the end of the line) but if I copy after highlighting and put
            >in a search in replace window it is just a ^P character, but it
            >doesn't work.

            The bug is in Std/Light. This is the work-around I just now made:



            >I think we discussed this a while ago, but I cannot find it. Any
            >suggestions for how I write my clip to work regardless of the version
            >of notetab I am in? Can I check for Pro vs Standard vs Light in the
            >application name and then vary the input in that search term?
            >
            >Can someone with standard tell me does it show standard in the
            >application name at the top when it is running?
            >
            >What do I need to put in there for standard? Will it be the same as
            >light?

            NoteTab Pro looks correct to me. NoteTab Standard/Light use the
            same input control which mat or may not be where the problem is.

            I have a copy of the bug in my bug folder for NoteTab in another
            copy of my mail client and will send this to it anyway.

            >Help ... anybody remember this discussion and the solution?

            I remember it, but have it in my bugs folder in another copy of
            NoteTab. I made a Clip that will work-around the problem. I'll
            post it along with this message on the Clips list. Please
            continue the thread using Clips over on that list. TIA


            Happy Clip'n!
            Jody

            All Lists: http://www.fookes.us/maillist.htm
            Convert your eMail programs... Aid4Mail: http://www.fookes.us/aid4mail

            Freeware and Shareware; some seamleesly integrates with NoteTab:
            http://www.sojourner.us/software

            See ya in the funnies!-) http://www.clean-funnies.com
          • Jody
            Hi All, Please take this over to the Clips list. TIA http://www.fookes.us/maillist.htm Happy Clip n! Jody All Lists: http://www.fookes.us/maillist.htm Convert
            Message 5 of 6 , Mar 15, 2006
              Hi All,

              Please take this over to the Clips list. TIA
              http://www.fookes.us/maillist.htm

              Happy Clip'n!
              Jody

              All Lists: http://www.fookes.us/maillist.htm
              Convert your eMail programs... Aid4Mail: http://www.fookes.us/aid4mail

              Freeware and Shareware; some seamleesly integrates with NoteTab:
              http://www.sojourner.us/software

              See ya in the funnies!-) http://www.clean-funnies.com
            • Don - htmlfixit.com
              ... Good idea Jim, Tried it ... same result exactly in light as using ^P ... does not replace the return character. That gives me another idea though that
              Message 6 of 6 , Mar 15, 2006
                > Since ^P is [supposedly] a carriage return/line feed pair (^C^L) have
                > you tried using those instead of ^P? When testing in PRO, using them
                > totogether produces an extra line, while using either ^C or ^L
                > produces the same results as ^P.

                Good idea Jim,

                Tried it ... same result exactly in light as using ^P ... does not
                replace the return character. That gives me another idea though that
                will be faster ... hmmm.

                I tried highlight all and join line. That did make it all on one line,
                but the phantom return then becomes a space. I then replaced all spaces
                (I have no spaces in the file/data I am working on) and I did it must
                faster than my line by line replace. This is flat out a bug in notetab
                -- I am convinced.

                Don
              Your message has been successfully submitted and would be delivered to recipients shortly.