Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] Unable to edit .ini files

Expand Messages
  • LJ
    ... Well, let me try to answer all of this. As far as I can tell, I have the binary character warnings checked. I know that part of it works because I have
    Message 1 of 8 , Feb 11 8:23 AM
    • 0 Attachment
      On Sat, 11 Feb 2006 09:52:22 -0600, Jody <kjv-av1611@...> wrote:

      > Hi dynabman,
      >
      >> I am a heavy user of Opera and have always been able to edit the
      >> .ini files to customize the program. Now, all of a sudden, I can
      >> not edit some of the files with Note Tab Pro.
      >
      > Short version:
      > Look under Document on the main menu and at the bottom, see if it
      > is marked Read-Only. If so, look in View | Options | Files and
      > you'll see four settings for binary characters. Two of them are
      > warnings. If they are unchecked, check them and reload one of the
      > files. You should get a warning then about a null/binary
      > character in the document. If you do, and you know for sure that
      > these are regular text based files, look at the bottom of the
      > file and see if your binary substitute character is there. (You
      > can see what the character is that is used for the substitute
      > next to the box that says "Substitute Binary Character.") Some
      > programs/servers add a null character at the end of the file.
      > Again, if you are sure that it is text based only, take it out of
      > Read-Only status from the Document menu at the bottom. You should
      > see Read-Only checked; uncheck it. It wouldn't hurt to make a
      > backup of the file first. A lot of times, one the characters is
      > taken out, it will not be added again.
      >

      Well, let me try to answer all of this. As far as I can tell, I have the binary character warnings checked. I know that part of it works because I have tried to load files before that give me the warnning you are talking about. I get no such warning when opening the opera6.ini file from my Opera profile folder. For what it is worth, I can edit the operadef6.ini files from the Opera program folder. I can see no substituted characters at the bottom of the file. They are not marked read-only in the file properties under Windows XP. However, when I load or reload one of the files in question, Note Tab Pro marks it as read-only. I can uncheck the read-only setting in Note Tab Pro and then I can edit the file, but it goes right back to read-only when I reload it. I would like to point out that I haven't had this problem until downloading Opera 9 TP2 and it is happening on both of my installations of Opera and Note Tab Pro. I am so confused. :'(



      --
      LJ
      My Best Friend Is My Wife!!
    • Jody
      Hi LJ, OK then, we re getting somewhere. ;) (We should start taking this to the Off-Topic list now (see footer), if you feel a need to continue discussing it,
      Message 2 of 8 , Feb 11 9:58 AM
      • 0 Attachment
        Hi LJ,

        OK then, we're getting somewhere. ;)

        (We should start taking this to the Off-Topic list now (see
        footer), if you feel a need to continue discussing it, or to the
        Clips list if you need a Clip to open INI files, or at least
        Opera INI files as non-read-only. I don't edit INI files myself
        enough to warrant me using a valuable Clipbar space for it
        though. :) http://www.fookes.us/maillist.htm

        It appears that Opera is adding a character somewhere that
        NoteTab is seeing as a null/binary character. Why you are not
        getting the warning, I do not know. Try changing your binary
        substitute to something that you can see real easy or that is
        something not likely to be in the file, perhaps a tilde ~. Load
        the INI file and then search for it. It is probably not going to
        be of much use if you do find something changed, because Opera is
        still going to change it back. You'll just need to take the file
        out of Document | Read-only when you need to edit it. (You can
        check the disk file properties while you have it open just for
        grins by clicking on Document | Disk File Properties (Alt+;) and
        it probably will not be checked (from what I gathered from the
        other messages. Anyway, if you find what is being substituted, if
        anything, you might be able to write Opera about it to see if
        they can change it.

        LJ wrote:
        My Best Friend Is My Wife!!

        Gee, and I thought I was the only one special to my wife. So you get
        frying pans thrown at you too for just missing an anniversary. <bg>

        >>> I am a heavy user of Opera and have always been able to edit the
        >>> .ini files to customize the program. Now, all of a sudden, I can
        >>> not edit some of the files with Note Tab Pro.
        >>
        >> Short version:
        >> Look under Document on the main menu and at the bottom, see if it
        >> is marked Read-Only. If so, look in View | Options | Files and
        >> you'll see four settings for binary characters. Two of them are
        >> warnings. If they are unchecked, check them and reload one of the
        >> files. You should get a warning then about a null/binary
        >> character in the document. If you do, and you know for sure that
        >> these are regular text based files, look at the bottom of the
        >> file and see if your binary substitute character is there. (You
        >> can see what the character is that is used for the substitute
        >> next to the box that says "Substitute Binary Character.") Some
        >> programs/servers add a null character at the end of the file.
        >> Again, if you are sure that it is text based only, take it out of
        >> Read-Only status from the Document menu at the bottom. You should
        >> see Read-Only checked; uncheck it. It wouldn't hurt to make a
        >> backup of the file first. A lot of times, one the characters is
        >> taken out, it will not be added again.
        >
        >Well, let me try to answer all of this. As far as I can tell, I
        >have the binary character warnings checked. I know that part of
        >it works because I have tried to load files before that give me
        >the warning you are talking about. I get no such warning when
        >opening the opera6.ini file from my Opera profile folder. For
        >what it is worth, I can edit the operadef6.ini files from the
        >Opera program folder. I can see no substituted characters at the
        >bottom of the file. They are not marked read-only in the file
        >properties under Windows XP. However, when I load or reload one
        >of the files in question, Note Tab Pro marks it as read-only. I
        >can uncheck the read-only setting in Note Tab Pro and then I can
        >edit the file, but it goes right back to read-only when I reload
        >it. I would like to point out that I haven't had this problem
        >until downloading Opera 9 TP2 and it is happening on both of my
        >installations of Opera and Note Tab Pro. I am so confused. :'(


        Happy Clip'n!
        Jody

        All Lists: http://www.fookes.us/maillist.htm
        Convert your eMail programs... Aid4Mail: http://www.fookes/aid4mail
        Freeware and Shareware; seamleesly integrates with NoteTab:
        http://www.sojourner.us/software
        See ya in the funnies!-) http://www.clean-funnies.com
      • LJ
        ... I have changed the character that Note Tab Pro uses as a substitute to and even though the file is still opened as read-only, that character is not in
        Message 3 of 8 , Feb 11 1:27 PM
        • 0 Attachment
          On Sat, 11 Feb 2006 11:58:34 -0600, Jody <kjv-av1611@...> wrote:

          > Hi LJ,
          >
          > OK then, we're getting somewhere. ;)
          >
          > (We should start taking this to the Off-Topic list now (see
          > footer), if you feel a need to continue discussing it, or to the
          > Clips list if you need a Clip to open INI files, or at least
          > Opera INI files as non-read-only. I don't edit INI files myself
          > enough to warrant me using a valuable Clipbar space for it
          > though. :) http://www.fookes.us/maillist.htm
          >
          > It appears that Opera is adding a character somewhere that
          > NoteTab is seeing as a null/binary character. Why you are not
          > getting the warning, I do not know. Try changing your binary
          > substitute to something that you can see real easy or that is
          > something not likely to be in the file, perhaps a tilde ~. Load
          > the INI file and then search for it. It is probably not going to
          > be of much use if you do find something changed, because Opera is
          > still going to change it back. You'll just need to take the file
          > out of Document | Read-only when you need to edit it. (You can
          > check the disk file properties while you have it open just for
          > grins by clicking on Document | Disk File Properties (Alt+;) and
          > it probably will not be checked (from what I gathered from the
          > other messages. Anyway, if you find what is being substituted, if
          > anything, you might be able to write Opera about it to see if
          > they can change it.
          >

          I have changed the character that Note Tab Pro uses as a substitute to ">" and even though the file is still opened as read-only, that character is not in the file. I don't know much about all of this, but I don't think the null/binary characters are the problem. Maybe I am wrong.

          --
          LJ
          My Best Friend Is My Wife!!
        • Jody
          Hi LJ, Just letting the list members know that I brought this over to the Off-Topic list in case somebody is following this and wondered where it went to. You
          Message 4 of 8 , Feb 11 2:26 PM
          • 0 Attachment
            Hi LJ,

            Just letting the list members know that I brought this over to
            the Off-Topic list in case somebody is following this and
            wondered where it went to.

            You are probably correct (last paragraph). I'm going to download
            Opera since our Aid4Mail supports it so I can have a direct look
            see at this first hand. ;)

            Aid4Mail: convert from one email program to another email program
            and archive from over 20 mail programs.
            http://www.fookes.us/aid4mail

            >> OK then, we're getting somewhere. ;)
            >>
            >> (We should start taking this to the Off-Topic list now (see
            >> footer), if you feel a need to continue discussing it, or to the
            >> Clips list if you need a Clip to open INI files, or at least
            >> Opera INI files as non-read-only. I don't edit INI files myself
            >> enough to warrant me using a valuable Clipbar space for it
            >> though. :) http://www.fookes.us/maillist.htm
            >>
            >> It appears that Opera is adding a character somewhere that
            >> NoteTab is seeing as a null/binary character. Why you are not
            >> getting the warning, I do not know. Try changing your binary
            >> substitute to something that you can see real easy or that is
            >> something not likely to be in the file, perhaps a tilde ~. Load
            >> the INI file and then search for it. It is probably not going to
            >> be of much use if you do find something changed, because Opera is
            >> still going to change it back. You'll just need to take the file
            >> out of Document | Read-only when you need to edit it. (You can
            >> check the disk file properties while you have it open just for
            >> grins by clicking on Document | Disk File Properties (Alt+;) and
            >> it probably will not be checked (from what I gathered from the
            >> other messages. Anyway, if you find what is being substituted, if
            >> anything, you might be able to write Opera about it to see if
            >> they can change it.
            >
            >I have changed the character that Note Tab Pro uses as a
            >substitute to ">" and even though the file is still opened as
            >read-only, that character is not in the file. I don't know much
            >about all of this, but I don't think the null/binary characters
            >are the problem. Maybe I am wrong.


            Happy Topics,
            Jody

            The NoteTab Off-Topic List
            mailto:ntb-OffTopic-Subscribe@yahoogroups.com
            mailto:ntb-OffTopic-UnSubscribe@yahoogroups.com

            All Fookes Software mailing lists and more...
            http://www.fookes.us/maillist.htm
            http://www.fookes.us/redir http://www.clean-funnies.com/
            http://www.notetab.net/ http://www.sojourner.us/software
          Your message has been successfully submitted and would be delivered to recipients shortly.