Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NTB] Unable to edit .ini files

Expand Messages
  • Jody
    Hi dynabman, ... Short version: Look under Document on the main menu and at the bottom, see if it is marked Read-Only. If so, look in View | Options | Files
    Message 1 of 8 , Feb 11, 2006
      Hi dynabman,

      >I am a heavy user of Opera and have always been able to edit the
      >.ini files to customize the program. Now, all of a sudden, I can
      >not edit some of the files with Note Tab Pro.

      Short version:
      Look under Document on the main menu and at the bottom, see if it
      is marked Read-Only. If so, look in View | Options | Files and
      you'll see four settings for binary characters. Two of them are
      warnings. If they are unchecked, check them and reload one of the
      files. You should get a warning then about a null/binary
      character in the document. If you do, and you know for sure that
      these are regular text based files, look at the bottom of the
      file and see if your binary substitute character is there. (You
      can see what the character is that is used for the substitute
      next to the box that says "Substitute Binary Character.") Some
      programs/servers add a null character at the end of the file.
      Again, if you are sure that it is text based only, take it out of
      Read-Only status from the Document menu at the bottom. You should
      see Read-Only checked; uncheck it. It wouldn't hurt to make a
      backup of the file first. A lot of times, one the characters is
      taken out, it will not be added again.

      From NoteTab's PasteBack Clip Code feature; long version :)
      Please understand what Help says (below) before making changes to
      binary documents such as *.doc, and *.exe, etc. I suggest you
      read this in full as well.

      Some servers and programs add a binary character at the end of
      the files. This is usually the case when you know they are text
      based files such as.txt and .htm. NoteTab detects the character
      and warns you that it may be a binary file like .doc, .jpg.
      NoteTab replaces the null character (binary value of no
      importance usually) with a replacement character. That assumes
      you have your binary features checked under the Files tab in
      Options. You can see the character in Options | File | Binary
      Replace Character. When NoteTab replaces it it also marks the
      file as read-only in NoteTab.

      (Also, with no text selected and the file in the saved state,
      hold your mouse pointer over the main document edit window and
      look at the file format on the status bar. If it says MAX, Unix,
      or something different than Windows/DOS and you want it to be
      Windows/DOS, right click on the tab and change the Save Format.
      You can also use the feature under Modify | Lines | Adjust Line
      Breaks - Use this command on documents (for example UNIX or Mac
      files) that do not display lines with standard carriage return +
      line feed characters.)

      You have a couple of options to take for binary read-only marked
      files. One is if you know for sure the file is a text based file,
      take it out of read-only from the Document menu at the bottom and
      then Ctrl+End to get to the bottom of the document. This assumes
      that is where the binary/null character is and where they are
      normally inserted at. The NoteTab default replacement character
      is the center dot/center period. If you see it at the bottom,
      delete it and then save the file. If you upload to the server and
      then download again, and the same thing happens you can use the
      second option.

      The second option is to uncheck all the binary warnings in Options
      | Files. You can get there from the View menu. There are three
      binary options to be concerned with. Actually, you can leave the
      warnings there if you don't mind the error message every time you
      open one of these files. If you turn off all three, then just
      remember that you did so and do not try to edit true binary files
      like .doc (MS Word) files - you will surely corrupt them.

      The following is from Help (under the File tab in Options).

      Filter Binary Codes:
      By default, if you try to load a file that contains null
      characters (a character with a decimal value of 0), NoteTab will
      treat the first occurring null as the end of the file. This
      option lets you override this behavior by allowing NoteTab to
      substitute null characters with another character – defined in
      the "Substitute Binary Character" field. When set, you can load
      the full content of any type of file (including binaries).

      Important: saving files which have had characters substituted
      will not restore the control character! This option slows the
      loading of large files, so do not set it if you use only true
      text files.

      Warn Partial Loading:
      Warns if a file has only been partially loaded due to the
      presence of null characters. This option has no effect if "Filter
      Binary Codes" is set.

      Warn Binaries Substituted:
      Displays a warning message if binary characters have been
      substituted in the loaded document.

      ---------------------------------------------------------------

      If there are no binary characters in the file and it is marked on
      the hard drive as read-only, that is, the read-only attribute is
      checked, then you'll need to uncheck it. (The files may get
      checked read-only by Windows if you burned them to storage media
      from at least Windows 98.) You can do that from NoteTab by
      clicking on Document | Disk File Properties... (Alt+;) and
      uncheck the Read-only box. If it is marked in all your files in a
      directory, you can go to Windows Explorer (or My Computer) and
      select/highlight all the files that you do not want marked read-
      only, right click over the selected area, and choose Properties.
      Uncheck the read-only box and then click on OK.

      I have a number of Clips that work with directories in my
      DirStuff. There are some Clips in it to change the file
      attributes in it about halfway down or there about. You can have
      it change the settings in an INI file for the whole directory.
      I'd only do run that Clip if you know for sure that all the
      files were falsely changed by Windows or some other program.
      FYI, I think Unix servers may add that character to the files.

      NoteTabbers Assistant Library Page
      http://www.notetab.net/html/library.htm
      Direct download for DirStuff
      http://www.notetab.net/zip/dirstuff.zip


      Happy Tab'n,
      Jody Adair

      NoteTabbers Assistant Page: http://www.notetab.net
      NoteTab FAQ: http://www.notetab.net/faq/ntb
      Sojourners Software: http://www.sojourner.us/software
      Convert to another mail program: http://www.fookes.us/aid4mail
      Clean-Funnies dot com: http://www.clean-funnies.com
    • LJ
      ... Well, let me try to answer all of this. As far as I can tell, I have the binary character warnings checked. I know that part of it works because I have
      Message 2 of 8 , Feb 11, 2006
        On Sat, 11 Feb 2006 09:52:22 -0600, Jody <kjv-av1611@...> wrote:

        > Hi dynabman,
        >
        >> I am a heavy user of Opera and have always been able to edit the
        >> .ini files to customize the program. Now, all of a sudden, I can
        >> not edit some of the files with Note Tab Pro.
        >
        > Short version:
        > Look under Document on the main menu and at the bottom, see if it
        > is marked Read-Only. If so, look in View | Options | Files and
        > you'll see four settings for binary characters. Two of them are
        > warnings. If they are unchecked, check them and reload one of the
        > files. You should get a warning then about a null/binary
        > character in the document. If you do, and you know for sure that
        > these are regular text based files, look at the bottom of the
        > file and see if your binary substitute character is there. (You
        > can see what the character is that is used for the substitute
        > next to the box that says "Substitute Binary Character.") Some
        > programs/servers add a null character at the end of the file.
        > Again, if you are sure that it is text based only, take it out of
        > Read-Only status from the Document menu at the bottom. You should
        > see Read-Only checked; uncheck it. It wouldn't hurt to make a
        > backup of the file first. A lot of times, one the characters is
        > taken out, it will not be added again.
        >

        Well, let me try to answer all of this. As far as I can tell, I have the binary character warnings checked. I know that part of it works because I have tried to load files before that give me the warnning you are talking about. I get no such warning when opening the opera6.ini file from my Opera profile folder. For what it is worth, I can edit the operadef6.ini files from the Opera program folder. I can see no substituted characters at the bottom of the file. They are not marked read-only in the file properties under Windows XP. However, when I load or reload one of the files in question, Note Tab Pro marks it as read-only. I can uncheck the read-only setting in Note Tab Pro and then I can edit the file, but it goes right back to read-only when I reload it. I would like to point out that I haven't had this problem until downloading Opera 9 TP2 and it is happening on both of my installations of Opera and Note Tab Pro. I am so confused. :'(



        --
        LJ
        My Best Friend Is My Wife!!
      • Jody
        Hi LJ, OK then, we re getting somewhere. ;) (We should start taking this to the Off-Topic list now (see footer), if you feel a need to continue discussing it,
        Message 3 of 8 , Feb 11, 2006
          Hi LJ,

          OK then, we're getting somewhere. ;)

          (We should start taking this to the Off-Topic list now (see
          footer), if you feel a need to continue discussing it, or to the
          Clips list if you need a Clip to open INI files, or at least
          Opera INI files as non-read-only. I don't edit INI files myself
          enough to warrant me using a valuable Clipbar space for it
          though. :) http://www.fookes.us/maillist.htm

          It appears that Opera is adding a character somewhere that
          NoteTab is seeing as a null/binary character. Why you are not
          getting the warning, I do not know. Try changing your binary
          substitute to something that you can see real easy or that is
          something not likely to be in the file, perhaps a tilde ~. Load
          the INI file and then search for it. It is probably not going to
          be of much use if you do find something changed, because Opera is
          still going to change it back. You'll just need to take the file
          out of Document | Read-only when you need to edit it. (You can
          check the disk file properties while you have it open just for
          grins by clicking on Document | Disk File Properties (Alt+;) and
          it probably will not be checked (from what I gathered from the
          other messages. Anyway, if you find what is being substituted, if
          anything, you might be able to write Opera about it to see if
          they can change it.

          LJ wrote:
          My Best Friend Is My Wife!!

          Gee, and I thought I was the only one special to my wife. So you get
          frying pans thrown at you too for just missing an anniversary. <bg>

          >>> I am a heavy user of Opera and have always been able to edit the
          >>> .ini files to customize the program. Now, all of a sudden, I can
          >>> not edit some of the files with Note Tab Pro.
          >>
          >> Short version:
          >> Look under Document on the main menu and at the bottom, see if it
          >> is marked Read-Only. If so, look in View | Options | Files and
          >> you'll see four settings for binary characters. Two of them are
          >> warnings. If they are unchecked, check them and reload one of the
          >> files. You should get a warning then about a null/binary
          >> character in the document. If you do, and you know for sure that
          >> these are regular text based files, look at the bottom of the
          >> file and see if your binary substitute character is there. (You
          >> can see what the character is that is used for the substitute
          >> next to the box that says "Substitute Binary Character.") Some
          >> programs/servers add a null character at the end of the file.
          >> Again, if you are sure that it is text based only, take it out of
          >> Read-Only status from the Document menu at the bottom. You should
          >> see Read-Only checked; uncheck it. It wouldn't hurt to make a
          >> backup of the file first. A lot of times, one the characters is
          >> taken out, it will not be added again.
          >
          >Well, let me try to answer all of this. As far as I can tell, I
          >have the binary character warnings checked. I know that part of
          >it works because I have tried to load files before that give me
          >the warning you are talking about. I get no such warning when
          >opening the opera6.ini file from my Opera profile folder. For
          >what it is worth, I can edit the operadef6.ini files from the
          >Opera program folder. I can see no substituted characters at the
          >bottom of the file. They are not marked read-only in the file
          >properties under Windows XP. However, when I load or reload one
          >of the files in question, Note Tab Pro marks it as read-only. I
          >can uncheck the read-only setting in Note Tab Pro and then I can
          >edit the file, but it goes right back to read-only when I reload
          >it. I would like to point out that I haven't had this problem
          >until downloading Opera 9 TP2 and it is happening on both of my
          >installations of Opera and Note Tab Pro. I am so confused. :'(


          Happy Clip'n!
          Jody

          All Lists: http://www.fookes.us/maillist.htm
          Convert your eMail programs... Aid4Mail: http://www.fookes/aid4mail
          Freeware and Shareware; seamleesly integrates with NoteTab:
          http://www.sojourner.us/software
          See ya in the funnies!-) http://www.clean-funnies.com
        • LJ
          ... I have changed the character that Note Tab Pro uses as a substitute to and even though the file is still opened as read-only, that character is not in
          Message 4 of 8 , Feb 11, 2006
            On Sat, 11 Feb 2006 11:58:34 -0600, Jody <kjv-av1611@...> wrote:

            > Hi LJ,
            >
            > OK then, we're getting somewhere. ;)
            >
            > (We should start taking this to the Off-Topic list now (see
            > footer), if you feel a need to continue discussing it, or to the
            > Clips list if you need a Clip to open INI files, or at least
            > Opera INI files as non-read-only. I don't edit INI files myself
            > enough to warrant me using a valuable Clipbar space for it
            > though. :) http://www.fookes.us/maillist.htm
            >
            > It appears that Opera is adding a character somewhere that
            > NoteTab is seeing as a null/binary character. Why you are not
            > getting the warning, I do not know. Try changing your binary
            > substitute to something that you can see real easy or that is
            > something not likely to be in the file, perhaps a tilde ~. Load
            > the INI file and then search for it. It is probably not going to
            > be of much use if you do find something changed, because Opera is
            > still going to change it back. You'll just need to take the file
            > out of Document | Read-only when you need to edit it. (You can
            > check the disk file properties while you have it open just for
            > grins by clicking on Document | Disk File Properties (Alt+;) and
            > it probably will not be checked (from what I gathered from the
            > other messages. Anyway, if you find what is being substituted, if
            > anything, you might be able to write Opera about it to see if
            > they can change it.
            >

            I have changed the character that Note Tab Pro uses as a substitute to ">" and even though the file is still opened as read-only, that character is not in the file. I don't know much about all of this, but I don't think the null/binary characters are the problem. Maybe I am wrong.

            --
            LJ
            My Best Friend Is My Wife!!
          • Jody
            Hi LJ, Just letting the list members know that I brought this over to the Off-Topic list in case somebody is following this and wondered where it went to. You
            Message 5 of 8 , Feb 11, 2006
              Hi LJ,

              Just letting the list members know that I brought this over to
              the Off-Topic list in case somebody is following this and
              wondered where it went to.

              You are probably correct (last paragraph). I'm going to download
              Opera since our Aid4Mail supports it so I can have a direct look
              see at this first hand. ;)

              Aid4Mail: convert from one email program to another email program
              and archive from over 20 mail programs.
              http://www.fookes.us/aid4mail

              >> OK then, we're getting somewhere. ;)
              >>
              >> (We should start taking this to the Off-Topic list now (see
              >> footer), if you feel a need to continue discussing it, or to the
              >> Clips list if you need a Clip to open INI files, or at least
              >> Opera INI files as non-read-only. I don't edit INI files myself
              >> enough to warrant me using a valuable Clipbar space for it
              >> though. :) http://www.fookes.us/maillist.htm
              >>
              >> It appears that Opera is adding a character somewhere that
              >> NoteTab is seeing as a null/binary character. Why you are not
              >> getting the warning, I do not know. Try changing your binary
              >> substitute to something that you can see real easy or that is
              >> something not likely to be in the file, perhaps a tilde ~. Load
              >> the INI file and then search for it. It is probably not going to
              >> be of much use if you do find something changed, because Opera is
              >> still going to change it back. You'll just need to take the file
              >> out of Document | Read-only when you need to edit it. (You can
              >> check the disk file properties while you have it open just for
              >> grins by clicking on Document | Disk File Properties (Alt+;) and
              >> it probably will not be checked (from what I gathered from the
              >> other messages. Anyway, if you find what is being substituted, if
              >> anything, you might be able to write Opera about it to see if
              >> they can change it.
              >
              >I have changed the character that Note Tab Pro uses as a
              >substitute to ">" and even though the file is still opened as
              >read-only, that character is not in the file. I don't know much
              >about all of this, but I don't think the null/binary characters
              >are the problem. Maybe I am wrong.


              Happy Topics,
              Jody

              The NoteTab Off-Topic List
              mailto:ntb-OffTopic-Subscribe@yahoogroups.com
              mailto:ntb-OffTopic-UnSubscribe@yahoogroups.com

              All Fookes Software mailing lists and more...
              http://www.fookes.us/maillist.htm
              http://www.fookes.us/redir http://www.clean-funnies.com/
              http://www.notetab.net/ http://www.sojourner.us/software
            Your message has been successfully submitted and would be delivered to recipients shortly.