Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NTB] Unable to edit html file

Expand Messages
  • Alex Plantema
    ... This is a precaution. If you edit a file with binary information and save it, the last part of the file might get lost, and non-display characters are
    Message 1 of 7 , Apr 4, 2005
      Op maandag 4 april 2005 14:24 schreef weigheyeman:

      > I am having trouble editing an html file with NoteTab Pro. When I type
      > into the file the typing seems to be ignored. I can copy characters,
      > but cut and paste are greyed out.
      > I can edit the file using Word Pad and on returning to the open file
      > in NoteTab I get a reload prompt. When I accept I get the message
      > "file not fully loaded use filter binary codes next time". I have set
      > the filter and reloaded the file. I get no error message but still
      > cannot edit the file.
      > Any suggestions?

      This is a precaution. If you edit a file with binary information and save it, the last part of the file might get lost, and non-display characters are replaced inadvertently.
      You can edit it after clicking Document, Read-Only.

      Alex.
    • weigheyeman
      ... save it, the last part of the file might get lost, and non-display characters are replaced inadvertently. ... Thanks Alex - thats sorted it.
      Message 2 of 7 , Apr 4, 2005
        --- In notetab@yahoogroups.com, "Alex Plantema" <alex.plantema@x> wrote:
        > Op maandag 4 april 2005 14:24 schreef weigheyeman:
        >
        > > I am having trouble editing an html file with NoteTab Pro. When I type
        > > into the file the typing seems to be ignored. I can copy characters,
        > > but cut and paste are greyed out.
        > > I can edit the file using Word Pad and on returning to the open file
        > > in NoteTab I get a reload prompt. When I accept I get the message
        > > "file not fully loaded use filter binary codes next time". I have set
        > > the filter and reloaded the file. I get no error message but still
        > > cannot edit the file.
        > > Any suggestions?
        >
        > This is a precaution. If you edit a file with binary information and
        save it, the last part of the file might get lost, and non-display
        characters are replaced inadvertently.
        > You can edit it after clicking Document, Read-Only.
        >
        > Alex.

        Thanks Alex - thats sorted it.
      • Jody
        Hi weigheyeman, Please understand what Help says (below) before making changes to binary documents such as *.doc, and *.exe, etc. I suggest you read this in
        Message 3 of 7 , Apr 4, 2005
          Hi weigheyeman,

          Please understand what Help says (below) before making changes to
          binary documents such as *.doc, and *.exe, etc. I suggest you
          read this in full as well.

          Some servers and programs add a binary character (null) at the
          end of the files. This is usually the case when you know they are
          text based files such as.txt and .htm. NoteTab detects the
          character and warns you that it may be a binary file like .doc,
          .jpg. NoteTab replaces the null character (binary value of no
          importance usually) with a replacement character. That assumes
          you have your binary features checked under the Files tab in
          Options. You can see the character in Options | File | Binary
          Replace Character. When NoteTab replaces it it also marks the
          file as read-only in NoteTab under the Document menu.

          You have a couple of options to take. One is if you know for sure
          the file is a text based file, take it out of read-only from the
          Document menu at the bottom and then Ctrl+End to get to the bottom
          of the document. This assumes that is where the binary/null
          character is and where they are normally inserted at. The NoteTab
          default replacement character is the center dot/center period. If
          you see it at the bottom, delete it and then save the file. If you
          upload to the server and then download again, and the same thing
          happens you can use the second option.

          The second option is to uncheck all the binary warnings in Options
          | Files. You can get there from the View menu. There are three
          binary options to be concerned with. Actually, you can leave the
          warnings there if you don't mind the error message every time you
          open one of these files. If you turn off all three, then just
          remember that you did so and do not try to edit true binary files
          like .doc (MS Word) files - you will surely corrupt them.

          The following is from Help (under the File tab in Options).

          Filter Binary Codes:
          By default, if you try to load a file that contains null
          characters (a character with a decimal value of 0), NoteTab will
          treat the first occurring null as the end of the file. This
          option lets you override this behavior by allowing NoteTab to
          substitute null characters with another character – defined in
          the "Substitute Binary Character" field. When set, you can load
          the full content of any type of file (including binaries).

          Important: saving files which have had characters substituted
          will not restore the control character! This option slows the
          loading of large files, so do not set it if you use only true
          text files.

          Warn Partial Loading:
          Warns if a file has only been partially loaded due to the
          presence of null characters. This option has no effect if "Filter
          Binary Codes" is set.

          Warn Binaries Substituted:
          Displays a warning message if binary characters have been
          substituted in the loaded document.

          >I am having trouble editing an html file with NoteTab Pro. When I type
          >into the file the typing seems to be ignored. I can copy characters,
          >but cut and paste are greyed out.
          >I can edit the file using Word Pad and on returning to the open file
          >in NoteTab I get a reload prompt. When I accept I get the message
          >"file not fully loaded use filter binary codes next time". I have set
          >the filter and reloaded the file. I get no error message but still
          >cannot edit the file.


          Happy Tab'n,
          Jody Adair

          NoteTabbers Assistant Page Sojourners Software
          http://www.notetab.net http://www.sojourner.us/software
          http://www.fookes.us http://www.clean-funnies.com
        Your message has been successfully submitted and would be delivered to recipients shortly.