Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] ^P are forced on every line - how to stop?

Expand Messages
  • David Smart
    Sorry Jody, I d sent my message before I saw this. In my case, the status bar says Dos/Windows and so does the save format (and ANSI). Doing the adjust line
    Message 1 of 9 , Mar 2, 2005
    • 0 Attachment
      Sorry Jody, I'd sent my message before I saw this. In my case, the status bar says Dos/Windows and so does the save format (and ANSI). Doing the "adjust line breaks" doesn't improve things.

      Dave S

      ----- Original Message -----
      From: Jody
      To: notetab@yahoogroups.com
      Sent: Thursday, March 03, 2005 2:41 AM
      Subject: Re: [NTB] ^P are forced on every line - how to stop?


      Hi singtartreble,

      Hold your mouse pointer over the file and look at the Statusbar.
      Make sure it says Windows/DOS. If not, make a copy of the file
      and set your Save Format to Windows/DOS (ANSI) by right clicking
      over the tab and clicking on Save Format. Save the file. See what
      happens then. If the same, click on Reload Document under the
      Edit menu. Next, click on Modify | Lines | Adjust Line Breaks.
      Try the Find ^p and Replace with ^t then.

      If you are doing this with a Clip, the you need to loop the
      find/replace until no more ^p are found. You can use an ^!IfError
      or ^!IfCancel if you are not using the S OPTION. If you need help
      writing a Clip that will do what you want with one click, then
      please sign up for the Clips list.


      [Non-text portions of this message have been removed]
    • singtartreble
      Hi Jody Thanks for your reply. Also thanks to others who replied earlier. I have followed your suggestion and it still is the same. Someone suggested I include
      Message 2 of 9 , Mar 3, 2005
      • 0 Attachment
        Hi Jody

        Thanks for your reply. Also thanks to others who replied earlier.

        I have followed your suggestion and it still is the same.

        Someone suggested I include my file for people to have a look at.
        Not sure how this is done so I will put into the files folder here.

        The file is called: realestate2.txt

        If you look at the file from line 64 onwards you can see what the
        layout looks like. I have put # and ## as an attempt to setup a
        delimiter that is not a tab or space.

        The ## is a new record delimiter for now.

        From line 64 onwards you can see that each record is set out on
        about 4 lines. The records do vary in length and number of discrete
        values (fields) so 4 lines is average. Some are only 2 or 3 lines in
        total.

        What I want is to remove the line breaks so each record (several
        fields in each) is on one line so it then forms a tab delimited file.

        No matter what I do the find replace just leaves me with no changes.
        Its the same before and after despite reporting to me that 5000+
        replacements were made.

        Thanks again
        ST









        --- In notetab@yahoogroups.com, "David Smart" <smartware@o...> wrote:
        > Sorry Jody, I'd sent my message before I saw this. In my case,
        the status bar says Dos/Windows and so does the save format (and
        ANSI). Doing the "adjust line breaks" doesn't improve things.
        >
        > Dave S
        >
        > ----- Original Message -----
        > From: Jody
        > To: notetab@yahoogroups.com
        > Sent: Thursday, March 03, 2005 2:41 AM
        > Subject: Re: [NTB] ^P are forced on every line - how to stop?
        >
        >
        > Hi singtartreble,
        >
        > Hold your mouse pointer over the file and look at the Statusbar.
        > Make sure it says Windows/DOS. If not, make a copy of the file
        > and set your Save Format to Windows/DOS (ANSI) by right clicking
        > over the tab and clicking on Save Format. Save the file. See what
        > happens then. If the same, click on Reload Document under the
        > Edit menu. Next, click on Modify | Lines | Adjust Line Breaks.
        > Try the Find ^p and Replace with ^t then.
        >
        > If you are doing this with a Clip, the you need to loop the
        > find/replace until no more ^p are found. You can use an ^!IfError
        > or ^!IfCancel if you are not using the S OPTION. If you need help
        > writing a Clip that will do what you want with one click, then
        > please sign up for the Clips list.
        >
        >
        > [Non-text portions of this message have been removed]
      • Jody
        Hi David, ... You sent in enough information now. Yes, I could replicate it in NoteTab *Std/Light*. We have enough now to get the bug fixed. Thanks! Sorry for
        Message 3 of 9 , Mar 3, 2005
        • 0 Attachment
          Hi David,

          >Sorry Jody, I'd sent my message before I saw this. In my case,
          >the status bar says Dos/Windows and so does the save format (and
          >ANSI). Doing the "adjust line breaks" doesn't improve things.

          You sent in enough information now. Yes, I could replicate it in
          NoteTab *Std/Light*. We have enough now to get the bug fixed. Thanks!
          Sorry for not getting into this more than I did. We've been
          extremely busy.

          Happy Tab'n,
          Jody Adair

          NoteTabbers Assistant Page Sojourners Software
          http://www.notetab.net http://www.sojourner.us/software
          http://www.fookes.us http://www.clean-funnies.com
        • Jody
          Hi singtartreble, I can only suggest that you download the Trial version of Pro and if it does what you want, buy it. Std has the same problem as like. It has
          Message 4 of 9 , Mar 4, 2005
          • 0 Attachment
            Hi singtartreble,

            I can only suggest that you download the Trial version of Pro and
            if it does what you want, buy it. Std has the same problem as
            like. It has something to do with the way NoteTab is interacting
            with the input control perhaps.

            >Thanks for your reply. Also thanks to others who replied earlier.
            >
            >I have followed your suggestion and it still is the same.
            >
            >Someone suggested I include my file for people to have a look at.
            >Not sure how this is done so I will put into the files folder here.
            >
            >The file is called: realestate2.txt
            >
            >If you look at the file from line 64 onwards you can see what the
            >layout looks like. I have put # and ## as an attempt to setup a
            >delimiter that is not a tab or space.
            >
            >The ## is a new record delimiter for now.
            >
            > From line 64 onwards you can see that each record is set out on
            >about 4 lines. The records do vary in length and number of discrete
            >values (fields) so 4 lines is average. Some are only 2 or 3 lines in
            >total.
            >
            >What I want is to remove the line breaks so each record (several
            >fields in each) is on one line so it then forms a tab delimited file.
            >
            >No matter what I do the find replace just leaves me with no changes.
            >Its the same before and after despite reporting to me that 5000+
            >replacements were made.


            Happy Tab'n,
            Jody Adair

            NoteTabbers Assistant Page Sojourners Software
            http://www.notetab.net http://www.sojourner.us/software
            http://www.fookes.us http://www.clean-funnies.com
          Your message has been successfully submitted and would be delivered to recipients shortly.