Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] ^P are forced on every line - how to stop?

Expand Messages
  • singtartreble
    Thanks Alex I have tried many multiple replaces without joy. haven t been back to it since posting so will have another crack at it. any other ideas are
    Message 1 of 9 , Mar 2, 2005
    • 0 Attachment
      Thanks Alex

      I have tried many multiple replaces without joy. haven't been back
      to it since posting so will have another crack at it.

      any other ideas are welcome

      cheers


      --- In notetab@yahoogroups.com, "Alex Plantema" <alex.plantema@x>
      wrote:
      > Op woensdag 23 februari 2005 02:52 schreef singtartreble:
      >
      > > I am trying to replace ^P with a ^T for a tab delimited file. I
      find
      > > that every replace still forces a ^P at the end of the line.
      > >
      > > So I end up with ^T^P when all I want is ^T
      > >
      > > Anyone have any thoughts on why this is and how to rectify
      please?
      >
      > I found the same, but with a second replace command you can delete
      all end of lines.
      >
      > Alex.
    • Don - htmlfixit.com
      ... Give us one or two lines of your content perhaps. Are you using clips or just using search and replace? This should be a simple one to fix.
      Message 2 of 9 , Mar 2, 2005
      • 0 Attachment
        > --- In notetab@yahoogroups.com, "Alex Plantema" <alex.plantema@x>
        > wrote:
        >
        >>Op woensdag 23 februari 2005 02:52 schreef singtartreble:
        >>
        >>
        >>>I am trying to replace ^P with a ^T for a tab delimited file. I
        >
        > find
        >
        >>>that every replace still forces a ^P at the end of the line.
        >>>
        >>>So I end up with ^T^P when all I want is ^T
        >>>
        >>>Anyone have any thoughts on why this is and how to rectify
        >
        > please?

        Give us one or two lines of your content perhaps. Are you using clips
        or just using search and replace? This should be a simple one to fix.
      • Jody
        Hi singtartreble, Hold your mouse pointer over the file and look at the Statusbar. Make sure it says Windows/DOS. If not, make a copy of the file and set your
        Message 3 of 9 , Mar 2, 2005
        • 0 Attachment
          Hi singtartreble,

          Hold your mouse pointer over the file and look at the Statusbar.
          Make sure it says Windows/DOS. If not, make a copy of the file
          and set your Save Format to Windows/DOS (ANSI) by right clicking
          over the tab and clicking on Save Format. Save the file. See what
          happens then. If the same, click on Reload Document under the
          Edit menu. Next, click on Modify | Lines | Adjust Line Breaks.
          Try the Find ^p and Replace with ^t then.

          If you are doing this with a Clip, the you need to loop the
          find/replace until no more ^p are found. You can use an ^!IfError
          or ^!IfCancel if you are not using the S OPTION. If you need help
          writing a Clip that will do what you want with one click, then
          please sign up for the Clips list.

          ------------ Discussion mailing lists at YahooGroups ------------

          You may sign up for the different discussion mailing lists from
          either of the links below. We use YahooGroups for the lists.

          _Please_ read the following if you decide to sign up to see what
          list to send messages to; it is very important and please also
          use a descriptive Subject: line! Delete text from your replies
          that is not needed to understand your reply and keep the
          conversation clean! :)

          If you sign up for any of the discussion lists, please *_do not_*
          post questions about NoteTab *Clips* and other scripting languages
          (such as *RegExp*, PERL, etc.) on the NoteTab Basic list. Use the
          Clips or Scripts list for them.

          More difficult tasks should be posted on the Clips or Scripts
          lists. HTML should be posted on the ntb-HTML list and off topic
          discussion takes place on the ntb-OffTopic list. The MailBag
          Assistant, Easy Thumbnails, Easy Imager, and Album Express lists
          are for discussion of those programs.

          The most important thing to remember is please leave the NoteTab
          Basic list for the *_very basic_* use of NoteTab. The other lists
          are a lot more flexible, for instance: Clips and RegExp can be
          used and are welcomed on the HTML list. Thanks!!!

          Discussion mailing list subscribing and un-subscribing:
          http://www.fookes.us/maillist.htm
          http://www.notetab.net/html/maillist.htm

          If you are already signed up for the NoteTab Basic list, there are
          links in the YahooGroups footer to get to the Clips and Off Topic
          lists.

          ---------- End Discussion mailing lists at YahooGroups ----------

          The NoteTabbers Assistant Page
          Useful Libraries and Clips for NoteTab: http://www.notetab.net

          Fookes Software Home Page via Jody'$ affiliate link:
          http://www.fookes.com/regnow.html?2448&item=home ;) Thank$ for
          getting the cookie if offered; they're delicious! :)


          >>> I am trying to replace ^P with a ^T for a tab delimited file.
          >>> I find that every replace still forces a ^P at the end of the
          >>> line.
          >>>
          >>> So I end up with ^T^P when all I want is ^T


          Happy Clip'n!
          Jody

          All Lists: http://www.fookes.us/maillist.htm
          Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
          UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
          Options: http://groups.yahoo.com/group/ntb-clips
          http://www.clean-funnies.com, http://www.sojourner.us/software
        • David Smart
          I just tried it on an odd text file and it failed in the same way. I m using NT light 4.95 - I don t know what Alex is using. My text file didn t have tabs
          Message 4 of 9 , Mar 2, 2005
          • 0 Attachment
            I just tried it on an odd text file and it failed in the same way. I'm using NT light 4.95 - I don't know what Alex is using. My text file didn't have tabs in it before I started - so it doesn't seem to matter if it has any or not.

            It's certainly a bug in NT light, don't know about NT pro.

            My experiments

            global replace ^p with "fred" - works fine
            global replace ^p with ^t - fails - puts a tab in but leaves the return
            global replace ^p with a space a ^t^ and a space - works fine
            global replace ^p with a space and a ^t - works fine
            global replace ^p with a ^t and a space - works fine
            global replace ^p with a space - fails - puts the space in but leaves the return
            global replace ^p with x - fails - puts the "x" in but leaves the return
            global replace ^p with xx - works fine

            Now a different test

            set up a replace for ^p with x
            find next
            replace
            replace
            replace

            what I see is an "x" inserted at each "replace" and the highlight moving to the right of the "x" (i.e. staying on the return).

            Similarly with find next/replace for ^p with ^t, where the highlight jumps right by a tab width.

            So the problem is not just with tabs, it's with replacement of ^p by any single character.

            OK gets funnier - a bit more testing (done with "find next/replace" so I can see what's going on) ...

            Replace a > and ^p with x - fails - the > is replaced by the x, but the return remains, and the highlight jumps to the next >^p (this html file has lots of them)

            Replace a > and ^p with xx - works fine

            Replace a ^p and a < with x - works fine.

            So, the two constants I'm seeing: search string ends with ^p but can have other items in it; replacement string is a single character (^t being counted as a single character).

            HTH

            Dave S

            ----- Original Message -----
            From: Don - htmlfixit.com
            To: notetab@yahoogroups.com
            Sent: Wednesday, March 02, 2005 11:12 PM
            Subject: Re: [NTB] ^P are forced on every line - how to stop?


            > --- In notetab@yahoogroups.com, "Alex Plantema" <alex.plantema@x>
            > wrote:
            >
            >>Op woensdag 23 februari 2005 02:52 schreef singtartreble:
            >>
            >>
            >>>I am trying to replace ^P with a ^T for a tab delimited file. I
            >
            > find
            >
            >>>that every replace still forces a ^P at the end of the line.
            >>>
            >>>So I end up with ^T^P when all I want is ^T
            >>>
            >>>Anyone have any thoughts on why this is and how to rectify
            >
            > please?

            Give us one or two lines of your content perhaps. Are you using clips
            or just using search and replace? This should be a simple one to fix.


            [Non-text portions of this message have been removed]
          • David Smart
            Sorry Jody, I d sent my message before I saw this. In my case, the status bar says Dos/Windows and so does the save format (and ANSI). Doing the adjust line
            Message 5 of 9 , Mar 2, 2005
            • 0 Attachment
              Sorry Jody, I'd sent my message before I saw this. In my case, the status bar says Dos/Windows and so does the save format (and ANSI). Doing the "adjust line breaks" doesn't improve things.

              Dave S

              ----- Original Message -----
              From: Jody
              To: notetab@yahoogroups.com
              Sent: Thursday, March 03, 2005 2:41 AM
              Subject: Re: [NTB] ^P are forced on every line - how to stop?


              Hi singtartreble,

              Hold your mouse pointer over the file and look at the Statusbar.
              Make sure it says Windows/DOS. If not, make a copy of the file
              and set your Save Format to Windows/DOS (ANSI) by right clicking
              over the tab and clicking on Save Format. Save the file. See what
              happens then. If the same, click on Reload Document under the
              Edit menu. Next, click on Modify | Lines | Adjust Line Breaks.
              Try the Find ^p and Replace with ^t then.

              If you are doing this with a Clip, the you need to loop the
              find/replace until no more ^p are found. You can use an ^!IfError
              or ^!IfCancel if you are not using the S OPTION. If you need help
              writing a Clip that will do what you want with one click, then
              please sign up for the Clips list.


              [Non-text portions of this message have been removed]
            • singtartreble
              Hi Jody Thanks for your reply. Also thanks to others who replied earlier. I have followed your suggestion and it still is the same. Someone suggested I include
              Message 6 of 9 , Mar 3, 2005
              • 0 Attachment
                Hi Jody

                Thanks for your reply. Also thanks to others who replied earlier.

                I have followed your suggestion and it still is the same.

                Someone suggested I include my file for people to have a look at.
                Not sure how this is done so I will put into the files folder here.

                The file is called: realestate2.txt

                If you look at the file from line 64 onwards you can see what the
                layout looks like. I have put # and ## as an attempt to setup a
                delimiter that is not a tab or space.

                The ## is a new record delimiter for now.

                From line 64 onwards you can see that each record is set out on
                about 4 lines. The records do vary in length and number of discrete
                values (fields) so 4 lines is average. Some are only 2 or 3 lines in
                total.

                What I want is to remove the line breaks so each record (several
                fields in each) is on one line so it then forms a tab delimited file.

                No matter what I do the find replace just leaves me with no changes.
                Its the same before and after despite reporting to me that 5000+
                replacements were made.

                Thanks again
                ST









                --- In notetab@yahoogroups.com, "David Smart" <smartware@o...> wrote:
                > Sorry Jody, I'd sent my message before I saw this. In my case,
                the status bar says Dos/Windows and so does the save format (and
                ANSI). Doing the "adjust line breaks" doesn't improve things.
                >
                > Dave S
                >
                > ----- Original Message -----
                > From: Jody
                > To: notetab@yahoogroups.com
                > Sent: Thursday, March 03, 2005 2:41 AM
                > Subject: Re: [NTB] ^P are forced on every line - how to stop?
                >
                >
                > Hi singtartreble,
                >
                > Hold your mouse pointer over the file and look at the Statusbar.
                > Make sure it says Windows/DOS. If not, make a copy of the file
                > and set your Save Format to Windows/DOS (ANSI) by right clicking
                > over the tab and clicking on Save Format. Save the file. See what
                > happens then. If the same, click on Reload Document under the
                > Edit menu. Next, click on Modify | Lines | Adjust Line Breaks.
                > Try the Find ^p and Replace with ^t then.
                >
                > If you are doing this with a Clip, the you need to loop the
                > find/replace until no more ^p are found. You can use an ^!IfError
                > or ^!IfCancel if you are not using the S OPTION. If you need help
                > writing a Clip that will do what you want with one click, then
                > please sign up for the Clips list.
                >
                >
                > [Non-text portions of this message have been removed]
              • Jody
                Hi David, ... You sent in enough information now. Yes, I could replicate it in NoteTab *Std/Light*. We have enough now to get the bug fixed. Thanks! Sorry for
                Message 7 of 9 , Mar 3, 2005
                • 0 Attachment
                  Hi David,

                  >Sorry Jody, I'd sent my message before I saw this. In my case,
                  >the status bar says Dos/Windows and so does the save format (and
                  >ANSI). Doing the "adjust line breaks" doesn't improve things.

                  You sent in enough information now. Yes, I could replicate it in
                  NoteTab *Std/Light*. We have enough now to get the bug fixed. Thanks!
                  Sorry for not getting into this more than I did. We've been
                  extremely busy.

                  Happy Tab'n,
                  Jody Adair

                  NoteTabbers Assistant Page Sojourners Software
                  http://www.notetab.net http://www.sojourner.us/software
                  http://www.fookes.us http://www.clean-funnies.com
                • Jody
                  Hi singtartreble, I can only suggest that you download the Trial version of Pro and if it does what you want, buy it. Std has the same problem as like. It has
                  Message 8 of 9 , Mar 4, 2005
                  • 0 Attachment
                    Hi singtartreble,

                    I can only suggest that you download the Trial version of Pro and
                    if it does what you want, buy it. Std has the same problem as
                    like. It has something to do with the way NoteTab is interacting
                    with the input control perhaps.

                    >Thanks for your reply. Also thanks to others who replied earlier.
                    >
                    >I have followed your suggestion and it still is the same.
                    >
                    >Someone suggested I include my file for people to have a look at.
                    >Not sure how this is done so I will put into the files folder here.
                    >
                    >The file is called: realestate2.txt
                    >
                    >If you look at the file from line 64 onwards you can see what the
                    >layout looks like. I have put # and ## as an attempt to setup a
                    >delimiter that is not a tab or space.
                    >
                    >The ## is a new record delimiter for now.
                    >
                    > From line 64 onwards you can see that each record is set out on
                    >about 4 lines. The records do vary in length and number of discrete
                    >values (fields) so 4 lines is average. Some are only 2 or 3 lines in
                    >total.
                    >
                    >What I want is to remove the line breaks so each record (several
                    >fields in each) is on one line so it then forms a tab delimited file.
                    >
                    >No matter what I do the find replace just leaves me with no changes.
                    >Its the same before and after despite reporting to me that 5000+
                    >replacements were made.


                    Happy Tab'n,
                    Jody Adair

                    NoteTabbers Assistant Page Sojourners Software
                    http://www.notetab.net http://www.sojourner.us/software
                    http://www.fookes.us http://www.clean-funnies.com
                  Your message has been successfully submitted and would be delivered to recipients shortly.