Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] Can't Display Korean Hangul

Expand Messages
  • Keith Russell
    Hi, Jody. I gave up on this after reading your reply and doing some more experimentation. I m back, though, because: 1. I hate having to use Notepad when I
    Message 1 of 5 , Jan 9, 2005
    • 0 Attachment
      Hi, Jody.

      I gave up on this after reading your reply and doing some more
      experimentation. I'm back, though, because:

      1. I hate having to use Notepad when I have something that should
      be so much better.
      2. I don't understand why this works so well in Notepad but not
      in NoteTab. It seems to me that NoteTab features and
      functionality should be a superset of Notepad's.

      Jody wrote:

      > There are two settings for document fonts. One is in View |
      > Options | Documents | Font... It controls the font used for all
      > new documents like when you click on the New Document icon on the
      > Toolbar (Ctrl+N) and also documents you have not set the font in.
      > The second is off the main menu under Documents | Font | Change
      > Font... It controls each document's settings, that is, the one
      > you have focused in NoteTab.


      I've tried changing both of these (and using several different
      Unicode and Korean fonts), and it makes no difference. I get
      nothing but garbage when trying to display Korean.

      > The settings are stored in
      > NoteTab's main folder in NoteTab.fpr (NotePro.fpr for Pro) and
      > remember between NoteTab sessions. Document Properties acts in
      > the same manner.


      I checked both these files, and all they have is a list of
      document paths....

      Could this be the problem? Are the font settings not changing
      anything?

      > If you would like to reset the file properties
      > in all documents you can do that under the Advanced tab in
      > Options.


      You've lost me here.

      Does anyone have any more ideas? Is no one else using NoteTab
      with Korean?

      P.S. I tried installing NoteTab Standard after my lack of success
      with NoteTab Light. I installed it to a different directory, but
      it still says NoteTab Light when I run and looks identical. Why
      is this?
    • Pete Hoyle
      ... I m not an expert, but I strongly suspect that the Korean character sets are Unicode rather than Ascii. Indeed, many non-Roman writing systems use unicode
      Message 2 of 5 , Jan 10, 2005
      • 0 Attachment
        At 07:53 PM 1/9/2005, Keith Russell wrote:

        >....
        >
        >I gave up on this after reading your reply and doing some more
        >experimentation. I'm back, though, because:
        >
        >1. I hate having to use Notepad when I have something that should
        >be so much better.
        >2. I don't understand why this works so well in Notepad but not
        >in NoteTab. It seems to me that NoteTab features and
        >functionality should be a superset of Notepad's.

        I'm not an expert, but I strongly suspect that the Korean character sets are Unicode rather than Ascii. Indeed, many non-Roman writing systems use unicode (I think it uses 16 bits per character rather than the 8 bits that extended Ascii uses). The Notetab help file explicitly says that when Notetab opens a unicode file, it converts into Ascii the characters that exist in Ascii, and the rest cannot be converted. I tried pasting some Korean that I cut from a web page into NoteTab Pro and what I got was a string of question marks. I pasted the same string into Wordpad and it showed up as Korean.

        Editors that handle unicode files have been especially written to do that. NoteTab is not written that way.



        --
        Pete Hoyle -- hoylesp@... (or use more permanent hoylesp@... for forwarding)
      • Jody
        Hi Keith, Sorry for being so late in replying. We ve been very busy... ... No, it shouldn t be the problem. You should have paths along with some other data
        Message 3 of 5 , Jan 17, 2005
        • 0 Attachment
          Hi Keith,

          Sorry for being so late in replying. We've been very busy...

          >> The settings are stored in NoteTab's main folder in NoteTab.fpr
          >> (NotePro.fpr for Pro) and remember between NoteTab sessions.
          >> Document Properties acts in the same manner.
          >
          >I checked both these files, and all they have is a list of
          >document paths....
          >
          >Could this be the problem? Are the font settings not changing
          >anything?

          No, it shouldn't be the problem. You should have paths along with
          some other data which NoteTab reads for the formatting of the
          document.

          >> If you would like to reset the file properties in all documents
          >> you can do that under the Advanced tab in Options.
          >
          >You've lost me here.
          >
          >P.S. I tried installing NoteTab Standard after my lack of success
          >with NoteTab Light. I installed it to a different directory, but
          >it still says NoteTab Light when I run and looks identical. Why
          >is this?

          Std/Light use the same input control, so the font issue should be
          the same in both of them. It is Pro that is different the those.
          You probably will not have any luck at all with Pro trying to
          display the font as Pete pointed out.

          As far as Light starting, my guess is that you are using a
          shortcut to Light thinking it is Std. Check out the shortcut
          Prosperities by right clicking over it.

          Other than setting the font and the script in Std/Light as we
          discussed I don't know of any other reason why it won't work or
          what to do to make it work.

          Happy Tab'n,
          Jody Adair

          NoteTabbers Assistant Page Sojourners Software
          http://www.notetab.net http://www.sojourner.us/software
          http://www.fookes.us http://www.clean-funnies.com
        Your message has been successfully submitted and would be delivered to recipients shortly.