Loading ...
Sorry, an error occurred while loading the content.

Shortcut key so eliminate the Toolbar

Expand Messages
  • treeline12345
    The only icons I use on the Toolbar setting are for FONT and Larger or Smaller Fonts. So I thought, how nifty to set up Shortcut keys for this and eliminate
    Message 1 of 5 , May 7, 2004
    • 0 Attachment
      The only icons I use on the Toolbar setting are for FONT and Larger
      or Smaller Fonts.

      So I thought, how nifty to set up Shortcut keys for this and
      eliminate another line on my monitor?

      Should be simple, yes?

      Would be nice to put the icons on the empty space on the very top
      line but that's not possible, where File to Help is, after the Help
      menu item.

      Looked into Shortcut.Dat which had shortcuts, but they are supposed
      to work?

      I guess I need to find the big Help file that I saw mentioned which
      goes into these details? When I use the Online Help, it does not have
      a setting for "Font" which surprised me.

      Thanks.
    • Jody
      Hi treeline12345, ... Yes. :) ... That you cannot do. I think in v5 we ll have movable Toolbars. We do not have an estimated time of release for v5, but it is
      Message 2 of 5 , May 7, 2004
      • 0 Attachment
        Hi treeline12345,

        >The only icons I use on the Toolbar setting are for FONT and
        >Larger or Smaller Fonts.
        >
        >So I thought, how nifty to set up Shortcut keys for this and
        >eliminate another line on my monitor?
        >
        >Should be simple, yes?

        Yes. :)

        >Would be nice to put the icons on the empty space on the very top
        >line but that's not possible, where File to Help is, after the
        >Help menu item.

        That you cannot do. I think in v5 we'll have movable Toolbars.
        We do not have an estimated time of release for v5, but it is
        being worked on. It will take quite awhile to complete though.
        The program is being rewritten from scratch.

        >Looked into Shortcut.Dat which had shortcuts, but they are
        >supposed to work?

        Of course they're suppose to. <g>

        You first add the shortcut keys you want to use. Check them out
        first to see if they are being used. You can open a few documents
        first since some shortcuts require that to be used. Sort of like
        if no text is edit the Ctrl+S shortcut is not available to Save.
        Also reference "keyboard shortcuts" in Help.

        So, the shortcut you would like to use first, then a space, and
        then the menu items separated with a forward slash. There is a
        rule when encountering and ellipse (...). Reference Shortcuts.dat
        for that and for quoting some items.

        So, put these in Shortcuts.dat. As soon as you save the file,
        Alt+Z will increase the font size and Alt+Shift+Z decreases.

        Alt+Z Document/Font/Increase Size
        Alt+Shift+Z Document/Font/Decrease Size

        If you use an existing shortcut it will be used to do what you
        want and be disabled for its default purpose. All the shortcuts
        that you make will appear next to the corresponding menu item.
        (Slick, eh?;)

        Note: If you change an existing shortcut to something else,
        simply removing the change will not set the existing shortcut
        back. You must re-map the shortcut yourself like if you used
        "Alt+C File/Save," you need to use "Ctrl+S File/Save" to revert
        back. Once the command is used once it may be removed from
        Shortcuts.dat (I would only remove the default shortcuts like if
        you reverted back to "File/Save Ctrl+S.")

        This is from Shortcuts.dat in Help...

        Changing Keyboard Shortcuts
        You can now change the default keyboard shortcuts for menu items
        by creating a definition file called Shortcuts.dat in the NoteTab
        program folder. Place one shortcut reassignment per line. Start
        the line with the shortcut value, followed by a space, followed by
        the menu item. The first menu name in the sequence is the one that
        appears at the top of the main menu, followed by submenu names (if
        any), and then the name of the final menu item to activate. You
        must separate submenu items with a forward slash and leave out any
        ellipsis. You should put double quotes around a menu name if it
        contains one or more forward slash characters. The case of
        characters does not have to be the same as the actual menu
        commands. You can comment out shortcuts by putting a semicolon at
        the start of the line. Note that this feature is not available in
        NoteTab Light.

        Contents example for the Shortcuts.dat file:

        ;This line starts with a semicolon and is ignored by NoteTab
        Ctrl+Shift+F Document/Font/Change Font
        Ctrl+T Document/"Insert Date/Time"

        >I guess I need to find the big Help file that I saw mentioned
        >which goes into these details? When I use the Online Help, it
        >does not have a setting for "Font" which surprised me.

        I know not of what Help file you speak of. Use the Search tab in
        Help and search for font.

        Happy Tab'n,
        Jody Adair

        NoteTabbers Assistant Page Sojourners Software
        http://www.notetab.net http://www.sojourner.us/software
        http://www.fookes.us http://www.clean-funnies.com
      • treeline12345
        ... That s what I thought but my system has a life of its own. For example, I put in CONTROL T, and up pops another text file editor, UltraEdit. I don t know
        Message 3 of 5 , May 8, 2004
        • 0 Attachment
          --- In notetab@yahoogroups.com, Jody <kjv-av1611@e...> wrote:

          > Hi treeline12345,

          > >Looked into Shortcut.Dat which had shortcuts, but they are
          > >supposed to work?
          >
          > Of course they're suppose to. <g>
          >
          > You first add the shortcut keys you want to use. Check them out
          > first to see if they are being used. You can open a few documents
          > first since some shortcuts require that to be used. Sort of like
          > if no text is edit the Ctrl+S shortcut is not available to Save.
          > Also reference "keyboard shortcuts" in Help.
          >
          > So, the shortcut you would like to use first, then a space, and
          > then the menu items separated with a forward slash. There is a
          > rule when encountering and ellipse (...). Reference Shortcuts.dat
          > for that and for quoting some items.
          >
          > So, put these in Shortcuts.dat. As soon as you save the file,
          > Alt+Z will increase the font size and Alt+Shift+Z decreases.
          >
          > Alt+Z Document/Font/Increase Size
          > Alt+Shift+Z Document/Font/Decrease Size

          That's what I thought but my system has a life of its own.
          For example, I put in CONTROL T, and up pops another
          text file editor, UltraEdit. I don't know why? Did I specify
          another editor in NoteTab at one time?


          > If you use an existing shortcut it will be used to do what you
          > want and be disabled for its default purpose. All the shortcuts
          > that you make will appear next to the corresponding menu item.
          > (Slick, eh?;)

          Very slick, but not yet, maybe tomorrow on mine :)
          Something is blocking the keyboard shortcuts apparently.
          Well blocking my specifying in NoteTab. I do have
          some shortcuts but not sure where and why.


          > Ctrl+Shift+F Document/Font/Change Font
          > Ctrl+T Document/"Insert Date/Time"

          Ctrl + T bring up another editor, go figure.
          Brings up UltraEdit, sometimes it brings up
          yet another editor, PFE, an oldie but goodie.

          Really, can't figure out why it does this.
          Must be triggering a search for an internal
          editor, but why it switches between 2 internal
          or infernal editors, beats me, ouch!


          > >I guess I need to find the big Help file that I saw mentioned
          > >which goes into these details? When I use the Online Help, it
          > >does not have a setting for "Font" which surprised me.
          >
          > I know not of what Help file you speak of. Use the Search tab in
          > Help and search for font.

          That was my point. There is not any "font" in the Help files.
          Really. Try it and find the word "font" anywhere in the Help
          files. It does not exist. You think I am kidding, I bet.


          Thanks,
          Treeline
        • Larry Thomas
          ... ... I have had this problem on my system before and it was caused by a freeware utility that I have called Hotkeys which was already set for a
          Message 4 of 5 , May 8, 2004
          • 0 Attachment
            At 05:45 PM 5/8/04 -0000, you wrote:
            >--- In notetab@yahoogroups.com, Jody <kjv-av1611@e...> wrote:
            >
            >> Hi treeline12345,

            <snip>

            >That's what I thought but my system has a life of its own.
            >For example, I put in CONTROL T, and up pops another
            >text file editor, UltraEdit. I don't know why? Did I specify
            >another editor in NoteTab at one time?

            I have had this problem on my system before and it was caused by a freeware
            utility that I have called "Hotkeys" which was already set for a shortcut I
            wanted to use. I went into "Hotkeys" and disabled that key and then
            NoteTab worked fine with it.

            >> If you use an existing shortcut it will be used to do what you
            >> want and be disabled for its default purpose. All the shortcuts
            >> that you make will appear next to the corresponding menu item.
            >> (Slick, eh?;)
            >
            >Very slick, but not yet, maybe tomorrow on mine :)
            >Something is blocking the keyboard shortcuts apparently.
            >Well blocking my specifying in NoteTab. I do have
            >some shortcuts but not sure where and why.
            >
            >
            >> Ctrl+Shift+F Document/Font/Change Font
            >> Ctrl+T Document/"Insert Date/Time"

            Why do you need another shortcut to insert the date and time? There is
            already a shortcut for this. When you drop down the menu, you will see
            beside "Insert Date/Time" on the menu F5. That means you press F5 to
            insert the date and time into your document.

            >Ctrl + T bring up another editor, go figure.
            >Brings up UltraEdit, sometimes it brings up
            >yet another editor, PFE, an oldie but goodie.
            >
            >Really, can't figure out why it does this.
            >Must be triggering a search for an internal
            >editor, but why it switches between 2 internal
            >or infernal editors, beats me, ouch!

            If you go to the menu bar and select View/Options and then select the
            "Tools" tab, you will see an item labled "Custom Launch". You probably
            have set up your UltraEdit in that box. If so, Ctrl+T will launch it.

            >> >I guess I need to find the big Help file that I saw mentioned
            >> >which goes into these details? When I use the Online Help, it
            >> >does not have a setting for "Font" which surprised me.
            >>
            >> I know not of what Help file you speak of. Use the Search tab in
            >> Help and search for font.
            >
            >That was my point. There is not any "font" in the Help files.
            >Really. Try it and find the word "font" anywhere in the Help
            >files. It does not exist. You think I am kidding, I bet.

            You can find the word font all over the help files. To do so go to the
            menu bar and select Help/Help Topics. Then on the upper left side you will
            see a series of tabs. Select the on labeled search and enter the word
            "font" where it says to "Type in the word to search for". Now click on the
            button labeled "List Topics". When the list of topics appears, select on
            of them and click on the button that is labeled "Display". Now you wil see
            that document on the right side and when you scroll through it you will see
            that every occcurrence of the word "font" is highlighted for you.

            In practical terms, I go through all of the menus and look for the one that
            changes fonts which is under the document menu item. Then I go to the help
            file and look down the left side to "Reference Information" and open that
            one and look for "Menu Commands" and open that one and then look for
            "Documents Menu" and click on that one which displays it on the right side.
            Then I scroll down until I find:

            Font
            Change the current document font, or increase/decrease its size. Using
            these commands turns off the "Default Properties" setting.

            Which is not a lot but better than nothing.

            Regards,

            Larry
            lrt@... e¿ê
          • treeline12345
            ... freeware ... shortcut I ... I don t have any resident programs that do this. If they do, they are not showing up in the task manager s list. The CONTROL -
            Message 5 of 5 , May 9, 2004
            • 0 Attachment
              --- In notetab@yahoogroups.com, Larry Thomas <larryt@c...> wrote:

              > >--- In notetab@yahoogroups.com, Jody <kjv-av1611@e...> wrote:

              > >> Hi treeline12345,
              > >That's what I thought but my system has a life of its own.
              > >For example, I put in CONTROL T, and up pops another
              > >text file editor, UltraEdit. I don't know why? Did I specify
              > >another editor in NoteTab at one time?

              > I have had this problem on my system before and it was caused by a
              freeware
              > utility that I have called "Hotkeys" which was already set for a
              shortcut I
              > wanted to use. I went into "Hotkeys" and disabled that key and then
              > NoteTab worked fine with it.

              I don't have any resident programs that do this. If they do,
              they are not showing up in the task manager's list. The
              CONTROL - ALT - DELETE thingee.


              > >> If you use an existing shortcut it will be used to do what you
              > >> want and be disabled for its default purpose. All the shortcuts
              > >> that you make will appear next to the corresponding menu item.
              > >> (Slick, eh?;)
              > >
              > >Very slick, but not yet, maybe tomorrow on mine :)
              > >Something is blocking the keyboard shortcuts apparently.
              > >Well blocking my specifying in NoteTab. I do have
              > >some shortcuts but not sure where and why.
              > >
              > >
              > >> Ctrl+Shift+F Document/Font/Change Font
              > >> Ctrl+T Document/"Insert Date/Time"


              > Why do you need another shortcut to insert the date and time?
              There is
              > already a shortcut for this. When you drop down the menu, you will
              see
              > beside "Insert Date/Time" on the menu F5. That means you press F5
              to
              > insert the date and time into your document.

              It's not a question of "need" - it's a question of getting
              the shortcuts to work as they should. The F5 does work!!
              The shortcuts in Shortcuts.DAT do not work!?!

              I also noticed that the file Shortcuts.DAT is being
              arbitrarily changed in its extention to .TXT
              and other things, so obviously there are some
              shenannigans? going on.


              > >Ctrl + T bring up another editor, go figure.
              > >Brings up UltraEdit, sometimes it brings up
              > >yet another editor, PFE, an oldie but goodie.
              > >
              > >Really, can't figure out why it does this.
              > >Must be triggering a search for an internal
              > >editor, but why it switches between 2 internal
              > >or infernal editors, beats me, ouch!
              >
              > If you go to the menu bar and select View/Options and then select
              the
              > "Tools" tab, you will see an item labled "Custom Launch". You
              probably
              > have set up your UltraEdit in that box. If so, Ctrl+T will launch
              it.

              Actually, Custom Launch is empty. So it's all a mystery so far.
              Especially since TWO editors come up, not at the same time,
              but I get either PFE or UltraEdit, taking turns!!!

              > file and look down the left side to "Reference Information" and
              open that
              > one and look for "Menu Commands" and open that one and then look for
              > "Documents Menu" and click on that one which displays it on the
              right side.
              > Then I scroll down until I find:
              >
              > Font
              > Change the current document font, or increase/decrease its size.
              Using
              > these commands turns off the "Default Properties" setting.
              >
              > Which is not a lot but better than nothing.
              >
              > Regards,
              >
              > Larry


              Thanks, it's a workable hint but very unwieldy. A listing for
              FONT in the main help file or Searchable would be something
              to consider. I figured it was left out by accident and
              because there is not much to be said about it. If someone
              needs help doing a Font, maybe they should not be using
              a text editor - that sort of thing.

              When I get up the energy, I'll probably re-install everything
              and see if that helps out matters. I suspect something is
              going on in my rig that is hard to duplicate on others, hence
              it may not be possible to address my problems - weird :(

              Thanks for the replies, Larry and Jody.
            Your message has been successfully submitted and would be delivered to recipients shortly.