Loading ...
Sorry, an error occurred while loading the content.

Re: [NTB] NoteTab and Win2000, Weird Behavior

Expand Messages
  • Eric G.V. Fookes
    Hello Virgil, ... NoteTab Light uses the Windows rich-edit control, so failure to accept the paste is probably due to this control rather than NoteTab. Have
    Message 1 of 4 , Apr 3 10:01 AM
    View Source
    • 0 Attachment
      Hello Virgil,

      >Recently, however, my employer upgraded me to Windows 2000. Now, when I
      >attempt to insert the RTF codes, I am unable to insert any code that starts
      >with the string "{\rtf". NoteTab just refuses to insert the code.
      >
      >I've also tried to Copy and Paste the code to no avail. NoteTab refuses to
      >paste the string "{\rtf". I can copy it in NoteTab and paste it in other
      >editors, but not in NoteTab. Hitting CTRL-V or Paste from the menu simply
      >does nothing.
      >
      >Does anybody out there have a clue what might be happening here? I'm using
      >Windows 2000 (Version 5, Build 2195, Service Pack 2) and NoteTab Light
      >4.86c.

      NoteTab Light uses the Windows rich-edit control, so failure to accept the
      paste is probably due to this control rather than NoteTab. Have you tried
      doing this with the trial version of NoteTab Pro?


      Regards,
      Eric G.V. Fookes
      Author of NoteTab, Mailbag Assistant, and Album Express
      http://www.fookes.com/ and http://www.notetab.com/







      ...
    • Jody
      Hi Virgil, I d be more than happy to test your Library in XP Pro. ;) Can you send it to me in private eMail or put it on the web for download please? I ll
      Message 2 of 4 , Apr 3 10:59 AM
      View Source
      • 0 Attachment
        Hi Virgil,

        I'd be more than happy to test your Library in XP Pro. ;) Can
        you send it to me in private eMail or put it on the web for
        download please? I'll send you a suggestion via private eMail
        since it deals with Clip code and "everybody" knows we do not
        post Clip code on this list, don't we? <bg>

        Oh, check to make sure your files are not marked read-only,
        especially if you can insert the rtf code in a new document.

        >I use NoteTab Light to create Rich Text Files for importing into a full
        >fledged word processor. I do this by inserting the appropriate Rich Text
        >codes into a basic text file. I use the ^!Replace command in a clipbook to
        >replace dot lines (of my own imagination) with the appropriate RTF code.
        >
        >One of the codes that must be inserted into every RTF file starts with the
        >string, "{\rtf". Without it, an RTF reader won't read the RTF formatting
        >codes I've inserted into the file.
        >
        >Does anybody out there have a clue what might be happening here? I'm using
        >Windows 2000 (Version 5, Build 2195, Service Pack 2) and NoteTab Light
        >4.86c.


        Happy Clip'n!
        Jody

        http://www.notetab.net

        Subscribe, UnSubscribe, Options
        mailto:Ntb-Clips-Subscribe@yahoogroups.com
        mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
        http://groups.yahoo.com/group/ntb-clips
      • Virgil Arrington Jr.
        I use NoteTab Light to create Rich Text Files for importing into a full fledged word processor. I do this by inserting the appropriate Rich Text codes into a
        Message 3 of 4 , Apr 3 4:47 PM
        View Source
        • 0 Attachment
          I use NoteTab Light to create Rich Text Files for importing into a full
          fledged word processor. I do this by inserting the appropriate Rich Text
          codes into a basic text file. I use the ^!Replace command in a clipbook to
          replace dot lines (of my own imagination) with the appropriate RTF code.

          One of the codes that must be inserted into every RTF file starts with the
          string, "{\rtf". Without it, an RTF reader won't read the RTF formatting
          codes I've inserted into the file.

          I have used this method successfully on PC's running both Win95 and Win98.

          Recently, however, my employer upgraded me to Windows 2000. Now, when I
          attempt to insert the RTF codes, I am unable to insert any code that starts
          with the string "{\rtf". NoteTab just refuses to insert the code.

          I've also tried to Copy and Paste the code to no avail. NoteTab refuses to
          paste the string "{\rtf". I can copy it in NoteTab and paste it in other
          editors, but not in NoteTab. Hitting CTRL-V or Paste from the menu simply
          does nothing.

          Does anybody out there have a clue what might be happening here? I'm using
          Windows 2000 (Version 5, Build 2195, Service Pack 2) and NoteTab Light
          4.86c.

          Thanks

          Virgil

          _________________________________________________________________
          Join the world�s largest e-mail service with MSN Hotmail.
          http://www.hotmail.com
        • Virgil Arrington Jr.
          From Eric, ... Thanks for the quick response. I just downloaded the Pro Trial version and it did not behave the same way. In other words, my clip worked fine
          Message 4 of 4 , Apr 3 8:24 PM
          View Source
          • 0 Attachment
            From Eric,

            >NoteTab Light uses the Windows rich-edit control, so failure to accept the
            >paste is probably due to this control rather than NoteTab. Have you tried
            >doing this with the trial version of NoteTab Pro?


            Thanks for the quick response.

            I just downloaded the Pro Trial version and it did not behave the same way.
            In other words, my clip worked fine in Pro and properly pasted the "{\rtf"
            string.

            I checked my Windows System32 folder and found the following Rich Edit
            Control dll's

            Riched20.dll
            Rich Text Edit Control, v3.0
            File Version 5.30.23.1205

            and

            Riched32.dll
            Wrapper Dll for Richedit 1.0
            File Version 5.0.2134.1

            I also found a workaround for Light. I just insert the string "\rtf", which
            Light will allow me to do, then do a CTRL+Home and insert the "{" character.
            It works, albeit slightly less elegantly.

            Thanks again for your help.

            Virgil


            _________________________________________________________________
            Send and receive Hotmail on your mobile device: http://mobile.msn.com
          Your message has been successfully submitted and would be delivered to recipients shortly.