Loading ...
Sorry, an error occurred while loading the content.

error message when installing nmrPipe on mac

Expand Messages
  • mengxi_44
    Dear All: I am installing nmrPipe on a mac machine with OS X. after the installation completed, I ran bruker to test the package, but system gave the error
    Message 1 of 4 , Mar 3, 2005
    • 0 Attachment
      Dear All:

      I am installing nmrPipe on a mac machine with OS X. after the installation
      completed, I ran "bruker" to test the package, but system gave the error
      message as following:

      *****************
      Xlib: extension "XFree86-Misc" missing on display ":0.0".
      BINVAL: Undefined variable.
      ***********************

      Can anyone give me a hint about what is going on here?

      Xi
    • Geoff Armstrong
      There are two things you should check when running nmrPipe on the mac. I m guessing that your problem may be realated to the second one. First, the default
      Message 2 of 4 , Mar 4, 2005
      • 0 Attachment
        There are two things you should check when running nmrPipe on the mac.
        I'm guessing that your problem may be realated to the second one.

        First, the default shell on Mac OS X is bash rather than csh. You
        must make sure that you start a csh before you start trying to run any
        nmrPipe scripts. The usual clue that you are in the wrong shell is a
        $ ending your prompt string. In csh the last character of the prompt
        will usually be a %. Type /bin/tcsh to start a csh.

        Second, the default installation for OS 10.3 does not include the X11
        package. This is required to run any of the tk based scripts (i.e.
        scripts with windows). You need to manually install the X11 package
        from the installation discs. For panther I believe it is on the third
        disc. X11 must also be running when you start the scripts, so if you
        use Terminal for the command line open X11 first.

        Hopefully checking one or both of these issues will solve your
        problem. If not, let us know, someone will help for sure.

        Geoff

        --- In nmrpipe@yahoogroups.com, "mengxi_44" <mengxi_44@y...> wrote:
        >
        >
        > Dear All:
        >
        > I am installing nmrPipe on a mac machine with OS X. after the
        installation
        > completed, I ran "bruker" to test the package, but system gave the
        error
        > message as following:
        >
        > *****************
        > Xlib: extension "XFree86-Misc" missing on display ":0.0".
        > BINVAL: Undefined variable.
        > ***********************
        >
        > Can anyone give me a hint about what is going on here?
        >
        > Xi
      • Frank Delaglio
        Many thanks to our friend Geoff for this useful reply. Also, perhaps some Mac expert has additional wisdom on the topic: the NMRPipe install notes describe a
        Message 3 of 4 , Mar 4, 2005
        • 0 Attachment
          Many thanks to our friend Geoff for this useful reply.

          Also, perhaps some Mac expert has additional wisdom on the topic:
          the NMRPipe install notes describe a "suggested" procedure for setting
          the default shell, but it doesn't always seem to work ...
          anyone know of an alternative for setting the default shell?


          Mac OS X
          ________

          The currently posted Mac software was built on Max OS X, version 10.3,
          using XFree86 4.2.0. The various NMRPipe graphical tools will require
          that X11 graphics server and libraries have been installed.

          When using graphical programs in the NMRPipe system, also note that all
          versions of the software expect use of a three-button mouse or its
          equivalent.

          To install and use NMRPipe on the Mac, you'll have to do at least
          two additional things:

          1. You have to be using the c-shell (or t c-shell) not bash or
          some other shell. To do this, run the application "Terminal"
          in the folder "Applications/Utilities". Then, in
          "Terminal/Preferences" set the following:

          o Execute this command: /bin/tcsh

          2. Start the X11 graphics server. You can find Mac's X11 server
          in folder Applications/Utilities. It will be helpful to drag
          a copy of this application to the Mac OS X command Dock so that
          you can start and control the X11 graphics server easily at any
          time.

          On Fri, 4 Mar 2005, Geoff Armstrong wrote:

          >
          >
          >
          > There are two things you should check when running nmrPipe on the mac.
          > I'm guessing that your problem may be realated to the second one.
          >
          > First, the default shell on Mac OS X is bash rather than csh. You
          > must make sure that you start a csh before you start trying to run any
          > nmrPipe scripts. The usual clue that you are in the wrong shell is a
          > $ ending your prompt string. In csh the last character of the prompt
          > will usually be a %. Type /bin/tcsh to start a csh.
          >
          > Second, the default installation for OS 10.3 does not include the X11
          > package. This is required to run any of the tk based scripts (i.e.
          > scripts with windows). You need to manually install the X11 package
          > from the installation discs. For panther I believe it is on the third
          > disc. X11 must also be running when you start the scripts, so if you
          > use Terminal for the command line open X11 first.
          >
          > Hopefully checking one or both of these issues will solve your
          > problem. If not, let us know, someone will help for sure.
          >
          > Geoff
          >
          > --- In nmrpipe@yahoogroups.com, "mengxi_44" <mengxi_44@y...> wrote:
          > >
          > >
          > > Dear All:
          > >
          > > I am installing nmrPipe on a mac machine with OS X. after the
          > installation
          > > completed, I ran "bruker" to test the package, but system gave the
          > error
          > > message as following:
          > >
          > > *****************
          > > Xlib: extension "XFree86-Misc" missing on display ":0.0".
          > > BINVAL: Undefined variable.
          > > ***********************
          > >
          > > Can anyone give me a hint about what is going on here?
          > >
          > > Xi
          >
          >
          >
          >
          >
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
          >
        • Pedro Aguiar
          Dear nmrpipers, I would not call myself any sort of mac expert, but here is how I have found to change the shell type. 1) For 10.3.X from the terminal or xterm
          Message 4 of 4 , Mar 5, 2005
          • 0 Attachment
            Dear nmrpipers,

            I would not call myself any sort of mac expert, but here is how I have found to change the
            shell type.

            1) For 10.3.X
            from the terminal or xterm in X11 type the following:
            chpass -s /bin/tcsh or chpass -s /bin/csh

            I know you recommend csh, but I have never had an issue with tcsh.

            2) for 10.1 and 10.2 (never tried for 10.0, but assume it's the same)
            chpass utility doesn't seem to be implemented, though this may have been due to
            version of X-11 and not OS X.

            from the terminal or xterm in X11 type the following:
            chsh

            this will open a database file in the vi editor containing info such as user's full name, and
            shell type. You need to change the line "Shell: /bin/bash" to /bin/tcsh (or /bin/csh).

            You must restart computer for the changes to take affect.

            Cheers,

            Pedro M. Aguiar

            --- In nmrpipe@yahoogroups.com, Frank Delaglio <delaglio@s...> wrote:
            >
            > Many thanks to our friend Geoff for this useful reply.
            >
            > Also, perhaps some Mac expert has additional wisdom on the topic:
            > the NMRPipe install notes describe a "suggested" procedure for setting
            > the default shell, but it doesn't always seem to work ...
            > anyone know of an alternative for setting the default shell?
            >
            >
            > Mac OS X
            > ________
            >
            > The currently posted Mac software was built on Max OS X, version 10.3,
            > using XFree86 4.2.0. The various NMRPipe graphical tools will require
            > that X11 graphics server and libraries have been installed.
            >
            > When using graphical programs in the NMRPipe system, also note that all
            > versions of the software expect use of a three-button mouse or its
            > equivalent.
            >
            > To install and use NMRPipe on the Mac, you'll have to do at least
            > two additional things:
            >
            > 1. You have to be using the c-shell (or t c-shell) not bash or
            > some other shell. To do this, run the application "Terminal"
            > in the folder "Applications/Utilities". Then, in
            > "Terminal/Preferences" set the following:
            >
            > o Execute this command: /bin/tcsh
            >
            > 2. Start the X11 graphics server. You can find Mac's X11 server
            > in folder Applications/Utilities. It will be helpful to drag
            > a copy of this application to the Mac OS X command Dock so that
            > you can start and control the X11 graphics server easily at any
            > time.
            >
            > On Fri, 4 Mar 2005, Geoff Armstrong wrote:
            >
            > >
            > >
            > >
            > > There are two things you should check when running nmrPipe on the mac.
            > > I'm guessing that your problem may be realated to the second one.
            > >
            > > First, the default shell on Mac OS X is bash rather than csh. You
            > > must make sure that you start a csh before you start trying to run any
            > > nmrPipe scripts. The usual clue that you are in the wrong shell is a
            > > $ ending your prompt string. In csh the last character of the prompt
            > > will usually be a %. Type /bin/tcsh to start a csh.
            > >
            > > Second, the default installation for OS 10.3 does not include the X11
            > > package. This is required to run any of the tk based scripts (i.e.
            > > scripts with windows). You need to manually install the X11 package
            > > from the installation discs. For panther I believe it is on the third
            > > disc. X11 must also be running when you start the scripts, so if you
            > > use Terminal for the command line open X11 first.
            > >
            > > Hopefully checking one or both of these issues will solve your
            > > problem. If not, let us know, someone will help for sure.
            > >
            > > Geoff
            > >
            > > --- In nmrpipe@yahoogroups.com, "mengxi_44" <mengxi_44@y...> wrote:
            > > >
            > > >
            > > > Dear All:
            > > >
            > > > I am installing nmrPipe on a mac machine with OS X. after the
            > > installation
            > > > completed, I ran "bruker" to test the package, but system gave the
            > > error
            > > > message as following:
            > > >
            > > > *****************
            > > > Xlib: extension "XFree86-Misc" missing on display ":0.0".
            > > > BINVAL: Undefined variable.
            > > > ***********************
            > > >
            > > > Can anyone give me a hint about what is going on here?
            > > >
            > > > Xi
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > > Yahoo! Groups Links
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
          Your message has been successfully submitted and would be delivered to recipients shortly.