Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nmrpipe] File selection dialog problem in TCL scripts

Expand Messages
  • delaglio@nmrscience.com
    HUZZAH!!! we posted an update which should fix this.
    Message 1 of 3 , Sep 1, 2011
      HUZZAH!!! we posted an update which should fix this.

      Quoting Andrew <andrew-fowler@...>:

      > I recently updated my old (2007) NMRPipe installation, and now I
      > have a problem selecting input files with any Tcl (or NMRWish)
      > script. As far as I can tell, everything else is working fine.
      >
      > In short, any script that uses a file selection dialog
      > (tk_getOpenFile), such as view2D.tcl, don't allow me to use the GUI
      > to actually select a file to open.
      >
      > The file browser opens fine and I can change directories, but if I
      > double click a file (i.e. test.ft2) or single click it then click
      > "Open", nothing happens - the dialog just sits there (no errors). If
      > I use any of the various other ways to input a filename, the scripts
      > work fine: enter the file on the command line, type into the
      > filename box without using the browser, or even type the filename on
      > the appropriate line in the file browser (after which clicking
      > "Open" works and even updates to the correct full path).
      >
      > The problem seems to be related to something included with the newer
      > version of NMRPipe. When I updated, I backed out the older version.
      > If I restore that version, the dialogs work again, and if I swap
      > back to the new version they don't.
      >
      > There are at least a few differences in files in the nmrtcl
      > directory between the old and new versions of NMRPipe.
      > NMRPIPE_TCL_LIB points to $NMRPIPE/nmrtcl/tcl8.4 either way (the
      > rest of the environment variables are similarly set correctly). The
      > old version also has some Tcl 7.6/Tk 4.2 directories, but they're
      > presumably being ignored.
      >
      > Here is a list of some other things I've tried just in case, none
      > have helped:
      >
      > 1. started with Mac OS X 10.6.7; updated to 10.6.8
      > 2. installed the most recent XQuartz
      > 3. tried starting from both Terminal and an xterm
      > 4. tried changing the symlinks in /System/Library/Frameworks to
      > point to Tcl/Tk 8.4 instead of 8.5.
      >
      > Mostly this is just annoying since the scripts still work, but I'd
      > love to have things working normally again. Any ideas?
      >
      > Thanks,
      > Andrew
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.