Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nmrpipe] autoFit.tcl with lots of spectra

Expand Messages
  • Frank Delaglio
    Greetings, all ... Yes, I think we had an earlier post about this too ... anyway, some lazy unimaginitive bastard hard-coded a 64 parameter limit per signal.
    Message 1 of 5 , Apr 27 9:26 AM

      Greetings, all ...

      Yes, I think we had an earlier post about this
      too ... anyway, some lazy unimaginitive bastard
      hard-coded a 64 parameter limit per signal.
      In a 2D series, this would be enough for two
      position parameters, two line width parameters,
      and 60 amplitudes.

      If a cure is critical, contact big fd directly,
      you can probably embarrass him into helping ...

      Cheerful regards

      F

      Sent from my iSmudge

      On Apr 25, 2008, at 5:16 PM, Sébastien Morin <sebastien.morin.1@...> wrote:

      Hi,

      I am currently trying to use autoFit.tcl with lots of spectra (i.e. 76).

      I used it before with success, but I get the error :

      ============ ========= ========= ======
      Peak 155 of 155
      Segmentation fault
      XYZ2Pipe Partition: Plane 1 to 76 of 76
      XY Plane 76 of 76
      RdTable File open error: nlin.tab.
      SimSpecND Error reading data table nlin.tab
      ============ ========= ========= ======

      If I reduce the number of spectra to 60, it works fine. However, it
      won't work with 61 spectra...

      I searched for a limit somewhere in the code, but could find one.

      Is there some hard coded limit for autoFit.tcl ?

      Thanks !

      Séb

    • Sébastien Morin
      Hi Frank, Thanks for the information. A cure is not critical..! I managed to trim my dataset without losing information... I had a lot of duplicates out of
      Message 2 of 5 , Apr 28 1:20 PM
        Hi Frank,

        Thanks for the information.

        A cure is not critical..! I managed to trim my dataset without losing
        information... I had a lot of duplicates out of these 76 points. 60
        being already a pretty high number of datapoints, I could take out some
        16 superfluous duplicates...

        Thanks again and sorry for bothering with such an extravagant request !


        Séb :)



        Frank Delaglio wrote:
        >
        > Greetings, all ...
        >
        > Yes, I think we had an earlier post about this
        > too ... anyway, some lazy unimaginitive bastard
        > hard-coded a 64 parameter limit per signal.
        > In a 2D series, this would be enough for two
        > position parameters, two line width parameters,
        > and 60 amplitudes.
        >
        > If a cure is critical, contact big fd directly,
        > you can probably embarrass him into helping ...
        >
        > Cheerful regards
        >
        > F
        >
        > Sent from my iSmudge
        >
        > On Apr 25, 2008, at 5:16 PM, Sébastien Morin
        > <sebastien.morin.1@...> wrote:
        >
        >> Hi,
        >>
        >> I am currently trying to use autoFit.tcl with lots of spectra (i.e. 76).
        >>
        >> I used it before with success, but I get the error :
        >>
        >> ====================================
        >> Peak 155 of 155
        >> Segmentation fault
        >> XYZ2Pipe Partition: Plane 1 to 76 of 76
        >> XY Plane 76 of 76
        >> RdTable File open error: nlin.tab.
        >> SimSpecND Error reading data table nlin.tab
        >> ====================================
        >>
        >> If I reduce the number of spectra to 60, it works fine. However, it
        >> won't work with 61 spectra...
        >>
        >> I searched for a limit somewhere in the code, but could find one.
        >>
        >> Is there some hard coded limit for autoFit.tcl ?
        >>
        >> Thanks !
        >>
        >> Séb
        >>
        >>
        >>
        >
      • IAN KLECKNER
        For whatever its worth, instead of removing those spectra entirely from your analysis, you may consider using the addNMR command to combine their information
        Message 3 of 5 , Apr 28 1:55 PM
          For whatever its worth, instead of removing those spectra entirely from your analysis, you may consider using the "addNMR" command to combine their information (e.g. better S/N) and run the autoFit.tcl with the added spectra.

          I think this is legit, but please correct me if I am wrong.

          -Ian

          ----- Original Message -----
          From: Sébastien Morin <sebastien.morin.1@...>
          Date: Monday, April 28, 2008 4:51 pm
          Subject: Re: [nmrpipe] autoFit.tcl with lots of spectra
          To: nmrpipe@yahoogroups.com

          > Hi Frank,

          > Thanks for the information.

          > A cure is not critical..! I managed to trim my dataset without losing
          > information.> .. I had a lot of duplicates out of these 76 points. 60
          > being already a pretty high number of datapoints, I could take out some
          > 16 superfluous duplicates..> .

          > Thanks again and sorry for bothering with such an extravagant request !

          > Séb :)

          > Frank Delaglio wrote:
          > >
          > > Greetings, all ...
          > >
          > > Yes, I think we had an earlier post about this
          > > too ... anyway, some lazy unimaginitive bastard
          > > hard-coded a 64 parameter limit per signal.
          > > In a 2D series, this would be enough for two
          > > position parameters, two line width parameters,
          > > and 60 amplitudes.
          > >
          > > If a cure is critical, contact big fd directly,
          > > you can probably embarrass him into helping ...
          > >
          > > Cheerful regards
          > >
          > > F
          > >
          > > Sent from my iSmudge
          > >
          > > On Apr 25, 2008, at 5:16 PM, Sébastien Morin
          > > <sebastien.morin.> 1@ulaval.> ca> wrote:
          > >
          > >> Hi,
          > >>
          > >> I am currently trying to use autoFit.tcl with lots of spectra (i.e. 76).
          > >>
          > >> I used it before with success, but I get the error :
          > >>
          > >> ============> =========> =========> ======
          > >> Peak 155 of 155
          > >> Segmentation fault
          > >> XYZ2Pipe Partition: Plane 1 to 76 of 76
          > >> XY Plane 76 of 76
          > >> RdTable File open error: nlin.tab.
          > >> SimSpecND Error reading data table nlin.tab
          > >> ============> =========> =========> ======
          > >>
          > >> If I reduce the number of spectra to 60, it works fine. However, it
          > >> won't work with 61 spectra...
          > >>
          > >> I searched for a limit somewhere in the code, but could find one.
          > >>
          > >> Is there some hard coded limit for autoFit.tcl ?
          > >>
          > >> Thanks !
          > >>
          > >> Séb
          > >>
          > >>
          > >>
          > >

          >

        • Sébastien Morin
          Hi Ian I think this approach would be fine for many situations. However, in my case, it won t work... Nevertheless, thanks for suggesting this command as I
          Message 4 of 5 , May 2, 2008
            Hi Ian

            I think this approach would be fine for many situations. However, in my
            case, it won't work...

            Nevertheless, thanks for suggesting this command as I didn't know it
            existed... Maybe it will be useful for me in the near future !!

            Cheers,


            Sébastien




            IAN KLECKNER wrote:
            > For whatever its worth, instead of removing those spectra entirely from your analysis, you may consider using the "addNMR" command to combine their information (e.g. better S/N) and run the autoFit.tcl with the added spectra.
            >
            > I think this is legit, but please correct me if I am wrong.
            >
            > -Ian
            >
            > ----- Original Message -----
            > From: Sébastien Morin <sebastien.morin.1@...>
            > Date: Monday, April 28, 2008 4:51 pm
            > Subject: Re: [nmrpipe] autoFit.tcl with lots of spectra
            > To: nmrpipe@yahoogroups.com
            >
            > > Hi Frank,
            >
            >
            >> Thanks for the information.
            >>
            >
            >
            >> A cure is not critical..! I managed to trim my dataset without losing
            >> information.> .. I had a lot of duplicates out of these 76 points. 60
            >> being already a pretty high number of datapoints, I could take out some
            >> 16 superfluous duplicates..> .
            >>
            >
            >
            >> Thanks again and sorry for bothering with such an extravagant request !
            >>
            >
            >
            >> Séb :)
            >>
            >
            >
            >> Frank Delaglio wrote:
            >> >
            >> > Greetings, all ...
            >> >
            >> > Yes, I think we had an earlier post about this
            >> > too ... anyway, some lazy unimaginitive bastard
            >> > hard-coded a 64 parameter limit per signal.
            >> > In a 2D series, this would be enough for two
            >> > position parameters, two line width parameters,
            >> > and 60 amplitudes.
            >> >
            >> > If a cure is critical, contact big fd directly,
            >> > you can probably embarrass him into helping ...
            >> >
            >> > Cheerful regards
            >> >
            >> > F
            >> >
            >> > Sent from my iSmudge
            >> >
            >> > On Apr 25, 2008, at 5:16 PM, Sébastien Morin
            >> > <sebastien.morin.> 1@ulaval.> ca> wrote:
            >> >
            >> >> Hi,
            >> >>
            >> >> I am currently trying to use autoFit.tcl with lots of spectra (i.e. 76).
            >> >>
            >> >> I used it before with success, but I get the error :
            >> >>
            >> >> ============> =========> =========> ======
            >> >> Peak 155 of 155
            >> >> Segmentation fault
            >> >> XYZ2Pipe Partition: Plane 1 to 76 of 76
            >> >> XY Plane 76 of 76
            >> >> RdTable File open error: nlin.tab.
            >> >> SimSpecND Error reading data table nlin.tab
            >> >> ============> =========> =========> ======
            >> >>
            >> >> If I reduce the number of spectra to 60, it works fine. However, it
            >> >> won't work with 61 spectra...
            >> >>
            >> >> I searched for a limit somewhere in the code, but could find one.
            >> >>
            >> >> Is there some hard coded limit for autoFit.tcl ?
            >> >>
            >> >> Thanks !
            >> >>
            >> >> Séb
            >> >>
            >> >>
            >> >>
            >> >
            >>
            >
            > > <!-- #ygrp-mkp{ border: 1px solid #d8d8d8; font-family: Arial; margin: 14px 0px; padding: 0px 14px; } #ygrp-mkp hr{ border: 1px solid #d8d8d8; } #ygrp-mkp #hd{ color: #628c2a; font-size: 85%; font-weight: bold; line-height: 122%; margin: 10px 0px; } #ygrp-mkp #ads{ margin-bottom: 10px; } #ygrp-mkp .ad{ padding: 0 0; } #ygrp-mkp .ad a{ color: #0000ff; text-decoration: none; } --> <!-- #ygrp-sponsor #ygrp-lc{ font-family: Arial; } #ygrp-sponsor #ygrp-lc #hd{ margin: 10px 0px; font-weight: bold; font-size: 78%; line-height: 122%; } #ygrp-sponsor #ygrp-lc .ad{ margin-bottom: 10px; padding: 0 0; } --> <!-- #ygrp-mlmsg {font-size:13px; font-family: arial,helvetica,clean,sans-serif;*font-size:small;*font:x-small;} #ygrp-mlmsg table {font-size:inherit;font:100%;} #ygrp-mlmsg select, input, textarea {font:99% arial,helvetica,clean,sans-serif;} #ygrp-mlmsg pre, code {font:115% monospace;*font-size:100%;} #ygrp-mlmsg * {line-height:1.22em;} #ygrp-text{ font-family: Georgia; } #ygrp-text p{ margin: 0 0 1em 0; } #ygrp-tpmsgs{ font-family: Arial; clear: both; } #ygrp-vitnav{ padding-top: 10px; font-family: Verdana; font-size: 77%; margin: 0; } #ygrp-vitnav a{ padding: 0 1px; } #ygrp-actbar{ clear: both; margin: 25px 0; white-space:nowrap; color: #666; text-align: right; } #ygrp-actbar .left{ float: left; white-space:nowrap; } .bld{font-weight:bold;} #ygrp-grft{ font-family: Verdana; font-size: 77%; padding: 15px 0; } #ygrp-ft{ font-family: verdana; font-size: 77%; border-top: 1px solid #666; padding: 5px 0; } #ygrp-mlmsg #logo{ padding-bottom: 10px; } #ygrp-reco { margin-bottom: 20px; padding: 0px; } #ygrp-reco #reco-head { font-weight: bold; color: #ff7900; } #reco-grpname{ font-weight: bold; margin-top: 10px; } #reco-category{ font-size: 77%; } #reco-desc{ font-size: 77%; } #ygrp-vital{ background-color: #e0ecee; margin-bottom: 20px; padding: 2px 0 8px 8px; } #ygrp-vital #vithd{ font-size: 77%; font-family: Verdana; font-weight: bold; color: #333; text-transform: uppercase; } #ygrp-vital ul{ padding: 0; margin: 2px 0; } #ygrp-vital ul li{ list-style-type: none; clear: both; border: 1px solid #e0ecee; } #ygrp-vital ul li .ct{ font-weight: bold; color: #ff7900; float: right; width: 2em; text-align:right; padding-right: .5em; } #ygrp-vital ul li .cat{ font-weight: bold; } #ygrp-vital a{ text-decoration: none; } #ygrp-vital a:hover{ text-decoration: underline; } #ygrp-sponsor #hd{ color: #999; font-size: 77%; } #ygrp-sponsor #ov{ padding: 6px 13px; background-color: #e0ecee; margin-bottom: 20px; } #ygrp-sponsor #ov ul{ padding: 0 0 0 8px; margin: 0; } #ygrp-sponsor #ov li{ list-style-type: square; padding: 6px 0; font-size: 77%; } #ygrp-sponsor #ov li a{ text-decoration: none; font-size: 130%; } #ygrp-sponsor #nc{ background-color: #eee; margin-bottom: 20px; padding: 0 8px; } #ygrp-sponsor .ad{ padding: 8px 0; } #ygrp-sponsor .ad #hd1{ font-family: Arial; font-weight: bold; color: #628c2a; font-size: 100%; line-height: 122%; } #ygrp-sponsor .ad a{ text-decoration: none; } #ygrp-sponsor .ad a:hover{ text-decoration: underline; } #ygrp-sponsor .ad p{ margin: 0; } o{font-size: 0; } .MsoNormal{ margin: 0 0 0 0; } #ygrp-text tt{ font-size: 120%; } blockquote{margin: 0 0 0 4px;} .replbq{margin:4} -->
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.