Loading ...
Sorry, an error occurred while loading the content.

22173Re: [new_distillers] Re: Turbo Yeast Question?

Expand Messages
  • donald holcombe
    Oct 9, 2006
    • 0 Attachment
      Its the anthrax radiation biofilter thats killing the yeast.

      michael_fearn <michael_fearn@...> wrote: Hi Stevo,
      I took them right from the box they were shipped in and used them.
      Maybe it happened before i got them? Maybe Canada Post is just having
      fun with me and they microwaved everything before i got it. LOL

      --- In new_distillers@yahoogroups.com, "stevolate" <stevolate@...> wrote:
      > Hi Michael
      > If the packets got hot at any stage this kills the yeast.
      > Either with you or before you received them.
      > Happy drinking
      > Stevo
      > > The second package of yeast also did not work. Not a peep. Filtered
      > > water, 29Deg C, aeration for 24 hours. Nothing. I waited for a few
      > > days and then decided it was dead. It had all settled out and nothing
      > > was happening.
      > >
      > > So it turns out that my turbo yeast was in fact, bad. I pitched some
      > > Lavlin EC-1118 in the very same wash and now it is working fine. Oh
      > > well. Live and learn. Must have been a bad lot of Turbo 8kg.
      > >
      > > Thanks for the input.
      > > Cheers,
      > > Michael

      Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2ยข/min or less.

      [Non-text portions of this message have been removed]
    • Show all 25 messages in this topic