Loading ...
Sorry, an error occurred while loading the content.

Interface issue on Mac OS X 10.5.5

Expand Messages
  • ruebeckc
    I just started using NetLogo 4.0.3 after using 4.0.2 for a while. While using it within Mac OS X 10.5.5, I find that the arrow keys cause me to scroll while in
    Message 1 of 3 , Sep 30, 2008
    • 0 Attachment
      I just started using NetLogo 4.0.3 after using 4.0.2 for a while.

      While using it within Mac OS X 10.5.5, I find that the arrow keys
      cause me to scroll while in the Procedures tab, rather than simply
      moving the cursor down one line. In fact, the cursor doesn't even move.

      When I use shift-arrow, though, I get the correct functionality---the
      text from the current insertion point gets selected through to the
      line below it.

      Any clues to making the arrow keys move the insertion point instead of
      scrolling the window?

      Thanks!
    • Esther Verreau
      Hi - ... I noticed this on my computer just a few days ago. (very annoying!) I don t think it has anything to do with NetLogo. I think it s a bug in Java
      Message 2 of 3 , Oct 1, 2008
      • 0 Attachment
        Hi -

        On Wed, 1 Oct 2008, ruebeckc wrote:

        > I just started using NetLogo 4.0.3 after using 4.0.2 for a while.
        >
        > While using it within Mac OS X 10.5.5, I find that the arrow keys
        > cause me to scroll while in the Procedures tab, rather than simply
        > moving the cursor down one line. In fact, the cursor doesn't even move.
        >
        > When I use shift-arrow, though, I get the correct functionality---the
        > text from the current insertion point gets selected through to the
        > line below it.
        >
        > Any clues to making the arrow keys move the insertion point instead of
        > scrolling the window?
        >

        I noticed this on my computer just a few days ago. (very annoying!) I
        don't think it has anything to do with NetLogo. I think it's a bug in
        Java (iirc installed an update last week or so and the problem
        affects all versions of NetLogo even versions that I'm certain did not
        have this problem, bummer).

        I have not yet found a related bug report. However, I found that if I
        force NetLogo to use java 1.4.2 it works (1.5 and 1.6 both appear to be
        broken).

        To force NetLogo to use java 1.4.2:
        1. open /Applications/Utilities/Java/Java Preferences.
        2. find the section called, "Java application versions" in the "General"
        tab
        3. drag 1.4.2 to the top of the list.

        Of course, this affects all java programs so it's not an ideal solution.
        I'll let you know if I figure out anything better.

        thanks for the report,

        esther
      • ruebeckc
        Thanks, Esther, that fixed it for me. I did recently software-update to Java 1.6, and going back to 1.4.2 did the trick. I wouldn t have guessed this
        Message 3 of 3 , Oct 3, 2008
        • 0 Attachment
          Thanks, Esther, that fixed it for me. I did recently software-update to Java 1.6, and going
          back to 1.4.2 did the trick. I wouldn't have guessed this solution nor known how to
          choose the Java version to use!

          --- In netlogo-users@yahoogroups.com, Esther Verreau <everreau@...> wrote:
          >
          > Hi -
          >
          > On Wed, 1 Oct 2008, ruebeckc wrote:
          >
          > > I just started using NetLogo 4.0.3 after using 4.0.2 for a while.
          > >
          > > While using it within Mac OS X 10.5.5, I find that the arrow keys
          > > cause me to scroll while in the Procedures tab, rather than simply
          > > moving the cursor down one line. In fact, the cursor doesn't even move.
          > >
          > > When I use shift-arrow, though, I get the correct functionality---the
          > > text from the current insertion point gets selected through to the
          > > line below it.
          > >
          > > Any clues to making the arrow keys move the insertion point instead of
          > > scrolling the window?
          > >
          >
          > I noticed this on my computer just a few days ago. (very annoying!) I
          > don't think it has anything to do with NetLogo. I think it's a bug in
          > Java (iirc installed an update last week or so and the problem
          > affects all versions of NetLogo even versions that I'm certain did not
          > have this problem, bummer).
          >
          > I have not yet found a related bug report. However, I found that if I
          > force NetLogo to use java 1.4.2 it works (1.5 and 1.6 both appear to be
          > broken).
          >
          > To force NetLogo to use java 1.4.2:
          > 1. open /Applications/Utilities/Java/Java Preferences.
          > 2. find the section called, "Java application versions" in the "General"
          > tab
          > 3. drag 1.4.2 to the top of the list.
          >
          > Of course, this affects all java programs so it's not an ideal solution.
          > I'll let you know if I figure out anything better.
          >
          > thanks for the report,
          >
          > esther
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.