Loading ...
Sorry, an error occurred while loading the content.

RE: [mrrobot] Re: Problems downloading initial code to TJ-PRO

Expand Messages
  • Scott Jantz
    ... are you seeing the LEDs on the MB2325 board flash? Both of them? Also what Com port are you using and is it a USB based com port or are there any
    Message 1 of 4 , Dec 1, 2008
    View Source
    • 0 Attachment
      during the download:
      > > Synchronizing with board
      > > Pcode version 3.10 present on board
      > > Loading C:\ictjp\libs\lib_tjp.lis.
      > > Loading C:\ictjp\libs\lib_rw11.c.
      > > Loading C:\ictjp\libs\twoservo.icb.
      > > Loading C:\ictjp\libs\twoservo.c.
      > > Loading C:\ictjp\libs\motorp.c.
      > > Initializing interrupts
      > > Downloading 1588 bytes (addresses 8000-8633): 1588 loaded
      > > Downloading 101 bytes (addresses 8634-8698): 101 loaded
      > > Downloading 19 bytes (addresses 8699-86AB): 19 loaded
      > > Board synchronization error: sent 98, received 12
      > > errors

      are you seeing the LEDs on the MB2325 board flash? Both of them? Also what
      Com port are you using and is it a USB based com port or are there any
      interrupt conflicts.
      --Scott

      -----Original Message-----
      From: mrrobot@yahoogroups.com [mailto:mrrobot@yahoogroups.com]On Behalf
      Of robwaaser
      Sent: Saturday, November 22, 2008 5:05 PM
      To: mrrobot@yahoogroups.com
      Subject: [mrrobot] Re: Problems downloading initial code to TJ-PRO


      Ok so I checked my version of IC and I believe I have the commercial
      version (v3.2) as opposed to the freeware version (which is v2.8,
      correct?). I was confused because it came bundled with the robot. My
      mistake. Is there any other reason why this might be happening?


      --- In mrrobot@yahoogroups.com, robots2000@... wrote:
      >
      > It's probably because you are using the freeware version which is
      not
      > supported by the manufacture (or anyone).
      >
      > You can purchase the latest version of IC (MrRobot sells it for
      $19) and then use the following scheme:
      >
      > INSTALLATION
      >
      > 0. Unzip your tjpicw01.zip file.
      > 1. Install IC by executing the distribution icw32.exe. Follow
      directions.
      > Enter your name and
      > the 17-digit code when prompted for. Name your ic directory ictjp
      > during
      > installation.
      > 2. Rename your ic directory to ictjp, if you did not install it as
      such in
      > Step 1.
      > 3. Transfer the TJ PRO directory tjpcode into c:\ictjp
      > 4. Transfer ALL the files in Libtjp directory into the c:\ictjp\libs
      > DO NOT TRANSFER the directory Libtjp into libs!
      > 5. Download the IC pcoder as prescribed below.
      >
      >
      >
      > INSTRUCTIONS FOR DOWNLOADING THE IC pcoder IN WIN95
      >
      >
      > 1.Turn on the robot.
      >
      > 2. Place the DOWNLOAD/RUN toggle switch into DOWNLOAD.
      >
      > 3. From Windows execute IC.
      > IC will give an error message that the board is not responding. Not
      to
      > worry! The board is not responding because you have not had a chance
      > to load
      > the p-coder and relevant libraries into the robot. Select the Yes
      > button in
      > the IC error Window to configure the board.
      >
      > 4. The system is configured to enable COM1 for serial communication.
      > If you wish to use another COM port select it on the screen that now
      > appears. To make your selection the default, you will need to
      change the
      > Port = 1 command in the ic.ini file to Port = n, where n is the COM
      port
      > number you picked.
      >
      > 5. Select the Download Pcode button in the opened IC Window.
      > IC will now open the Libs directory.
      >
      > 6. Select the file TJ-pro.icd file to open.
      >
      > 7. Press the red RESET button on the robot.
      >
      > 8. Select the OK button in the window.
      > You will observe a flurry of loading activity with the green LEDs
      on the
      > MB2325 board rapidly flashing.
      >
      > IC will prompt you to perform Steps 9 and 10.
      >
      > 9. Switch the robot DOWNLOAD/RUN toggle switch to RUN.
      >
      > 10. Press the red RESET button.
      >
      > IC will then load the remaining library files onto the robot and
      you are
      > ready to go.
      >
      > IMPORTANT!
      >
      > As long as you keep the batteries charged and connected to the robot
      > controller, the p-coder will not have to be reloaded and you can
      turn the
      > power switch on-and-off at will. You can also exit and restart IC
      with a
      > simple invokation. For example, suppose you exit IC and then wish to
      > restart
      > later. Just turn the robot power on, put it in run mode and then
      > execute IC.
      > That's all there is to it!
      >
      > If the batteries drain or are disconnected or you otherwise
      overwrite
      > memory
      > you will have to repeat the first time load procedure described
      above.
      >
      >
      >
      >
      >
      >
      >
      >
      > --- In mrrobot@yahoogroups.com, "robwaaser" <robwaaser@> wrote:
      > >
      > > Hi,
      > >
      > > I just bought a TJ-Pro and I am having problems loading the
      initial
      > > code onto the robot. Upon installing the Interactive C freeware
      and
      > > attempting to follow the instructions for loading the bootstrap
      code,
      > > etc this is what happens:
      > >
      > >
      > > I start IC and there is an error message. I connect the robot. The
      > > MB2325 red diode lights up and stays on when I reset the robot in
      > > download mode. I follow the prompt to configure the board and to
      > > select the com port and press Download Pcode. I select the TJ-
      PRO.ic
      > > file and hit ok. This happens:
      > >
      > > Please find the definition file that matches your board type.
      > > Downloading bootstrap code to the board (256 bytes)
      > > Downloading bootstrap code to the board (256 bytes)
      > > Bootstrap load successful.
      > > Downloading the pcode to the board... this may take a while.
      > > Download complete.
      > >
      > > The next error message appears telling me to reset the board in
      run
      > > mode. I do so and click "OK". This happens:
      > >
      > > Synchronizing with board
      > > Pcode version 3.10 present on board
      > > Loading C:\ictjp\libs\lib_tjp.lis.
      > > Loading C:\ictjp\libs\lib_rw11.c.
      > > Loading C:\ictjp\libs\twoservo.icb.
      > > Loading C:\ictjp\libs\twoservo.c.
      > > Loading C:\ictjp\libs\motorp.c.
      > > Initializing interrupts
      > > Downloading 1588 bytes (addresses 8000-8633): 1588 loaded
      > > Downloading 101 bytes (addresses 8634-8698): 101 loaded
      > > Downloading 19 bytes (addresses 8699-86AB): 19 loaded
      > > Board synchronization error: sent 98, received 12
      > > errors
      > >
      > > An error message appears telling me "Board error. Retry?". If I
      click
      > > retry the same thing happens:
      > >
      > > Initializing interrupts
      > > Downloading 1588 bytes (addresses 8000-8633): 1588 loaded
      > > Downloading 101 bytes (addresses 8634-8698): 101 loaded
      > > Downloading 19 bytes (addresses 8699-86AB): 19 loaded
      > > Board synchronization error: sent 98, received 12
      > > errors
      > >
      > > I have no idea what this means and cannot seem to get past this
      > > error, and its always the exact same one. Can anyone tell me how
      to
      > > resolve this issue?
      > >
      > >
      > > Thanks in advance
      > >
      >



      ------------------------------------

      Yahoo! Groups Links
    Your message has been successfully submitted and would be delivered to recipients shortly.