Loading ...
Sorry, an error occurred while loading the content.

Logging loops with mod_perl1/apache1/amd64

Expand Messages
  • Michael Renner
    Hi, I m seeing strange logging loops with apache 1.3.34/mod_perl 1.29/perl 5.8.7 running on amd64 on debian testing. First I thought it might be related to
    Message 1 of 1 , Oct 25, 2005
    • 0 Attachment
      Hi,

      I'm seeing strange logging loops with apache 1.3.34/mod_perl 1.29/perl 5.8.7
      running on amd64 on debian testing. First I thought it might be related to
      changes in DBD::Pg or DBI but downgrading those to the identical versions of
      a working setup prooved unsuccessful. Also finding an SQL-unrelated error
      looping (although less-fatal than the SQL errors) might prove this theory
      wrong. The only differences I'm seeing between the setups are Perl (5.8.4),
      glibc (2.3.2 vs. 2.3.5) and used compiler-versions.

      Sample error-log entries can be found at http://phpfi.com/83864 (offlist for
      the sake of line-wrappings)

      The errors seem to be related to "dirty" childs; I've written a sample
      script with warnings enabled that tries to print an undefined variable. On
      "virgin" childs this doesn't cause any loops, but when reloading it after
      mod_perl has done some work causes a logging loop after a few tries.

      Do you have any ideas what might cause this or what else I should test?

      --

      best regards,
      Michael Renner - Network services

      Preisvergleich Internet Services AG
      Obere Donaustra├če 63/2, A-1020 Wien
      Tel: +43 1 5811609 80
      Fax: +43 1 5811609 55
    Your message has been successfully submitted and would be delivered to recipients shortly.